Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 42661 - yelp dependency on =gnome-extra/libgtkhtml-2* is incorrect
Summary: yelp dependency on =gnome-extra/libgtkhtml-2* is incorrect
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2004-02-23 15:28 UTC by Joel Martin (RETIRED)
Modified: 2004-02-24 02:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Joel Martin (RETIRED) gentoo-dev 2004-02-23 15:28:02 UTC
During yelp's configure, it complained stating that yelp required
libgtkhtml >= 2.1.2.

I don't have exact output because I upgraded libgtkhtml and the error scrolled
off the screen and don't have an ebuild for older than 2.1.2 anymore to 
reproduce it easily.

This is a one line change to yelp 2.4.2 ebuild:
RDEPEND =gnome-extra/libgtkhtml-2* 
becomes >=gnome-extra/libgtkhtml-2.1.2

Reproducible: Always
Steps to Reproduce:
Comment 1 Yi Quang (RETIRED) gentoo-dev 2004-02-23 15:53:53 UTC
Is this a problem since the oldest libgtkhtml package is 2.2.1 in portage? If i remember correctly ebuilds are supposed to try and always use major revisions right?
Comment 2 Spider (RETIRED) gentoo-dev 2004-02-23 16:03:51 UTC
theres an interesting headache here as you cant do the >= since it won't build against libgtkhtml 3.x series....
Comment 3 Spider (RETIRED) gentoo-dev 2004-02-23 16:04:27 UTC
theres an interesting headache here as you cant do the >= since it won't build against libgtkhtml 3.x series....

now where the heck are those SLOT dependencies we've wanted for two years?
Comment 4 Joel Martin (RETIRED) gentoo-dev 2004-02-23 17:28:27 UTC
Here is the reason why I ran into this. I have stopped using gnome and removed
"gnome" from my world file so my gnome stuff is becoming old and out of date,
however I still had gnome in my USE flags. I got this error when upgrading
xscreensaver. I got around the problem by using "-gnome". If I upgraded all my
gnome packages this would go away too, but I really don't care to.

As the original submitter I'm comfortable with just closing this.
Comment 5 Alastair Tse (RETIRED) gentoo-dev 2004-02-24 00:47:21 UTC
dunno, but its not something that is in our hands. i'll close this as CANTFIX for now.
Comment 6 foser (RETIRED) gentoo-dev 2004-02-24 02:11:23 UTC
'the 'fix' gtkhtml deps' in the ChangeLog on bumping to 2.4.0 refers to this problem. Guess i should write more descriptive stuff. And yes the oldest libgtkhtml in the tree at that time was 2.2.x or something, but theoretically there still could be trouble with users on systems not updated for a long time.