Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 426260 - net-misc/x2goserver - x2go loses the applications menu under gnome
Summary: net-misc/x2goserver - x2go loses the applications menu under gnome
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-12 05:41 UTC by xenon.kay
Modified: 2016-01-24 23:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xenon.kay 2012-07-12 05:41:17 UTC
Upon logging in to an x2go gnome session from a remote Windows XP box, I found that the Applications menu would not show up. It would highlight when selected but nothing would drop down.

At first I suspected the client, but after trying different versions on different platforms (XP, Windows 7, Ubuntu) I found that they all exhibited the same problem.

I've verified that x2go has an applications symlink in /etc/x2go pointing to /usr/share/applications and that both are readable.

I can't seem to find any sort of error message in either the system or session logs that might provide a clue as to the cause, even with the log level set to debug.

Nothing else seems to be affected. The System and Places menus appear as they should, I can launch any installed application manually and all I've tried work normally. I can even add launchers to the panel and those will work.

I've also installed nxserver-freenx and verified proper operation using a Windows NX client. The applications menu appears normally if I use nx server/client instead of x2go.

Could x2go actually be looking in the wrong place for the menu?

The issue may affect other WMs but I have no others installed in order to verify this.

Reproducible: Always

Steps to Reproduce:
1. Log in from a remote machine using x2go with a gnome session
2. Attempt to open the applications menu on the panel

Actual Results:  
No menu appears.

Expected Results:  
The application menu should drop down.
Comment 1 Bernard Cafarelli gentoo-dev 2012-07-17 08:38:38 UTC
Gnome 3 I guess? There are comments (mostly on Ubuntu) that the default session with its 3d thingies) could cause a problem like that:
http://www.nomachine.com/tr/view.php?id=TR10I02623

Have you tried with a custom session sarting gnome fallback? (the 2D-only one)
Also it may be worth trying with a new clean user, just in case

The applications symlink in /etc/x2go should not matter, it is only used for the "published applications" session type
Comment 2 xenon.kay 2012-07-17 18:04:16 UTC
Gnome 2.32 actually. I haven't switched to Gnome 3 and don't use any 3D desktop compositing since sessions on this machine are primarily remote.

I did try creating a session with a brand new user, but it exhibited the same issue.