Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 425708 - dev-lang/R-2.10.1 - R: stack smashing attack in function <unknown> - terminated
Summary: dev-lang/R-2.10.1 - R: stack smashing attack in function <unknown> - terminated
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Denis Dupeyron
URL:
Whiteboard:
Keywords:
Depends on: 437508
Blocks:
  Show dependency tree
 
Reported: 2012-07-10 16:57 UTC by myhrlin
Modified: 2014-01-15 12:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Error: emerge -q dev-lang/R (file_425708.txt,148.19 KB, text/plain)
2012-07-10 16:57 UTC, myhrlin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description myhrlin 2012-07-10 16:57:24 UTC
Created attachment 317826 [details]
Error: emerge -q dev-lang/R

When attempting to install dev-lang/R-2.10.1 I received the error attached.  When reported to #gentoo-science I was asked to file a bug.

# emerge -pvq dev-lang/R

[ebuild  N    ] dev-lang/R-2.10.1  USE="X cairo doc java jpeg lapack nls perl png readline threads tk -bash-completion -minimal"


# emerge --info dev-lang/R

Portage 2.1.11.5 (hardened/linux/amd64, gcc-4.5.3, glibc-2.14.1-r3, 3.4.2-hardened-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.4.2-hardened-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T6600_@_2.20GHz-with-gentoo-2.1
Timestamp of tree: Mon, 09 Jul 2012 13:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2  -msse4.1 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.d
at.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2  -msse4.1 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirror2.corbina.ru/gentoo-distfiles/ http://mirror.yandex.ru/gentoo-distfiles/ ftp://mirror.yandex.ru/gentoo-distfiles/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="af ar ca cs da de el eo es fa fi fr hr hu hy id it ja ko lt mk nb nl pl pt pt_BR ro ru sk sl sr sv tr uk vi en gd ga hi is he rw sa_IN sh zh_CN zh_TW"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync4.ru.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 animgif berkdb bzip2 cdio cli cracklib crypt cups cxx dmx doc dri embed enchant fileinfo filter fpm gdbm gimp glamor gpm grub gtk hardened hash icons iconv intl ipv6 json justify kdrive ldap-sasl mhash mmx modules mp3 mudflap multilib mysqlnd ncurses nls nptl opengl openmp openssl pam pax_kernel pcre perl pppd readline session smp sna sse sse2 ssl ssse3 suhosin synaptics tcpd tools unicode urandom xinerama xml xmlreader xmlwriter xnest xorg xsl xvfb zip zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="af ar ca cs da de el eo es fa fi fr hr hu hy id it ja ko lt mk nb nl pl pt pt_BR ro ru sk sl sr sv tr uk vi en gd ga hi is he rw sa_IN sh zh_CN zh_TW" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Denis Dupeyron gentoo-dev 2012-07-12 19:58:57 UTC
Thanks for this bug report.

I don't have a spare machine to install gentoo hardened on or enough space on my hard drive to install it in a vm to try and reproduce this.

I saw on irc that you tried installing R-2.15.1 on your setup and that it worked. Since 2.10.1 is rather old and we're currently aiming at stabilizing 2.15.1 in the (hopefully) short term, I think we'll just do that and remove 2.10.1 when that happens.

What do you guys think?

Denis.
Comment 2 myhrlin 2012-07-13 02:27:12 UTC
(In reply to comment #1)
> I saw on irc that you tried installing R-2.15.1 on your setup and that it
> worked. Since 2.10.1 is rather old and we're currently aiming at stabilizing
> 2.15.1 in the (hopefully) short term, I think we'll just do that and remove
> 2.10.1 when that happens.
> 
> What do you guys think?

I think that's excellent.  I didn't realize R-2.10.1 was a much older version and R-2.15.1 installed and works fine.

The replacement, for whenever 2.15.1 is ready, sounds great too.
Comment 3 Justin Lecher gentoo-dev 2014-01-15 12:18:49 UTC
+  15 Jan 2014; Justin Lecher <jlec@gentoo.org> -R-2.10.1.ebuild,
+  -R-2.15.3.ebuild:
+  Drop old; fixes #478572 (EAPI <4 should be removed), #476010 & #476008
+  (Respect AR and LDFLAGS), #438544 (Installation Problems with version 2),
+  #425708 (stack smashing)
+