Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 42548 - bridge-utils fails compile, but installs anyway
Summary: bridge-utils fails compile, but installs anyway
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High major (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2004-02-22 22:40 UTC by Rajiv Aaron Manglani (RETIRED)
Modified: 2004-06-21 13:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rajiv Aaron Manglani (RETIRED) gentoo-dev 2004-02-22 22:40:04 UTC
during emerge net-misc/bridge-utils-0.9.6:

gcc -Wall -g -I/usr/src/linux/include  -c libbridge_misc.c
libbridge_misc.c: In function `__tv_to_jiffies':
libbridge_misc.c:33: error: `HZ' undeclared (first use in this function)
libbridge_misc.c:33: error: (Each undeclared identifier is reported only once
libbridge_misc.c:33: error: for each function it appears in.)
libbridge_misc.c: In function `__jiffies_to_tv':
libbridge_misc.c:40: error: `HZ' undeclared (first use in this function)
make[1]: *** [libbridge_misc.o] Error 1

the ebuild continues and is 'successful' but only the docs and man pages are installed. none
of the binaries are built or installed.

this is with aa-sources 2.4.23-r1 ... oddly enough, if i 'rm /usr/src/linux' (the symlink) then
'emerge bridge-utils', the compile works and i get the binaries!

Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.4.23-aa1)
System uname: 2.4.23-aa1 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version
distcc 2.11.1 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.58
Automake: sys-devel/automake-1.7.7
CFLAGS="-march=athlon-xp -O3 -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=athlon-xp -O3 -pipe"
FEATURES="autoaddcvs buildpkg ccache sandbox"
USE="3dnow X alsa apache2 apm avi berkdb cdr crypt cups curl dvd emacs encode ethereal foomaticdb gd gdbm gif gtk gtk2 imap imlib innodb java jikes jpeg ldap libg++ libwww mad maildir mbox mmx motif mozilla mpeg mysql ncurses oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sasl sdl slang slp spell sse ssl svga tcltk tiff truetype x86 xml xml2 xmms xv xvid zlib"
Comment 1 Patrick Kursawe (RETIRED) gentoo-dev 2004-02-24 23:42:21 UTC
I can't reproduce your problem, I guess your linux symlink pointed to some invalid directory before - but nevertheless it should not have installed, so I added an additional check now that makes it die if brctl and brctld are not found. Thanks for reporting this.
Comment 2 Patrick Kursawe (RETIRED) gentoo-dev 2004-02-25 08:37:55 UTC
rajiv said the problem persists, and I don't understand why I can't reproduce it, then...
Comment 3 Patrick Kursawe (RETIRED) gentoo-dev 2004-02-25 08:38:40 UTC
... so this goes back to the kernel experts. Sorry.
Comment 4 Jason Cox (RETIRED) gentoo-dev 2004-04-13 21:17:34 UTC
Have you tried this with a newer kernel? What version of linux-headers do you have installed?
Comment 5 Jason Cox (RETIRED) gentoo-dev 2004-04-16 17:30:59 UTC
This has gone stale. He's been away for too long for this bug to reamin open.
Comment 6 Rajiv Aaron Manglani (RETIRED) gentoo-dev 2004-04-18 00:41:16 UTC
just upgraded to aa-sources 2.4.23-aa2. tried again with the bridge-utils-0.9.6-r1 ebuild, and the
same thing is happening. there are several make errors, but the ebuild continues and is supposedly
'successful' yet no binaries are installed.

the changelog says that the emerge of bridge-utils-0.9.6-r1 should fail if an error happens, but it
keeps going.

as for the HZ error, i think bridge-utils does not work with aa-sources or other kernels which have
variable HZ. if i rm /usr/src/linux, the ebuild compiles just fine and i get the binaries (is it getting
the headers from some other place in that case?). however, the system locks up under heavy network
load, so i'm guessing that the binaries are not compatible somehow.

the machine has linux-headers-2.4.21-r1 installed. 

i think 2 things should happen here:

the ebuild should fail if an error occurs.
the ebuild should block on ebuilds of kernels which have variable HZ (namely aa-sources), or at least
an error/warning should be printed out.

(that is, we should give up on trying to make bridge-utils work with aa-sources.)

Comment 7 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-06-21 13:09:06 UTC
Closing as this is not a kernel bug, and the -aa 2.4 kernel is not supported