Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 424970 - sys-devel/gcc-4.6.3 with sys-libs/glibc-2.16.0 - In function ‘x86_fallback_frame_state’: /var/tmp/portage/sys-devel/gcc-4.6.3/work/gcc-4.6.3/libgcc/../gcc/config/i386/linux-unwind.h:138:17: error: field ‘info’ has incomplete type
Summary: sys-devel/gcc-4.6.3 with sys-libs/glibc-2.16.0 - In function ‘x86_fallback_fr...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 444234 445071 524628 (view as bug list)
Depends on: 427220
Blocks: glibc-2.16
  Show dependency tree
 
Reported: 2012-07-05 19:28 UTC by Chris Smith
Modified: 2016-01-12 18:53 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
requested build log (gcc-4.6.3-build.log,844.11 KB, text/plain)
2012-07-06 14:46 UTC, Chris Smith
Details
patch for gcc-3.4.6-r2 (gentoo424970.patch,4.15 KB, patch)
2012-12-29 20:11 UTC, Martin von Gagern
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Smith 2012-07-05 19:28:38 UTC
After upgrading to sys-libs/glibc-2.16.0, attempts to recompile sys-devel/gcc-4.6.3 fail.

Reproducible: Always

Actual Results:  
In file included from /var/tmp/portage/sys-devel/gcc-4.6.3/work/gcc-4.6.3/libgcc/../gcc/unwind-dw2.c:334:0:
/var/tmp/portage/sys-devel/gcc-4.6.3/work/gcc-4.6.3/libgcc/../gcc/config/i386/linux-unwind.h: In function ‘x86_fallback_frame_state’:
/var/tmp/portage/sys-devel/gcc-4.6.3/work/gcc-4.6.3/libgcc/../gcc/config/i386/linux-unwind.h:138:17: error: field ‘info’ has incomplete type
make[5]: *** [unwind-dw2.o] Error 1
make[5]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.6.3/work/build/x86_64-pc-linux-gnu/32/libgcc'
make[4]: *** [multi-do] Error 1
make[4]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.6.3/work/build/x86_64-pc-linux-gnu/libgcc'
make[3]: *** [all-multi] Error 2
make[3]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.6.3/work/build/x86_64-pc-linux-gnu/libgcc'
make[2]: *** [all-stage1-target-libgcc] Error 2
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.6.3/work/build'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.6.3/work/build'
make: *** [bootstrap-lean] Error 2
emake failed



emerge --info
Portage 2.2.0_alpha116 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.16.0, 3.4.4-gentoo x86_64)
=================================================================
System uname: Linux-3.4.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Thu, 05 Jul 2012 17:45:01 +0000
app-shells/bash:          4.2_p29
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5, 1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo tcg-desktop tcg-server mythtv
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -fomit-frame-pointer -pipe -floop-interchange -floop-strip-mine -floop-block"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -fomit-frame-pointer -pipe -floop-interchange -floop-strip-mine -floop-block"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/ http://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ ftp://chi-10g-1-mirror.fastsoft.net/pub/linux/gentoo/gentoo-distfiles/ ftp://mirrors.rit.edu/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en"
MAKEOPTS="V=1 -j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/tcg_desk /usr/local/portage/tcg_server /usr/local/mythtv_portage/Gentoo"
SYNC="rsync://rsync11.us.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 amr apache2 audiofile bash-completion berkdb bluetooth bzip2 cairo caps cdaudio cddb cdparanoia cdr cdrdao chm cli consolekit cracklib crypt cups curl cxx dbus designer-plugin djvu dri dts dv dvb dvd dvdr ebook encode exif fam ffmpeg flac fortran gdbm gif gmp gnome gphoto2 gpm gps graphite gstreamer gtk gtk3 iconv icu ieee1394 imagemagick imap imlib ipv6 jack java jpeg jpeg2k kpathsea lame lcms libffi libnotify mad marble midi mmap mmx modules mozilla mp3 mudflap multilib musicbrainz mythtv ncurses network nls nodrm nptl nsplugin nvidia ofx ogg opencl openexr opengl openmp pam pcre pdf png policykit pulseaudio quicktime readline samba sasl scanner sdl semantic-desktop session slp smp sndfile spell sse sse2 ssl subversion svg theora threads tiff tk transparency truetype udev unicode usb v4l vcd vdpau vim-syntax vorbis vpx wav wavpack wmf x264 xattr xcomposite xine xml xorg xscreensaver xv xvid xvmc zlib" ALSA_CARDS="hda-intel hdsp hpet hrtimer rtctimer seqdummy virmidi" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_US en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2012-07-06 14:31:10 UTC
Please attach the entire build log to this bug report.
Comment 2 Chris Smith 2012-07-06 14:46:04 UTC
Created attachment 317438 [details]
requested build log
Comment 3 SpanKY gentoo-dev 2012-07-23 15:07:22 UTC
i've backported the fix from upstream to 4.5.[0-3] and 4.6.[0-3], and pushed it out into current 4.6.3 release (since 4.5.4 was already released with the fix).

http://sources.gentoo.org/gentoo/src/patchsets/gcc/4.6.3/gentoo/05_all_gcc-4.6.x-siginfo.patch?rev=1.1
Comment 4 SpanKY gentoo-dev 2012-07-23 15:09:27 UTC
should be all set now in the tree; thanks for the report!

Commit message: Fix building with glibc-2.16
http://sources.gentoo.org/sys-devel/gcc/gcc-4.6.3.ebuild?r1=1.9&r2=1.10
Comment 5 SpanKY gentoo-dev 2012-11-24 21:23:59 UTC
*** Bug 444234 has been marked as a duplicate of this bug. ***
Comment 6 SpanKY gentoo-dev 2012-11-24 22:38:41 UTC
also added to 4.3.x and 4.4.x
Comment 7 SpanKY gentoo-dev 2012-11-28 18:15:45 UTC
*** Bug 445071 has been marked as a duplicate of this bug. ***
Comment 8 Justin Lecher gentoo-dev 2012-11-28 18:46:00 UTC
(In reply to comment #7)
> *** Bug 445071 has been marked as a duplicate of this bug. ***

So could you please backport it to 4.1 too? I have a binary package depending on that version.
Comment 9 SpanKY gentoo-dev 2012-11-29 01:23:33 UTC
added to 4.1.2 too
Comment 10 SpanKY gentoo-dev 2012-11-29 05:03:34 UTC
and 4.2.4
Comment 11 Justin Lecher gentoo-dev 2012-11-29 07:01:02 UTC
Thanks for the quick fix.
Comment 12 Martin von Gagern 2012-12-29 20:11:30 UTC
Created attachment 333704 [details, diff]
patch for gcc-3.4.6-r2

gcc-3.4.6-r2 is affected by this as well. The patch from comment #3 won't apply, but it's essence is a simple 's/struct siginfo/siginfo_t/g' so I did a little sed on the 3.4.6 sources to create this patch.
Comment 13 SpanKY gentoo-dev 2013-01-08 15:26:18 UTC
also added to:
3.3.6
3.4.6
4.0.4
Comment 14 Ryan Hill (RETIRED) gentoo-dev 2014-07-11 01:24:21 UTC
*** Bug 516276 has been marked as a duplicate of this bug. ***
Comment 15 SpanKY gentoo-dev 2014-10-17 17:32:22 UTC
*** Bug 524628 has been marked as a duplicate of this bug. ***