Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 424801 - circular dependencies between dbus and glib
Summary: circular dependencies between dbus and glib
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-04 20:39 UTC by Demetr
Modified: 2012-07-04 20:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Demetr 2012-07-04 20:39:17 UTC
* Error: circular dependencies:

(sys-apps/dbus-1.4.20::gentoo, ebuild scheduled for merge) depends on
 (dev-libs/glib-2.30.3::gentoo, ebuild scheduled for merge) (buildtime)
  (sys-apps/dbus-1.4.20::gentoo, ebuild scheduled for merge) (buildtime)



Reproducible: Always

Steps to Reproduce:
1.emerge dbus or glib
2.
3.
Comment 1 Samuli Suominen gentoo-dev 2012-07-04 20:50:35 UTC
Only if you enable USE="test" prematurarely. The flag is, among other flags, like USE="doc", is known to cause termorary circular dependencies.

*** This bug has been marked as a duplicate of bug 175808 ***
Comment 2 Samuli Suominen gentoo-dev 2012-07-04 20:51:04 UTC
Meant FEATURES="test" in last comment (which enables USE="test")