Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 424751 - net-p2p/qbittorrent fails with parallel make: fatal error: ui_propertieswidget.h: No such file or directory
Summary: net-p2p/qbittorrent fails with parallel make: fatal error: ui_propertieswidge...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor with 1 vote (vote)
Assignee: Markos Chandras (RETIRED)
URL: https://bugs.launchpad.net/qbittorren...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-04 11:46 UTC by Wonko
Modified: 2017-03-26 10:02 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (net-p2p:qbittorrent-2.9.11:20120704-071450.log,31.45 KB, text/plain)
2012-07-04 11:46 UTC, Wonko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wonko 2012-07-04 11:46:00 UTC
Created attachment 317119 [details]
build log

Fails to build (multiple times) with MAKEOPTS="--jobs --load 5", build fine with MAKEOPTS=-j1. I wasn't able to reproduce this with 5, 10 or 20 parallel jobs. I see this with some other packages as well, they fail with --load, but build fine with a fixed number of parallel jobs.


Portage 2.2.0_alpha115 (default/linux/amd64/10.0/desktop/kde, gcc-4.6.3, glibc-2.15-r2, 3.4.4-gentoo x86_64)                                                                                                                                                                   
=================================================================                                                                                                                                                                                                              
                         System Settings                                                                                                                                                                                                                                       
=================================================================                                                                                                                                                                                                              
System uname: Linux-3.4.4-gentoo-x86_64-AMD_FX-tm-4100_Quad-Core_Processor-with-gentoo-2.1                                                                                                                                                                                     
Timestamp of tree: Wed, 04 Jul 2012 05:45:01 +0000                                                                                                                                                                                                                             
distcc 3.1 x86_64-pc-linux-gnu [disabled]                                                                                                                                                                                                                                      
ccache version 3.1.7 [disabled]                                                                                                                                                                                                                                                
app-shells/bash:          4.2_p29                                                                                                                                                                                                                                              
dev-java/java-config:     2.1.12                                                                                                                                                                                                                                               
dev-lang/python:          2.6.8, 2.7.3-r2, 3.2.3-r1                                                                                                                                                                                                                            
dev-util/ccache:          3.1.7                                                                                                                                                                                                                                                
dev-util/cmake:           2.8.8-r3                                                                                                                                                                                                                                             
dev-util/pkgconfig:       0.26                                                                                                                                                                                                                                                 
sys-apps/baselayout:      2.1-r1                                                                                                                                                                                                                                               
sys-apps/openrc:          0.10.4                                                                                                                                                                                                                                               
sys-apps/sandbox:         2.6                                                                                                                                                                                                                                                  
sys-devel/autoconf:       2.13, 2.69                                                                                                                                                                                                                                           
sys-devel/automake:       1.9.6-r3, 1.11.5, 1.12.1                                                                                                                                                                                                                             
sys-devel/binutils:       2.22-r1                                                                                                                                                                                                                                              
sys-devel/gcc:            4.4.7, 4.5.3-r2, 4.6.3                                                                                                                                                                                                                               
sys-devel/gcc-config:     1.7.3                                                                                                                                                                                                                                                
sys-devel/libtool:        2.4.2                                                                                                                                                                                                                                                
sys-devel/make:           3.82-r3                                                                                                                                                                                                                                              
sys-kernel/linux-headers: 3.4 (virtual/os-headers)                                                                                                                                                                                                                             
sys-libs/glibc:           2.15-r2                                                                                                                                                                                                                                              
Repositories: gentoo zugaina nx kde enlightenment emacs dfreise proaudio science gamerlay-stable xarthisius sunrise local                                                                                                                                                      
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                                                                                                                                                                                 
ACCEPT_LICENSE="* -@EULA"                                                                                                                                                                                                                                                      
CBUILD="x86_64-pc-linux-gnu"                                                                                                                                                                                                                                                   
CFLAGS="-pipe -march=amdfam10 -O2          -floop-interchange -floop-strip-mine -floop-block          -msse -msse2 -msse3 -msse4a -msse4.1 -msse4.2 -m3dnow          -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx          --param l1-cache-size=16          --param l1-cache-line-size=64          --param l2-cache-size=2048"                                                                                                                                                                                                                    
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /usr/share/X11/xkb /usr/share/openvpn/easy-rsa"
CXXFLAGS="-pipe -march=amdfam10 -O2          -floop-interchange -floop-strip-mine -floop-block          -msse -msse2 -msse3 -msse4a -msse4.1 -msse4.2 -m3dnow          -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx          --param l1-cache-size=16          --param l1-cache-line-size=64          --param l2-cache-size=2048"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --with-bdeps y --load-average=6.0"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg buildsyspkg collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://mirror.netcologne.de/gentoo/ http://gentoo.mneisen.org/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="de_DE.utf8"
LC_ALL="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="--jobs --load 5"
PKGDIR="/var/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/portage/tmpfs"
PORTDIR="/var/portage/tree"
PORTDIR_OVERLAY="/var/portage/layman/zugaina /var/portage/layman/nx /var/portage/layman/kde /var/portage/layman/enlightenment /var/portage/layman/emacs /var/portage/layman/dfreise /var/portage/layman/pro-audio /var/portage/layman/science /var/portage/layman/gamerlay /var/portage/layman/xarthisius /var/portage/layman/sunrise /var/portage/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib acl acpi aim alsa amd64 apache2 apm audiofile bash-completion bcmath berkdb bluetooth branding bzip2 cairo calendar cdda cdparanoia cdr cli consolekit cracklib crypt ctype cups cvs cxx dbus declarative dga directfb dri dts dvb dvd dvdr emacs emboss encode exif fam fbcon ffmpeg firefox flac foomaticdb fortran ftp gd gdbm ggi gif gimp ginac git gnutls gphoto2 gpm gtk handbook hddtemp iconv icu ieee1394 imagemagick imlib ipv6 jabber jack java javascript jbig jpeg jpeg2k kde kipi latex lcms ldap libnotify lm_sensors lzma mad maildir matroska matrox mikmod mime mmx mng modplug modules motif mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz nas ncurses nls nptl nsplugin ogg openal opengl openmp oss pam pango pch pcre pdf phonon php plasma plotutils png policykit ppds pppd qt3support qt4 quicktime radius rdesktop readline recode ruby samba scanner sdl semantic-desktop session slang slp smp sndfile sockets sox speex spell sse sse2 sse3 ssl startup-notification subversion svg tcpd theora threads tiff truetype udev udisks unicode upower usb videos vim-syntax visualization vnc vorbis wma wmf wxwidgets wxwindows x264 xattr xcb xcomposite xine xinerama xml xorg xosd xpm xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="cgi alias auth_basic authn_file authz_groupfile authz_host authz_owner authz_user dir mime userdir" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FRITZCAPI_CARDS="fcpci" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" LIRC_DEVICES="serial" MISDN_CARDS="avmfritz" PHP_TARGETS="php5-3 php5-4" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="canon_pp microtek plustek_pp" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

net-p2p/qbittorrent-2.9.11 was built with the following:
USE="X (consolekit) dbus (multilib) (policykit) -geoip"
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2012-07-05 19:21:34 UTC
I can't reproduce it with -j7. Could you open a bug upstream?
Comment 2 Wonko 2012-07-06 15:46:46 UTC
Neither can I, it only happens with --load=5, and is reproducible. I do not have an explanation for this.

Anyway, I filed the bug here:
https://bugs.launchpad.net/qbittorrent/+bug/1021789
Comment 3 Davide Pesavento gentoo-dev 2012-10-04 01:52:18 UTC
I can reproduce with your exact MAKEOPTS and 2.9.11, while 3.0.5 fails in the same way but on a different missing file.
Comment 4 Markos Chandras (RETIRED) gentoo-dev 2013-10-16 20:14:07 UTC
I did a few builds with

MAKEOPTS="--jobs --load 5" emerge qbittorrent

on the 3.1.0 package.

I was not able to reproduce it. If you still have problems please re-open the bug
Comment 5 Thomas Capricelli 2013-12-05 23:54:58 UTC
Hello. Just got it by this bug, 3 times in a row, trying to emerge net-p2p/qbittorrent-3.1.3 on a very typical ~amd64 system

Each time i got :

-----------------------------------------------------------------------------
...

x86_64-pc-linux-gnu-g++ -c -march=native -pipe -O2 -Wformat -Wformat-security -D_REENTRANT -Wall -W -DQT_NO_DEBUG_OUTPUT -DVERSION=\"v3.1.3\" -DVERSION_MAJOR=3 -DVERSION_MINOR=1 -DVERSION_BUGFIX=3 -DQT_NO_CAST_TO_ASCII -DQT_USE_FAST_CONCATENATION -DQT_USE_FAST_OPERATOR_PLUS -DBOOST_FILESYSTEM_VERSION=2 -DTORRENT_USE_OPENSSL -DWITH_SHIPPED_GEOIP_H -DBOOST_ASIO_HASH_MAP_BUCKETS=1021 -DBOOST_EXCEPTION_DISABLE -DBOOST_ASIO_ENABLE_CANCELIO -DBOOST_ASIO_DYN_LINK -DTORRENT_LINKING_SHARED -DQT_NO_DEBUG -DQT_DBUS_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtDBus -I/usr/include/qt4 -I/usr/include/libtorrent -I/usr/include -Iqtnotify -I. -Iqtlibtorrent -Iwebui -Itracker -Ipreferences -Ilineedit/src -Iproperties -Isearchengine -Irss -Itorrentcreator -Igeoip -Ipowermanagement -I/usr/include/qt4/QtSolutions -I. -I. -o mainwindow.o mainwindow.cpp
In file included from properties/trackerlist.h:41:0,
                 from mainwindow.cpp:62:
properties/propertieswidget.h:36:33: fatal error: ui_propertieswidget.h: No such file or directory
 #include "ui_propertieswidget.h"
                                 ^
compilation terminated.
Makefile:1927: recipe for target 'mainwindow.o' failed
make[1]: *** [mainwindow.o] Error 1
make[1]: Leaving directory '/var/tmp/portage/net-p2p/qbittorrent-3.1.3/work/qbittorrent-3.1.3/src'
Makefile:39: recipe for target 'sub-src-make_default' failed
make: *** [sub-src-make_default] Error 2
 * ERROR: net-p2p/qbittorrent-3.1.3::gentoo failed (compile phase):
 *   emake failed

...
-----------------------------------------------------------------------------

And indeed, I suspected a parallel build error.

The last comment says "re-open the bug" but i have no clue on how to do it. I only have "Save changes" under this textbox...
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2013-12-07 09:47:49 UTC
Hi,

Could you please open a *new* upstream bug on https://github.com/qbittorrent/qBittorrent/issues ? It seems this is where they prefer bugs nowadays. Please post the link back here so we can track it.
Comment 7 Davide Pesavento gentoo-dev 2014-05-24 23:03:56 UTC
3.1.9.2-r1 still randomly fails for me with MAKEOPTS="--jobs --load 5"

In file included from mainwindow.cpp:55:0:
rss/rss_imp.h:38:20: fatal error: ui_rss.h: No such file or directory
 #include "ui_rss.h"
                    ^
compilation terminated.
Makefile:1947: recipe for target 'mainwindow.o' failed
Comment 8 Thomas Capricelli 2014-10-12 23:46:18 UTC
the bug is still there as of today, with net-p2p/qbittorrent-3.1.10
Comment 9 Davide Pesavento gentoo-dev 2015-06-04 18:26:57 UTC
is this still reproducible with 3.2.0?
Comment 10 crabbed halo ablution 2015-08-27 09:49:02 UTC
I've got the same bug as Davide mentioned with 3.2.3

In file included from gui/mainwindow.cpp:57:0:
gui/rss/rss_imp.h:38:20: fatal error: ui_rss.h: No such file or directory
 #include "ui_rss.h"
                    ^
compilation terminated.

Builds without parallel make.
Comment 11 Andreas Sturmlechner gentoo-dev 2017-03-06 21:11:31 UTC
qbittorrent is built using cmake in >=3.3.10, please check back using 3.3.11 preferably.