Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 424529 - vpnc init script does not wait for network connectivity (NetworkManager)
Summary: vpnc init script does not wait for network connectivity (NetworkManager)
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lori
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-02 16:57 UTC by Andrew Udvare
Modified: 2014-09-23 12:32 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Udvare 2012-07-02 16:57:36 UTC
If NetworkManager and vpnc are in the default runlevel, the vpnc init script does not wait for NetworkManager to make a connection before running.

Reproducible: Always

Steps to Reproduce:
1. USE="dhcpcd" emerge networkmanager vpnc
2. rc-update add NetworkManager default
3. rc-update add vpnc default
4. Set up vpnc
5. Reboot
Actual Results:  
vpnc fails to connect because there is no network connection until I log in to KDE.

 * Starting VPNC: vpnc ...
/usr/sbin/vpnc: unknown host `**'

 * start-stop-daemon: failed to start `/usr/sbin/vpnc'
 [ !! ]
 * ERROR: vpnc failed to start

Expected Results:  
Should wait for NetworkManager to make a connection as others do (nginx).
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-07-17 03:21:50 UTC
FYI, unless you are using a highly customized vpnc setup, you will likely find it easier to use net-misc/networkmanager-vpnc, which is the official networkmanager plugin for using vpnc.
Comment 2 Andrew Udvare 2012-07-17 04:56:03 UTC
(In reply to comment #1)
> FYI, unless you are using a highly customized vpnc setup, you will likely
> find it easier to use net-misc/networkmanager-vpnc, which is the official
> networkmanager plugin for using vpnc.

This combination has been very unstable for me on this computer which is why I use plain old dhcpcd (/etc/init.d/net.eth0 linked to net.lo) and vpnc.
Comment 3 Pavel Šimerda (pavlix) 2012-11-23 07:52:18 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > FYI, unless you are using a highly customized vpnc setup, you will likely
> > find it easier to use net-misc/networkmanager-vpnc, which is the official
> > networkmanager plugin for using vpnc.
> 
> This combination has been very unstable for me on this computer which is why
> I use plain old dhcpcd (/etc/init.d/net.eth0 linked to net.lo) and vpnc.

Would that mean you are no longer interested in this bug report?

I don't think you can properly handle network dependency issues in OpenRC when running NetworkManager. There are two notable interfaces that can be used to handle connection dependencies with NetworkManager and those are the D-Bus API
and the dispatcher scripts in /etc/NetworkManager/dispatcher.d. The latter
being more suitable for distribution quickfixes.
Comment 4 Andrew Udvare 2012-11-23 08:13:55 UTC
Yeah, no longer interested as I have decided not to use NetworkManager this way.
Comment 5 Pacho Ramos gentoo-dev 2014-09-23 12:32:13 UTC
What is the status of this currently? Doesn't seem to be assigned to any concrete package :/

Also, what is the current status with an updated system?