Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 423801 - net-im/pidgin-2.10.4[gnutls] fails configure with net-libs/gnutls[nettle]
Summary: net-im/pidgin-2.10.4[gnutls] fails configure with net-libs/gnutls[nettle]
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnutls-nettle
  Show dependency tree
 
Reported: 2012-06-27 09:59 UTC by Alexander Tsoy
Modified: 2013-06-20 13:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,13.04 KB, text/plain)
2012-06-27 10:00 UTC, Alexander Tsoy
Details
config.log (config.log,104.73 KB, text/plain)
2012-06-27 10:00 UTC, Alexander Tsoy
Details
pidgin-2.10.4.ebuild.patch (pidgin-2.10.4.ebuild.patch,533 bytes, patch)
2012-06-27 10:07 UTC, Alexander Tsoy
Details | Diff
pidgin-2.10.4-configure.patch (pidgin-2.10.4-configure.patch,596 bytes, patch)
2012-06-27 12:24 UTC, Alexander Tsoy
Details | Diff
pidgin-2.10.4.ebuild.patch (pidgin-2.10.4.ebuild.patch,347 bytes, patch)
2012-06-27 12:25 UTC, Alexander Tsoy
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Tsoy 2012-06-27 09:59:27 UTC
Configure test fails when emerging pidgin with USE="gnutls" if dev-libs/libgcrypt is not installed.

Reproducible: Always




$ emerge --info 
Portage 2.1.10.65 (hardened/linux/amd64, gcc-4.6.3, glibc-2.14.1-r3, 3.2.20-hardened-r1 x86_64)
=================================================================
System uname: Linux-3.2.20-hardened-r1-x86_64-QEMU_Virtual_CPU_version_0.12.3-with-gentoo-2.1
Timestamp of tree: Tue, 26 Jun 2012 23:45:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://de-mirror.org/gentoo/ ftp://de-mirror.org/gentoo/ "
LANG="ru_RU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl aio amd64 bash-completion berkdb bzip2 caps cli cracklib crypt cups cxx device-mapper dri gdbm gpm hardened iconv icu idn ipv6 justify logrotate maildir mmx modules mudflap multilib mysql ncurses nls nptl openmp pam pax_kernel pcre perl pppd python readline session sse sse2 ssl tcpd tls unicode urandom vim-syntax xattr xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Alexander Tsoy 2012-06-27 10:00:02 UTC
Created attachment 316395 [details]
build.log
Comment 2 Alexander Tsoy 2012-06-27 10:00:24 UTC
Created attachment 316397 [details]
config.log
Comment 3 Alexander Tsoy 2012-06-27 10:07:56 UTC
Created attachment 316399 [details, diff]
pidgin-2.10.4.ebuild.patch
Comment 4 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-06-27 10:17:08 UTC
Unfortunately that's not the right solution. The problem is that in the case of gnutls[nettle] it shouldn't use gcrypt at all.
Comment 5 Alexander Tsoy 2012-06-27 12:24:37 UTC
Created attachment 316415 [details, diff]
pidgin-2.10.4-configure.patch
Comment 6 Alexander Tsoy 2012-06-27 12:25:17 UTC
Created attachment 316417 [details, diff]
pidgin-2.10.4.ebuild.patch
Comment 7 Alexander Tsoy 2012-06-27 12:44:47 UTC
(In reply to comment #5)
> Created attachment 316415 [details, diff] [details, diff]
> pidgin-2.10.4-configure.patch

Oh.. I didn't test it with net-libs/gnutls[-nettle] and it may fail.
Comment 8 Bartosz Brachaczek 2012-09-22 19:36:52 UTC
(In reply to comment #7)
> Oh.. I didn't test it with net-libs/gnutls[-nettle] and it may fail.

It won't fail. Pidgin doesn't use libgcrypt, `pkg-config --libs gnutls` with stable net-libs/gnutls[-nettle] doesn't mention -lgcrypt, so simply removing -lgcrypt is correct.

I filed an upstream report for this: https://developer.pidgin.im/ticket/15329
Comment 9 PeGa! 2012-11-06 17:27:58 UTC
Hi, I can confirm that pidgin 2.10.6 without gtk && with ncurses (in order to get finch only) is not able to build. After negating 'nettle' flag on gnutls it builds fine.

System is a recently installed gentoo 2012.

Here's an emerge --info:

http://bpaste.net/show/56253/

Regards,

Paul
Comment 10 Bartosz Brachaczek 2013-02-13 20:41:47 UTC
It's fixed in upstream Pidgin 2.10.7.
Comment 11 Lars Wendler (Polynomial-C) gentoo-dev 2013-06-20 13:35:44 UTC
As already mentioned this is fixed in 2.10.7.