Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 421623 - dev-lang/ghc-7.4.1-r1: unable to compile with portage because it results in a segmentation fault.
Summary: dev-lang/ghc-7.4.1-r1: unable to compile with portage because it results in a...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo's Haskell Language team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-17 17:33 UTC by Damien Hammer
Modified: 2013-06-08 04:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Damien Hammer 2012-06-17 17:33:35 UTC
I tried to emerge ghc, since it was a dependency of pcap which was need to use nmap, but it exited with an error. It was a segmentation fault as seen by:

ghc-stage1[4168]: segfault at 3ffffff8 ip 0000000000403b96 sp 00007fff7ee460e0 error 4 in ghc-stage1[400000+19ba000]

which was the in the output of dmesg after the segmentation fault while emerging ghc. More information can be seen in the attached files and additional information including the output of emerge --info.

Reproducible: Always

Steps to Reproduce:
1.Emerge ghc.
Actual Results:  
It had a segmentation fault while compiling the ebuild ghc.

Expected Results:  
It should have compiled the ebuild ghc successfuly.

Portage 2.1.10.65 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.4.2 x86_64)
=================================================================
System uname: Linux-3.4.2-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.1
Timestamp of tree: Fri, 15 Jun 2012 14:00:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p29
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.5, 1.12.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O3 -fomit-frame-pointer -fno-inline-functions -fno-ipa-cp-clone -fno-unswitch-loops -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7 -O3 -fomit-frame-pointer -fno-inline-functions -fno-ipa-cp-clone -fno-unswitch-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://mirror.the-best-hosting.net http://gentoo.cites.uiuc.edu/pub/gentoo/ http://mirror.lug.udel.edu/pub/gentoo/ http://mirrors.rit.edu/gentoo/"
LDFLAGS="-Wl,-O1,-z,now"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl alsa amd64 apache2 apng berkdb bzip2 cairo cli consolekit cracklib crypt cups cxx dbus dri flac fortran gdbm gpm iconv jpeg kde mmx modules mp3 mudflap multilib mysql mysqli ncurses nls nptl ogg opengl openmp pam pcre php png policykit pppd pulseaudio python qt3support qt4 readline sasl session sse sse2 sse3 ssl startup-notification tcpd threads udev unicode vhosts vorbis webkit x264 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Damien Hammer 2012-06-18 00:20:08 UTC
This can be avoided if the binary use flag is enabled on the ebuild since it builds it using the precompiled binaries rather than from source which is where the problem occurs.
Comment 2 Sergei Trofimovich gentoo-dev 2012-06-19 16:29:37 UTC
Can you try with MAKEOPTS=-j1 to see if a workaround helps?
Comment 3 Alexander Vershilov (RETIRED) gentoo-dev 2013-06-08 04:50:32 UTC
Closing as RESOLVED-OBSOLETE. Due ghc-7.4.2 is stable.

If you still have problems with ghc-7.4.1 with MAKEOPTS="-j1" feel free to reopen.