Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 42135 - net-misc/iputils-021109-r1 fails to compile : error in configure.in
Summary: net-misc/iputils-021109-r1 fails to compile : error in configure.in
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Joshua Kinard
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 38774
  Show dependency tree
 
Reported: 2004-02-19 04:00 UTC by Benoit Boissinot
Modified: 2004-02-22 04:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch removes compile/install support for racoon tools (iputils-021109-r1.patch,269 bytes, patch)
2004-02-22 02:18 UTC, Gregg Casillo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benoit Boissinot 2004-02-19 04:00:16 UTC
Emerging iputils fails, i don't know if the bug is related to iputils or autoconf :

gcc -O3 -march=athlon-xp -pipe -fforce-addr -fmove-all-movables -fomit-frame-pointer -fprefetch-loop-arrays -ffast-math -mfpmath=sse -m3dnow -mmmx -msse -include ../include-glibc/glibc-bugs.h -I../libipsec -I../include-glibc -I/usr/include -DIPSEC_DEBUG -DINET6 -DYY_NO_UNPUT -I. -Wall   -c -o token.o token.c
gcc -o setkey setkey.o parse.o token.o pfkey.o pfkey_dump.o key_debug.o ipsec_strerror.o -L../libipsec -lipsec -lfl
rm token.c
configure.in:1: error: possibly undefined macro: dnl
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.in:138: error: do not use LIBOBJS directly, use AC_LIBOBJ (see section `AC_LIBOBJ vs LIBOBJS'

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




my emerge info :
Portage 2.0.50-r1 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3_pre20040207-r0,
2.6.3-rc3-love1)
=================================================================
System uname: 2.6.3-rc3-love1 i686 AMD Athlon(TM) XP 2500+
Gentoo Base System version 1.4.3.13
distcc 2.12.1 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=athlon-xp -pipe -fforce-addr -fmove-all-movables
-fomit-frame-pointer -fprefetch-loop-arrays -ffast-math -mfpmath=sse -m3dnow
-mmmx -msse"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -march=athlon-xp -pipe -fforce-addr -fmove-all-movables
-fomit-frame-pointer -fprefetch-loop-arrays -ffast-math -mfpmath=sse -m3dnow
-mmmx -msse"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs buildsyspkg ccache sandbox"
GENTOO_MIRRORS="ftp://sci7.residence.ens-lyon.fr/
ftp://ghost.residence.ens-lyon.fr/gentoo/portage/
ftp://ftp.easynet.nl/mirror/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://sci7.residence.ens-lyon.fr/gentoo-portage"
USE="3dnow X alsa apm avi berkdb bonobo cdr crypt cups distcc dvd encode esd
foomaticdb gdbm gif gnome gpm gtk gtk2 gtkhtml guile imlib ipv6 java jpeg libg++
libwww mad mikmod mmx motif mpeg ncurses nls nptl oggvorbis opengl oss pam
pdflib perl png python quicktime radeon readline samba sdl slang spell sse ssl
svga tcltk tcpd tetex truetype vi x86 xine xml2 xv zlib"
Comment 1 Collins Richey 2004-02-19 13:43:44 UTC
Any ideas on this?  I've also tried the fix recommended in #41095 for a similar problem with metamail, namely 
'FEATURES="keeptemp keepwork" WANT_AUTOCONF="2.5" emerge iputils', 
but no joy.
Comment 2 Joshua Kinard gentoo-dev 2004-02-20 14:54:29 UTC
Are you using ipsec related stuff, or more specifically, does the following file exist for you?:

/usr/include/linux/pfkeyv2.h

If so, iputils attempts to compile an extra set of utilities.  the breakage is likely occuring in here.
Comment 3 Joshua Kinard gentoo-dev 2004-02-20 15:00:12 UTC
Try re-merging autoconf and flex, see if that changes anything.  See the comments in Bug #38774 for similar issues as well and a possible solution.  I haven't been able to reproduce this yet, mainly because I lack the pfkeyv2.h header.
Comment 4 Dev 2004-02-21 01:14:31 UTC
I can confirm with kernel 2.6.3-mm1 and linux-headers 2.6.3. (Re)merging autoconf/flex/openssl did nothing.
Comment 5 Gregg Casillo 2004-02-22 00:57:07 UTC
Same problem for me. I'm installing from stage1-x86-20040204 and braking at this point in emerge system on iputils-021109-r1. I have linux-headers-2.6.3 installed, and I have the aforementioned header file. Reemerging flex and autoconf did nothing for me either.
Comment 6 Gregg Casillo 2004-02-22 02:17:14 UTC
Okay, the solution for me was to delete all lines related to "racoon" in the ebuild. Best as I can tell, the stuff under that subdirectory are VPN/IPSec related, and I don't care about any of that (that I know of). Attached is a patch that carries this out, though I would imagine that this is something that should be *fixed* instead. I know nothing about m4, so I don't know what the undefined macro errors is all about. ;-)
Comment 7 Gregg Casillo 2004-02-22 02:18:25 UTC
Created attachment 26086 [details, diff]
Patch removes compile/install support for racoon tools
Comment 8 Joshua Kinard gentoo-dev 2004-02-22 02:29:31 UTC
plasmaroo: I think you added this support originally -- Any idea what can be done here?  The conditional hangs on the existance of pfvkey2.h existing, which could be the case on machines that don't need this additional iputils support.  Maybe the best approach is a USE Flag for this support?
Comment 9 Tim Yamin (RETIRED) gentoo-dev 2004-02-22 03:28:20 UTC
Hmmm - well, the racoon stuff is under a *sh "Do I have pfkeyv2.h?" conditional, mainly because that header is needed for things to go for racoon.

Try changing the "autoconf || die" to an "autoconf" -- it seems to compile more-or-less with their packaged pre-autoconfig'ed ./configure script so I guess that should work. If that fixed the issue, can somebody please confirm this and I'll add the change to CVS?

Thanks!
Comment 10 Benoit Boissinot 2004-02-22 04:11:42 UTC
That fixed the issue for me.

Thanks
Comment 11 Tim Yamin (RETIRED) gentoo-dev 2004-02-22 04:23:24 UTC
Fixed in CVS, should hit Portage within an hour. Thanks!