Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 421191 - app-arch/libarchive-3.0.4-r1 causes ebuilds using elibtoolize to fail on ~amd64-fbsd
Summary: app-arch/libarchive-3.0.4-r1 causes ebuilds using elibtoolize to fail on ~amd...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: FreeBSD (show other bugs)
Hardware: AMD64 FreeBSD
: Normal major (vote)
Assignee: Gentoo/BSD Team
URL:
Whiteboard:
Keywords: Bug, REGRESSION
Depends on:
Blocks:
 
Reported: 2012-06-15 03:09 UTC by Richard Yao
Modified: 2012-11-24 12:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Yao gentoo-dev 2012-06-15 03:09:18 UTC
All ebuilds using elibtoolize fail to build on ~amd64-fbsd immediately after invoking "libtoolize --install --copy --force --automake". Here is an example:

***** libtoolize *****
***** PWD: /var/tmp/portage/dev-libs/libxml2-2.8.0-r1/work/libxml2-2.8.0
***** libtoolize --install --copy --force --automake

libtoolize: can not copy `/usr/share/libtool/config/config.guess' to `./'
libtoolize: can not copy `/usr/share/libtool/config/config.sub' to `./'
libtoolize: can not copy `/usr/share/libtool/config/install-sh' to `./'
libtoolize: can not copy `/usr/share/libtool/config/ltmain.sh' to `./'
libtoolize: can not copy `/usr/share/aclocal/libtool.m4' to `m4/'
libtoolize: You should add the contents of `m4/libtool.m4' to `aclocal.m4'.
libtoolize: can not copy `/usr/share/aclocal/ltoptions.m4' to `m4/'
libtoolize: You should add the contents of `m4/ltoptions.m4' to `aclocal.m4'.
libtoolize: can not copy `/usr/share/aclocal/ltsugar.m4' to `m4/'
libtoolize: You should add the contents of `m4/ltsugar.m4' to `aclocal.m4'.
libtoolize: can not copy `/usr/share/aclocal/ltversion.m4' to `m4/'
libtoolize: You should add the contents of `m4/ltversion.m4' to `aclocal.m4'.
libtoolize: can not copy `/usr/share/aclocal/lt~obsolete.m4' to `m4/'
libtoolize: You should add the contents of `m4/lt~obsolete.m4' to `aclocal.m4'.

floppym pointed out that libtoolize depended on tar. After downgrading to app-arch/libarchive-3.0.3 on my system, this issue disappeared.
Comment 1 Richard Yao gentoo-dev 2012-06-15 03:11:56 UTC
=app-arch/libarchive-3.0.4-r1 is now masked on FreeBSD.
Comment 2 Naohiro Aota gentoo-dev 2012-07-04 09:32:59 UTC
What do you get with "libtoolize --install --copy --force --automake --debug" or "libtoolize --install --copy --force --verbose"? I have no problem on x86-fbsd.
Comment 3 Alexis Ballier gentoo-dev 2012-11-24 12:55:58 UTC
(In reply to comment #1)
> =app-arch/libarchive-3.0.4-r1 is now masked on FreeBSD.

please do _NOT_ mask packages unless the problem is identified and you are sure it is not a ricing or pebcak problem; even less if you plan to leave it as such for 5 months

(In reply to comment #2)
> What do you get with "libtoolize --install --copy --force --automake
> --debug" or "libtoolize --install --copy --force --verbose"? I have no
> problem on x86-fbsd.

works fine here too, hence unmasked.