Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 420531 - >=app-i18n/fcitx-configtool-0.4.1 makes use of gtk3 useflag
Summary: >=app-i18n/fcitx-configtool-0.4.1 makes use of gtk3 useflag
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mu Qiao (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: use_gtk3
  Show dependency tree
 
Reported: 2012-06-10 18:22 UTC by Julian Ospald
Modified: 2012-07-20 08:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Ospald 2012-06-10 18:22:04 UTC
These packages make use of gtk3 useflag which indicates that there are issues of migration to gtk+:3.
Gtk3 and similar useflags should be avoided.

Adding to tracker. Please have a look.

On top of that, this seems to be missing dependency gtk+:3 completely (even if gtk3 useflag is enabled).
Comment 1 Ben de Groot (RETIRED) gentoo-dev 2012-07-19 09:09:17 UTC
Not a bug. The gtk3 useflag is used as intended here.
Comment 2 Samuli Suominen gentoo-dev 2012-07-20 08:28:18 UTC
(In reply to comment #1)
> Not a bug. The gtk3 useflag is used as intended here.

The GTK+-3.x version of the program does something different than the GTK+-2.x version? Like write different config files?

If not, then this bug should be reopened