Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 420233 - =www-client/seamonkey-2.10 fails to build with -alsa -webm
Summary: =www-client/seamonkey-2.10 fails to build with -alsa -webm
Status: RESOLVED DUPLICATE of bug 419801
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-08 11:23 UTC by Maurizio Camisaschi (amd64 AT)
Modified: 2012-06-08 12:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (seamonkey-2.10:20120607-131230.log.gz,257.13 KB, application/x-gzip)
2012-06-08 11:23 UTC, Maurizio Camisaschi (amd64 AT)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maurizio Camisaschi (amd64 AT) 2012-06-08 11:23:58 UTC
Created attachment 314671 [details]
build.log

USE="-alsa -webm" emerge =www-client/seamonkey-2.10:

/usr/bin/python2.7 /var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/mozilla/config/pythonpath.py -I../../../../config /var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/mozilla/config/expandlibs_gen.py DOMSVGAnimatedLengthList.o DOMSVGAnimatedNumberList.o DOMSVGAnimatedTransformList.o DOMSVGLength.o DOMSVGLengthList.o DOMSVGMatrix.o DOMSVGNumber.o DOMSVGNumberList.o DOMSVGPathSeg.o DOMSVGPathSegList.o DOMSVGPoint.o DOMSVGPointList.o DOMSVGStringList.o DOMSVGTests.o DOMSVGTransform.o DOMSVGTransformList.o nsDOMSVGZoomEvent.o nsDOMSVGEvent.o nsSVGAElement.o nsSVGAltGlyphElement.o nsSVGAngle.o nsSVGBoolean.o nsSVGCircleElement.o nsSVGClass.o nsSVGClipPathElement.o nsSVGDataParser.o nsSVGDefsElement.o nsSVGDescElement.o nsSVGElement.o nsSVGElementFactory.o nsSVGEllipseElement.o nsSVGEnum.o nsSVGFeatures.o nsSVGFilterElement.o nsSVGFilters.o nsSVGForeignObjectElement.o nsSVGGElement.o nsSVGGradientElement.o nsSVGGraphicElement.o nsSVGImageElement.o nsSVGInteger.o nsSVGIntegerPair.o nsSVGLength2.o nsSVGLineElement.o nsSVGMarkerElement.o nsSVGMaskElement.o nsSVGMetadataElement.o nsSVGNumber2.o nsSVGNumberPair.o nsSVGPathDataParser.o nsSVGPathElement.o nsSVGPathGeometryElement.o nsSVGPatternElement.o nsSVGPolyElement.o nsSVGPolygonElement.o nsSVGPolylineElement.o nsSVGScriptElement.o nsSVGString.o nsSVGStylableElement.o nsSVGRect.o nsSVGRectElement.o nsSVGSVGElement.o nsSVGStopElement.o nsSVGStyleElement.o nsSVGSwitchElement.o nsSVGSymbolElement.o nsSVGTSpanElement.o nsSVGTextContentElement.o nsSVGTextElement.o nsSVGTextPathElement.o nsSVGTextPositioningElement.o nsSVGTitleElement.o nsSVGUnknownElement.o nsSVGUseElement.o nsSVGViewBox.o SVGAnimatedLengthList.o SVGAnimatedNumberList.o SVGAnimatedPathSegList.o SVGAnimatedPointList.o SVGAnimatedPreserveAspectRatio.o SVGAnimatedTransformList.o SVGLength.o SVGLengthList.o SVGNumberList.o SVGPathData.o SVGPathSegUtils.o SVGPointList.o SVGStringList.o SVGTransform.o SVGTransformList.o SVGTransformListParser.o nsSVGAnimateElement.o nsSVGAnimateTransformElement.o nsSVGAnimateMotionElement.o nsSVGAnimationElement.o nsSVGMpathElement.o nsSVGSetElement.o SVGAttrValueWrapper.o SVGIntegerPairSMILType.o SVGLengthListSMILType.o SVGMotionSMILType.o SVGMotionSMILAttr.o SVGMotionSMILAnimationFunction.o SVGMotionSMILPathUtils.o SVGNumberListSMILType.o SVGNumberPairSMILType.o SVGOrientSMILType.o SVGPathSegListSMILType.o SVGPointListSMILType.o SVGTransformListSMILType.o SVGViewBoxSMILType.o   > libgkcontentsvg_s.a.desc
make[8]: Leaving directory `/var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/seamonk/mozilla/content/svg/content/src'
make[7]: Leaving directory `/var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/seamonk/mozilla/content/svg/content'
make[6]: Leaving directory `/var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/seamonk/mozilla/content/svg'
make[5]: Leaving directory `/var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/seamonk/mozilla/content'
make[4]: *** [libs_tier_platform] Error 2
make[4]: Leaving directory `/var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/seamonk/mozilla'
make[3]: *** [tier_platform] Error 2
make[3]: Leaving directory `/var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/seamonk/mozilla'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/seamonk/mozilla'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/var/tmp/portage/www-client/seamonkey-2.10/work/comm-release/seamonk'
make: *** [build] Error 2
emake failed
 * ERROR: www-client/seamonkey-2.10 failed (compile phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  85:  Called src_compile
 *   environment, line 6186:  Called die
 * The specific snippet of code:
 *       CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" MOZ_MAKE_FLAGS="${MAKEOPTS}" emake -f client.mk || die;
 * 
 * If you need support, post the output of 'emerge --info =www-client/seamonkey-2.10',
 * the complete build log and the output of 'emerge -pqv =www-client/seamonkey-2.10'.
 * The complete build log is located at '/home/at_user/log/build/www-client/seamonkey-2.10:20120607-131230.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/seamonkey-2.10/temp/environment'.
 * S: '/var/tmp/portage/www-client/seamonkey-2.10/work/comm-release'
Comment 1 Maurizio Camisaschi (amd64 AT) 2012-06-08 11:25:36 UTC
emerge --info

Portage 2.1.10.49 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.2.12-gentoo x86_64)
=================================================================
System uname: Linux-3.2.12-gentoo-x86_64-AMD_FX-tm-8150_Eight-Core_Processor-with-gentoo-2.1
Timestamp of tree: Wed, 06 Jun 2012 21:15:01 +0000
app-shells/bash:          4.2_p20
dev-lang/python:          2.7.3-r1, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.3.6-r1, 4.4.6-r1, 4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe -mcx16 -msahf -maes -mpclmul -mpopcnt -mabm -mlwp -mavx"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="assume-digests binpkg-logs collision-protect distlocks ebuild-locks fixlafiles multilib-strict news parallel-fetch protect-owned sandbox sfperms split-log strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="am fil zh af ca cs da de el es et gl hu nb nl pl pt ro ru sk sl sv uk bg cy en eo fo ga he id ku lt lv mk ms nn sw tn zu ja zh_TW en_GB pt_BR ko zh_CN ar en_CA fi kk oc sr tr fa wa nds as be bn bn_BD bn_IN en_US es_AR es_CL es_ES es_MX eu fy fy_NL ga_IE gu gu_IN hi hi_IN is ka kn ml mr nn_NO or pa pa_IN pt_PT rm si sq sv_SE ta ta_LK te th vi ast dz km my om sh ug uz ca@valencia sr@ijekavian sr@ijekavianlatin sr@latin csb hne mai se es_LA fr_CA zh_HK br la no es_CR et_EE sr_CS bo hsb hy mn sr@Latn lb ne bs tg uz@cyrillic xh be_BY brx ca_XV dgo en_ZA gd kok ks ky lo mni nr ns pap ps rw sa_IN sat sd ss st sw_TZ ti ts ve mt ia az me tl ak hy_AM lg nso son ur_PK it fr nb nb_NO hr nan ur tk ha mi tt ven cs_CZ da_DK de_1901 de_CH en_AU lt_LT pl_PL sa sk_SK th_TH ta_IN"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nvidia objc objc++ objc-gc ogg opengl openmp pam pango pcre pdf plasma png policykit ppds pppd qt3support qt4 readline sdl semantic-desktop session spell sql sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis webkit wxwidgets x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="am fil zh af ca cs da de el es et gl hu nb nl pl pt ro ru sk sl sv uk bg cy en eo fo ga he id ku lt lv mk ms nn sw tn zu ja zh_TW en_GB pt_BR ko zh_CN ar en_CA fi kk oc sr tr fa wa nds as be bn bn_BD bn_IN en_US es_AR es_CL es_ES es_MX eu fy fy_NL ga_IE gu gu_IN hi hi_IN is ka kn ml mr nn_NO or pa pa_IN pt_PT rm si sq sv_SE ta ta_LK te th vi ast dz km my om sh ug uz ca@valencia sr@ijekavian sr@ijekavianlatin sr@latin csb hne mai se es_LA fr_CA zh_HK br la no es_CR et_EE sr_CS bo hsb hy mn sr@Latn lb ne bs tg uz@cyrillic xh be_BY brx ca_XV dgo en_ZA gd kok ks ky lo mni nr ns pap ps rw sa_IN sat sd ss st sw_TZ ti ts ve mt ia az me tl ak hy_AM lg nso son ur_PK it fr nb nb_NO hr nan ur tk ha mi tt ven cs_CZ da_DK de_1901 de_CH en_AU lt_LT pl_PL sa sk_SK th_TH ta_IN" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Jory A. Pratt gentoo-dev 2012-06-08 12:17:45 UTC

*** This bug has been marked as a duplicate of bug 419801 ***