Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 418399 - =media-gfx/blender-2.64a please stabilize
Summary: =media-gfx/blender-2.64a please stabilize
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 436566 436568 436570 436572 436576 448312
Blocks: gcc-4.6-stable
  Show dependency tree
 
Reported: 2012-05-31 16:32 UTC by Kacper Kowalik (Xarthisius) (RETIRED)
Modified: 2013-02-05 17:14 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2012-05-31 16:32:00 UTC
Required for gcc-4.6 stabilization wrt bug 362369
Comment 1 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2012-06-23 10:52:43 UTC
just a friendly ping
Comment 2 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-07-16 00:51:45 UTC
We'll go for 2.63 as there are many more issues. Or we can ask other arches to drop the stable...
Comment 3 brothermechanic 2012-08-14 06:29:02 UTC
Somebody please create ebuild for opencolorio.
Thank you.
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2012-08-14 09:43:53 UTC
(In reply to comment #3)
> Somebody please create ebuild for opencolorio.
> Thank you.

Please open a separate bug for this. This bug is about stabilization of 2.63a-r3, not about improving the next version/revision with additional 
features.
Comment 5 brothermechanic 2012-08-15 03:20:17 UTC
>Please open a separate bug
i'm noob for this), please do that for me.
Many thanks...
Comment 6 Mike Limansky 2012-08-19 18:39:44 UTC
(In reply to comment #2)
> We'll go for 2.63 as there are many more issues. Or we can ask other arches
> to drop the stable...

Actually, there are no open bugs for blender 2.6x.
Comment 7 Pacho Ramos gentoo-dev 2012-09-23 14:09:16 UTC
Any news on this? What is blocking arches CCing? Thanks
Comment 8 Dirkjan Ochtman gentoo-dev 2012-09-26 10:55:48 UTC
Adding Diego to the CC, as he is now also a Blender maintainer, and apparently has been doing most of the recent work. Diego, perhaps you can set some dependencies for this or otherwise provide insight for an ETA? It looks like this is the only thing blocking gcc-4.6 for common arches.
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-09-26 22:25:56 UTC
Ah I think it's fine to go for it now.
Comment 10 Agostino Sarubbo gentoo-dev 2012-12-10 12:26:43 UTC
Keywords for media-gfx/blender:
         |                           | u   |  
         | a a             p     s   | n   |  
         | l m   h i m m   p s   p   | u s | r
         | p d a p a 6 i p c 3   a x | s l | e
         | h 6 r p 6 8 p p 6 9 s r 8 | e o | p
         | a 4 m a 4 k s c 4 0 h c 6 | d t | o
---------+---------------------------+-----+-------
2.49b-r2 | o + o o o o o + + o o o + | o 0 | gentoo
2.63a-r2 | o ~ o o o o o o o o o o ~ | #   | gentoo
2.64a    | o ~ o o o o o o o o o o ~ | o   | gentoo

ppc and ppc64 are not keyworded. Is this a keywordreq for them or what I should do?
Comment 11 Pacho Ramos gentoo-dev 2012-12-10 20:04:24 UTC
(In reply to comment #10) 
> ppc and ppc64 are not keyworded. Is this a keywordreq for them or what I
> should do?

I originally opened a keyword request for them:
https://bugs.gentoo.org/show_bug.cgi?id=436566#c3

but, per that comment, looks like the idea is to keyword and fast stabilize it
Comment 12 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2012-12-11 10:00:12 UTC
ppc* keywords dropped
Comment 13 Pacho Ramos gentoo-dev 2012-12-15 21:34:07 UTC
+*blender-2.63a-r3 (15 Dec 2012)
+
+  15 Dec 2012; Pacho Ramos <pacho@gentoo.org> +blender-2.63a-r3.ebuild:
+  Drop opencollada for stable candidate as it's not ready for stabilization yet
+  (#436574).
+
Comment 14 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-12-31 15:58:28 UTC
Given the snail-pace on this, and the fact that for 2.65a we're going to have to do everything from scratch, and remaining bugs with 2.63a anyway...

I'll just point this at 2.64a, and will _have_ to support collada then.
Comment 15 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-12-31 16:00:02 UTC
Alternatively, and might be preferred now, we could just mask blender until it's completely sorted out and drop the stable version altogether.
Comment 16 Pacho Ramos gentoo-dev 2012-12-31 16:57:07 UTC
In that case, please remember to drop this as blocked of gcc-4.6-stable bug
Comment 17 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-12-31 17:02:12 UTC
Sounds good to me, I'll set the mask and send the announcement tonight.
Comment 18 Diego Elio Pettenò (RETIRED) gentoo-dev 2013-02-05 16:09:05 UTC
I've finally masked this, so the stablereq is not important anymore.