Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 418115 - www-client/firefox ignores ccache when both ccache and distcc are enabled
Summary: www-client/firefox ignores ccache when both ccache and distcc are enabled
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-29 10:43 UTC by Andrew Savchenko
Modified: 2013-05-28 22:26 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,8.20 KB, text/plain)
2012-05-29 10:45 UTC, Andrew Savchenko
Details
environment (environment,258.30 KB, text/plain)
2012-05-29 10:46 UTC, Andrew Savchenko
Details
build.log.xz (build.log.xz,415.36 KB, application/x-xz)
2012-05-30 17:33 UTC, Andrew Savchenko
Details
environment (environment,259.06 KB, text/plain)
2012-05-30 17:34 UTC, Andrew Savchenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Savchenko gentoo-dev 2012-05-29 10:43:15 UTC
Hello,

with FEATURES="ccache distcc" firefox build ignores ccache, but uses distcc. With FEATURES="ccache" only ccache is used. Other packages use both ccache and distcc without problems. Mine ccache is 3.1.7 and distcc is 3.2_rc1.

Sample of ps ax | grep gcc output:

11229 pts/7    SN+    0:00 /usr/lib/distcc/bin/i686-pc-linux-gnu-g++ -o nsHttpHandler.i_o -c -I../../../dist/stl_wrappers -I../../../dist/syste
m_wrappers -include /var/tmp/portage/www-client/firefox-12.0-r2/work/mozilla-release/config/gcc_hidden.h -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM 
-DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES -DSTATIC_EXPORTABLE_JS_API -DOSTYPE="Linux3.3" -DOSARCH=Linux -DEXCLUDE_SKIA_DEPENDENCIES -DOS_LINUX=1 -DOS_POSIX=1 -DIMPL_NS_NET -I/var/tmp/portage/www-client/firefox-12.0-r2/work/mozilla-release/netwerk/protocol/http/../../base/src -I/var/tmp/portage/www-client/firefox-12.0-r2/work/mozilla-release/xpcom/ds -I/var/tmp/portage/www-client/firefox-12.0-r2/work/mozilla-release/content/base/src -I/var/tmp/portage/www-client/firefox-12.0-r2/work/mozilla-release/content/events/src -I/var/tmp/portage/www-client/firefox-12.0-r2/work/mozilla-release/ipc/chromium/src -I/var/tmp/portage/www-client/firefox-12.0-r2/work/mozilla-release/ipc/glue -I../../../ipc/ipdl/_ipdlheaders -I/var/tmp/portage/www-client/firefox-12.0-r2/work/mozilla-release/netwerk/protocol/http -I. -I../../../dist/include -I../../../dist/include/nsprpub -I/usr/include/nspr -I/usr/include/nss -fPIC -fno-rtti -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=athlon-xp -m32 -funswitch-loops -fpredictive-commoning -fgcse-after-reload -ftree-vectorize -mstackrealign -ftree-loop-linear -ftree-loop-im -fweb -frename-registers -mfpmath=sse -pipe -mno-avx -fno-exceptions -fno-strict-aliasing -std=gnu++0x -pthread -ffunction-sections -fdata-sections -pipe -DNDEBUG -DTRIMMED -g -fprofile-generate -O2 -fomit-frame-pointer -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/nsHttpHandler.pp /var/tmp/portage/www-client/firefox-12.0-r2/work/mozilla-release/netwerk/protocol/http/nsHttpHandler.cpp
Comment 1 Andrew Savchenko gentoo-dev 2012-05-29 10:45:07 UTC
Created attachment 313507 [details]
emerge --info
Comment 2 Andrew Savchenko gentoo-dev 2012-05-29 10:46:23 UTC
Created attachment 313509 [details]
environment

PATH looks OK, maybe firefox build tools strip it somehow.
Comment 3 Jeroen Roovers gentoo-dev 2012-05-29 21:50:30 UTC
Please attach the entire build log to this bug report.

Judging from my build logs, it appears to figure a couple of things out wrongly in src_configure() (it appears to ignore CHOST), and your ps output doesn't suggest that it isn't using ccache or distcc, just that there is a subprocess that does not include that path. So you may have found a genuine bug but without a build log, we cannot be certain.
Comment 4 Andrew Savchenko gentoo-dev 2012-05-30 17:33:14 UTC
I noticed that ccache is not used when rebuild of the same version of firefox took too long time and ccache -s showed no changes in counters.

I'm uploading full build log (compressed, too large otherwise) and environment of the new build.
Comment 5 Andrew Savchenko gentoo-dev 2012-05-30 17:33:41 UTC
Created attachment 313621 [details]
build.log.xz
Comment 6 Andrew Savchenko gentoo-dev 2012-05-30 17:34:01 UTC
Created attachment 313623 [details]
environment
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2012-07-15 05:38:36 UTC
Nothing for toolchain to do here.
Comment 8 Andrew Savchenko gentoo-dev 2013-05-26 09:43:33 UTC
The problem is still here with firefox-20.0.1.
Comment 9 Andrew Savchenko gentoo-dev 2013-05-28 22:26:37 UTC
I undestand what is happening: ccache doesn't support profile-related options, -fprofile-generate in particular and ccache's counter of "unsupported compiler option" is growing during firefox build.