Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 417355 - app-text/sgml-common-0.6.3-r5 fails to merge with automake errors
Summary: app-text/sgml-common-0.6.3-r5 fails to merge with automake errors
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 417011 (view as bug list)
Depends on: 420631
Blocks:
  Show dependency tree
 
Reported: 2012-05-24 09:16 UTC by Steffen Hau
Modified: 2013-01-03 04:36 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
automake.out (automake.out,384 bytes, text/plain)
2012-05-24 09:16 UTC, Steffen Hau
Details
Tarball of portage tmpdir (sgml-common-fail.tar.gz,191.10 KB, application/x-gzip)
2012-05-26 14:40 UTC, Mike Gilbert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steffen Hau 2012-05-24 09:16:03 UTC
I've recompiled world with empty tree and app-text/sgml-common-0.6.3-r5 failed to merge with the following error:


 * Package:    app-text/sgml-common-0.6.3-r5
 * Repository: gentoo
 * Maintainer: sgml@gentoo.org
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   ccache fakeroot sandbox splitdebug userpriv usersandbox
>>> Unpacking source...
>>> Unpacking sgml-common-0.6.3.tgz to /var/tmp/portage/app-text/sgml-common-0.6.3-r5/work
>>> Source unpacked in /var/tmp/portage/app-text/sgml-common-0.6.3-r5/work
>>> Preparing source in /var/tmp/portage/app-text/sgml-common-0.6.3-r5/work/sgml-common-0.6.3 ...
 * Applying sgml-common-0.6.3-prefix.patch ...
 [ ok ]
 * Adjusting to prefix /
 *   install-catalog.in ...
 [ ok ]
 *   sgmlwhich ...
 [ ok ]
 *   sgml.conf ...
 [ ok ]
 * Applying sgml-common-0.6.3-configure.in.patch ...
 [ ok ]
 * Applying sgml-common-0.6.3-man_MANS.patch ...
 [ ok ]
 * Applying sgml-common-0.6.3-htmldir.patch ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/app-text/sgml-common-0.6.3-r5/work/sgml-common-0.6.3' ...
 * Running aclocal ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running automake --add-missing --copy --foreign ...
 [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/app-text/sgml-common-0.6.3-r5/temp/automake.out

 * ERROR: app-text/sgml-common-0.6.3-r5 failed (prepare phase):
 *   Failed Running automake !
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_prepare
 *   environment, line 2594:  Called eautoreconf
 *   environment, line  721:  Called eautomake
 *   environment, line  679:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *   environment, line  473:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of `emerge --info '=app-text/sgml-common-0.6.3-r5'`,
 * the complete build log and the output of `emerge -pqv '=app-text/sgml-common-0.6.3-r5'`.
 * The complete build log is located at '/var/tmp/portage/app-text/sgml-common-0.6.3-r5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-text/sgml-common-0.6.3-r5/temp/environment'.
 * Working directory: '/var/tmp/portage/app-text/sgml-common-0.6.3-r5/work/sgml-common-0.6.3'
 * S: '/var/tmp/portage/app-text/sgml-common-0.6.3-r5/work/sgml-common-0.6.3'

See attached automake.out for details.

Reproducible: Always





Portage 2.1.10.62 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.4.0-HAUIHAU x86_64)
=================================================================
System uname: Linux-3.4.0-HAUIHAU-x86_64-Intel-R-_Core-TM-_i7-2620M_CPU_@_2.70GHz-with-gentoo-2.1
Timestamp of tree: Wed, 23 May 2012 09:45:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo x11 hauihau
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb -floop-interchange -floop-strip-mine -floop-block -ftree-loop-distribution -fira-loop-pressure -ftree-vectorize -ftree-loop-linear"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb -floop-interchange -floop-strip-mine -floop-block -ftree-loop-distribution -fira-loop-pressure -ftree-vectorize -ftree-loop-linear"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --keep-going=y --quiet-build=n --with-bdeps=y"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fakeroot fixlafiles metadata-transfer news parallel-fetch parallel-install parse-eapi-ebuild-head protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox xattr"
FFLAGS=""
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo/"
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-znow -Wl,--sort-common -Wl,--hash-style=gnu -Wl,--enable-new-dtags"
LINGUAS="de"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/hauihau"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl alsa amd64 apache2 bash-completion bcmath berkdb bidi bluetooth branding bzip2 cairo calendar caps cdda cddb cdparanoia cdr cli cracklib crypt ctype cups curl cxx dbus dga directfb doc dri dts dv dvd encode examples exif ffmpeg flac fontconfig fortran ftp gd gdbm gif gmp gnome gnome-keyring gphoto2 gstreamer gtk iconv icu imagemagick imap imlib ipv6 java jpeg jpeg2k kde lame latex lcms libcaca libnotify libsamplerate lua lzma lzo mad matroska mhash mmap mmx mng modules mono mp3 mpeg msn mtp mudflap multilib musepack mysql mysqli ncurses networkmanager nls nptl nptlonly nsplugin offensive ogg openal opengl openmp oscar pam pcre pdf perl php plasma png policykit posix python qt4 quicktime readline ruby samba sdl session sharedext smp sndfile snmp soap sockets spell sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs syslog tcl tcpd theora threads tidy tiff tk tokenizer truetype udev unicode usb v4l vcd vim-syntax vorbis wavpack x264 xattr xcb xcomposite xine xinerama xml xmlrpc xmp xorg xosd xpm xsl xv xvid yahoo zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_alias authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http rewrite setenvif so speling status substitute unique_id userdir usertrack version vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon casio_qv fuji kodak konica minolta mustek panasonic samsung sonydscf1 sonydscf55 toshiba" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="grub_platforms_efi-64" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Steffen Hau 2012-05-24 09:16:31 UTC
Created attachment 312931 [details]
automake.out
Comment 2 Mike Gilbert gentoo-dev 2012-05-25 13:48:53 UTC
I see bug 417353 was magically fixed for you after syncing. Do you still experience this problem with sgml-common?
Comment 3 Joel 2012-05-26 08:13:00 UTC
Happens to me too, and I've sinced 5 minutes ago
Comment 4 Joel 2012-05-26 08:35:01 UTC
Solved when changing EAPI=3 to EAPI=4 and doing and "env-update"
Comment 5 Samuli Suominen gentoo-dev 2012-05-26 08:37:00 UTC
(In reply to comment #4)
> Solved when changing EAPI=3 to EAPI=4 and doing and "env-update"

Why? That doesn't make sense.
Comment 6 Mike Gilbert gentoo-dev 2012-05-26 12:46:41 UTC
I was able to reproduce this a few times by doing the following repeatedly in a chroot environment.

emerge --depclean --with-bdeps=n
emerge -1 app-text/sgml-common

I wasn't able to make it happen consistently. Maybe a race? Not sure where to go with this.
Comment 7 Mike Gilbert gentoo-dev 2012-05-26 14:40:08 UTC
Created attachment 313139 [details]
Tarball of portage tmpdir

Here's a tarball of PORTAGE_TMPDIR taken just after this happens. If you unpack it and run automake-1.11 from sys-devel/automake-1.11.1, you should be able to reproduce the issue locally.

I'm guessing that some file has a weird mtime.
Comment 8 SpanKY gentoo-dev 2012-05-30 22:19:53 UTC
(In reply to comment #7)

the autom4te.cache dir in your build is broken.  what version of m4/autoconf are you using to create this ?
Comment 9 Mike Gilbert gentoo-dev 2012-05-30 22:55:04 UTC
(In reply to comment #8)

root@naomi ~ # equery list m4 autoconf
 * Searching for m4 ...
[IP-] [  ] sys-devel/m4-1.4.15:0

 * Searching for autoconf ...
[IP-] [  ] sys-devel/autoconf-2.68:2.5
Comment 10 Артём Воротников 2012-05-31 21:00:28 UTC
Syncing portage tree and re-emergin m4, automake, autoconf solved the bug for me.
Comment 11 Mike Gilbert gentoo-dev 2012-06-02 14:52:09 UTC
*** Bug 417011 has been marked as a duplicate of this bug. ***
Comment 12 Balint SZENTE 2012-06-07 07:46:19 UTC
Happens for me also on x86. Syncing portage tree and re-emergin m4, automake, autoconf *did not* solved the problem for me.

However disabling parallel builds works:
# MAKEOPTS="-j1" emerge -1 sgml-common

It seems that sgml-common is sensitive for parallel builds. As Mike Gilbert suggested, it might be some kind of racing condition.
Comment 13 Balint SZENTE 2012-06-07 07:53:16 UTC
False alarm. I made more tests and it is completely random. MAKEOPTS value does not matter. I did not find any pattern in the manifestation of this bug: sometimes the package compiles successfully, sometimes not.
Comment 14 SpanKY gentoo-dev 2012-06-08 05:06:08 UTC
(In reply to comment #6)

did you really need to --depclean every time ?  would just emerging sgml-common over and over not trigger it ?

(In reply to comment #9)

can you try m4-1.4.16 ?
Comment 15 cyberbat 2012-06-08 08:53:01 UTC
Same thing.

Re-emerging  m4, automake, autoconf has fixed the issue. Independent from -jX make option.
sys-devel/m4-1.4.15
sys-devel/automake-1.11.1
sys-devel/autoconf-2.68

emerge --info
Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r3, 3.2.12-gentoo x86_64)
=================================================================
System uname: Linux-3.2.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.1
Timestamp of tree: Thu, 07 Jun 2012 07:15:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo x-gsom
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3 Q3AEULA PUEL LOKI-EULA Intel-SDP"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg ccache distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS=""
GENTOO_MIRRORS="ftp://gentoo.bloodhost.ru/ ftp://xeon.gentoo.ru/mirrors/Gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j13"
PKGDIR="/var/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/gsom"
SYNC="rsync://rsync.ru.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acl acpi alsa amd64 amr audiofile bash-completion bluetooth branding bzip2 cairo cdda cddb cdio cdparanoia cdr cli consolekit cracklib crypt css cups cxx dbus declarative djvu dri dts dv dvd dvdr emboss encode exif ffmpeg firefox flac fontconfig fortran gd geoip gif gimp gmp gnutls gphoto2 gpm graphviz gsm gstreamer gtk iconv icu id3tag idn ieee1394 imagemagick imap imlib inotify iphone ipod ipv6 jabber jbig jingle jpeg jpeg2k kde kipi ladspa lame lcms libnotify libsamplerate lm_sensors lzma lzo mac mad matroska midi mikmod mjpeg mmx mmxext mng modplug modules mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz ncurses nls nptl nuv ogg openal openexr opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pppd pulseaudio qt3support qt4 quicktime rar raw readline rss rtmp sasl scanner sdl semantic-desktop session smp sndfile socks5 speex spell sqlite sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg symlink syslog taglib theora threads thumbnail tiff timidity truetype tta udev udisks unicode upower usb video vim-syntax vorbis wavpack webkit wma wmf wxwidgets x264 xcb xcomposite xface xml xmp xmpp xorg xpm xscreensaver xulrunner xv xvid zip zlib" ALSA_CARDS="hda-intel usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias asis auth_basic auth_digest authn_alias authn_anon authn_dbd authn_default authn_file authz_default authz_groupfile authz_host authz_owner authz_user autoindex cgid cern_meta dbd deflate dir dumpio env expires ext_filter filter headers imagemap include info log_config log_forensic logio mime mime_magic negotiation proxy rewrite setenvif speling status substitute unique_id userdir version vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2 canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="caps lvm gensplash" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="epson epson2" USERLAND="GNU" VIDEO_CARDS="fglrx radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 16 Balint SZENTE 2012-06-08 09:32:51 UTC
(In reply to comment #15)
> Re-emerging  m4, automake, autoconf has fixed the issue.

Are you sure that it was not just pure luck?
Try to "emerge -1 app-text/sgml-common" consecutively 10-20 times and see what happens. In my case sometimes it builds fine, sometimes not. Completely random.

When I did "emerge -e world" and failed with sgml-common, I gave the "emerge --resume" command approx. 3 times until I got "lucky" with the build.
Comment 17 Mike Gilbert gentoo-dev 2012-06-08 14:55:20 UTC
(In reply to comment #14)
> did you really need to --depclean every time ?  would just emerging
> sgml-common over and over not trigger it ?

Right. Simply emerging sgml-common over and over will eventually trigger it. Depcleaning is not necessary.

It happens quite often (1 in 5 attempts) in my chroot, which is based on a fairly recent amd64 stage3 tarball and only has stable packages installed.

I have been not been able to trigger this in my live desktop environment, which is a hodgepodge of ~1200 stable and unstable packages.
Comment 18 Mike Gilbert gentoo-dev 2012-06-08 15:25:24 UTC
Heh, I just ran emerge --sync, and can no longer reproduce this in the chroot (after 90 attempts).
Comment 19 cyberbat 2012-06-09 06:57:20 UTC
I have depcleaned system, synced portage. I have the error occasionally reemerging. 

After reemerging m4, automake, autoconf still occasionally got the error.
Comment 20 Alexey Kretov 2012-06-09 15:55:41 UTC
emerge sys-devel/automake-wrapper-7
And after that app-text/sgml-common-0.6.3-r5 shall build successfully
Comment 21 Branko 2012-06-10 13:24:55 UTC
This bug is preventing my system from completing emerge --emptytree world.

The fault does not happen with every emerge so I have broken it down a little bit to help demonstrate.  Use this command:

ebuild /usr/portage/sgml-common/sgml-common-0.6.3-r5.ebuild clean fetch unpack prepare

(I copied this by hand from my partial install to the system I'm using now so please excuse any typos).

When this command is run over and over, in about one in five cases, it will reproduce the fault.  The other times it runs just fine.  This explains the mixed results people have had in this thread.  Someone will do a sync or emerge a dependency, then emerge sgml-common with success - by luck.  Later it fails.

Bug 419741 behaves the same way.  libatomic-ops-1.2-r1 behaves the same way (I'm new to bugzilla, should I submit a bug for that ebuild as well?).

My system is x86 32 bit, Intel core 5 CPU.  Has been sync-ed a few days ago.
Comment 22 Branko 2012-06-11 07:29:07 UTC
I have traced this to a problem in autotools.eclass and raised bug 420631 against it.
Comment 23 predhomme.p 2012-06-19 07:18:15 UTC
Happens to me too, with both sgml-common and libatomic_ops.
I'm using gcc4.6 now (wanted avx support) but it happened before i upgraded gcc too.

emerge --info
Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.3, glibc-2.14.1-r3, 3.2.16-gentoo x86_64)
=================================================================
System uname: Linux-3.2.16-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Tue, 19 Jun 2012 05:45:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3 PUEL skype-eula"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ ftp://gentoo.imj.fr/pub/gentoo/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ ftp://mirrors.linuxant.fr/distfiles.gentoo.org/ http://gentoo.modulix.net/gentoo/ ftp://mirror.ovh.net/gentoo-distfiles/ http://mirror.ovh.net/gentoo-distfiles/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-j17"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 ass avx berkdb bluetooth branding bzip2 cairo cdda cdio cdr cli clutter colord consolekit corefonts cracklib crypt cups cxx dbus dri dvd dvdr emboss encode evo exif fam fat ffmpeg firefox flac fontconfig fortran gdbm gdm gif gnome gnome-keyring gnome-online-accounts gstreamer gtk gtkstyle iconv imlib inotify introspection ipv6 jack java joystick jpeg lcms libass libcanberra libnotify live mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz nautilus ncurses nls nokia nptl nsplugin ntfs ogg openal opencl opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio python3 qt3support readline reiserfs rtmp rtsp samba sdl session shared-dricore speex spell sse sse2 sse3 sse4 sse4_1 sse4a ssl ssse3 startup-notification svg tcpd theora threads thumbnail thunderbird tiff tracker truetype twolame udev udisks unicode upnp upower usb vaapi vdpau vlc vorbis webkit winbind wxwidgets x264 xcb xcomposite xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev mouse keyboard joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 24 Roman Barczyński 2012-06-28 23:27:38 UTC
(In reply to comment #20)
> emerge sys-devel/automake-wrapper-7
> And after that app-text/sgml-common-0.6.3-r5 shall build successfully

actually it fails to build because of automake-wrapper-7

downgrading to automake-wrapper-6 solved issue in my case:

[IP-] [  ] sys-devel/automake-1.11.1:1.11
[IP-] [  ] sys-devel/automake-wrapper-6:0
app-text/sgml-common-0.6.3-r5:0 << builds fine

[IP-] [  ] sys-devel/automake-1.11.1:1.11
[IP-] [  ] sys-devel/automake-wrapper-7:0
app-text/sgml-common-0.6.3-r5:0 << fails!!
Comment 25 Maciej Mrozowski gentoo-dev 2012-08-05 22:53:02 UTC
Strangely I needed to re-install automake-wrapper-7 in order to make it work (donwgrade to -6 didn't help).
Comment 26 Stefan 2012-08-12 00:19:17 UTC
(In reply to comment #10)
> Syncing portage tree and re-emergin m4, automake, autoconf solved the bug
> for me.

Works for me to. sgml-common doesn't build for some afforts, but after re-mergin m4, automake and autoconf it builds immediatly. gcc-4.6.3.

Do not mix up this bug with https://bugs.gentoo.org/show_bug.cgi?id=424041 If you have a look at /var/tmp/portage/app-text/sgml-common-0.6.3-r5/temp/automake.out you can see, that this bug prevent compiling of sgml-common at all. So if sgml-common is compiled someway and than brokes, this is another bug.
Comment 27 Stefan 2012-08-12 00:21:19 UTC
One more important fact: I don't have to sync. Just re-merge solved the issue.
Comment 28 anonymous 2012-08-31 16:09:58 UTC
> Syncing portage tree and re-emergin m4, automake, autoconf solved the bug for me.


Works for me too.

//GCC 4.7.1, amd64
Comment 29 Mike Gilbert gentoo-dev 2012-08-31 18:00:03 UTC
We don't need any more "me too" comments on this bug. The problem is sporadic, so your "solutions" are probably just coincidental.

I think we are just waiting for base-system to take some action on bug 420631.
Comment 30 Mike Gilbert gentoo-dev 2012-09-21 03:57:12 UTC
This should be fixed by the recent change to autotools.eclass.
Comment 31 Oleh 2013-01-03 04:35:47 UTC
this issue happens again. same build error and automake.out. This breaks stage builds.