Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 416919 - xfce-base/xfce4-session causes X to crash on login with external monitor
Summary: xfce-base/xfce4-session causes X to crash on login with external monitor
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: XFCE Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-21 14:27 UTC by Benn Snyder
Modified: 2015-07-05 09:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/log/slim.log after a crash (slim.log,2.70 KB, text/plain)
2012-05-21 14:29 UTC, Benn Snyder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benn Snyder 2012-05-21 14:27:51 UTC
When logging in via slim with xfce-base/xfce4-session installed and using an external monitor, X segfaults and kicks me back out to slim.
Logging in first then plugging the monitor works.  Removing xfce4-session avoids the problem altogether.

Reproducible: Always

Steps to Reproduce:
1. Install xfce-base/xfce4-meta with USE="session" (pulls in xfce-base/xfce4-session) and x11-misc/slim
2. Set XSESSION="Xfce4" and DISPLAYMANAGER="slim"
3. /etc/init.d/xdm start
4. Enter login credentials
Actual Results:  
X segfaults, and I get kicked back to slim

Expected Results:  
Should be logged into xfce4.

grep xfce /var/log/messages
May 21 09:15:32 gentoo-eee kernel: [   35.427776] xfce4-session[2324]: segfault at 8 ip 0000003fa9403abf sp 00007fff6467a970 error 4 in libstartup-notification-1.so.0.0.0[3fa9400000+9000]

emerge --info
Portage 2.1.10.49 (default/linux/amd64/10.0/desktop, gcc-4.5.3, glibc-2.14.1-r3, 3.2.12-gentoo x86_64)
=================================================================
System uname: Linux-3.2.12-gentoo-x86_64-Intel-R-_Atom-TM-_CPU_N450_@_1.66GHz-with-gentoo-2.0.3
Timestamp of tree: Sun, 20 May 2012 02:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo sabayon gamerlay-stable x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=atom -O2 -pipe -mcx16 -msahf -mmovbe --param l1-cache-size=24 --param l1-cache-line-size=64 --param l2-cache-size=512"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=atom -O2 -pipe -mcx16 -msahf -mmovbe --param l1-cache-size=24 --param l1-cache-line-size=64 --param l2-cache-size=512"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j3 --load-average=2.6 --keep-going"
FEATURES="assume-digests binpkg-logs distcc distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sabayon /var/lib/layman/gamerlay /usr/local/portage"
SYNC="rsync://system76-pc/gentoo-portage"
USE="X aac acl acpi alsa amd64 bash-completion berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cxx dbus dri dts dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gstreamer iconv ipv6 jpeg lcms libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses networkmanager nls nptl offensive ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio readline sdl session spell sse sse2 sse3 ssl ssse3 startup-notification svg tcpd threads tiff truetype udev udisks unicode upower usb v4l vaapi vorbis wifi wxwidgets x264 xcb xcomposite xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_US" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Benn Snyder 2012-05-21 14:29:13 UTC
Created attachment 312523 [details]
/var/log/slim.log after a crash
Comment 2 Samuli Suominen gentoo-dev 2012-05-21 14:49:11 UTC
(In reply to comment #0)
> 1. Install xfce-base/xfce4-meta with USE="session" (pulls in
> xfce-base/xfce4-session) and x11-misc/slim

Current stable =xfce-base/xfce4-meta-4.10 doesn't have USE="session" anymore and xfce4-session gets always installed.

Test with current stable, it's not worth continuing with this bug before. 
Xfce 4.8 is subject to be removed from Portage in favour of 4.10.
Comment 3 Benn Snyder 2012-05-21 22:31:34 UTC
Problem persists with =xfce-base/xfce-meta-4.10.0 and =xfce-base/xfce-session-4.10.0 - same errors in slim.log and /var/log/messages.  But now that session is mandatory, removing xfce-session makes login fail completely - slim reports "Failed to execute login command".
Comment 4 David Carlos Manuelda 2014-06-09 08:11:57 UTC
I have my laptop screen broken, so I use an external monitor (via HDMI) connected, and I use xfce4 without problems.

I run slim also.

I am on ~amd64 by the way, and I can't reproduce what you say.

If needed, lead me which relevant files to post and I will do.
Comment 5 David Carlos Manuelda 2014-06-09 08:12:23 UTC
P.S. I use nvidia-drivers, if relevant
Comment 6 Benn Snyder 2014-06-09 15:16:00 UTC
I use KDE now, so I don't know if this bug still exists.  I was using Intel drivers and VGA cable at the time.