Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 416827 - dev-libs/glib - CFLAGS="-fplugin=/usr/lib64/llvm/dragonegg.so" - gbitlock.c:210:3: sorry, unimplemented: 'asm goto' not supported
Summary: dev-libs/glib - CFLAGS="-fplugin=/usr/lib64/llvm/dragonegg.so" - gbitlock.c:2...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords:
: 393369 416831 (view as bug list)
Depends on:
Blocks: dragonegg-build
  Show dependency tree
 
Reported: 2012-05-21 00:29 UTC by John (EBo) David
Modified: 2015-09-03 13:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
glib-2.32.3 ebuild with USE_ASM_GOTO hack patch (glib-2.32.3-r1.ebuild,8.43 KB, text/plain)
2012-05-21 00:29 UTC, John (EBo) David
Details
a simple patch to force USE_ASM_GOTO off (USE_ASM_GOTO.patch,344 bytes, patch)
2012-05-21 00:30 UTC, John (EBo) David
Details | Diff
a good emerge info for glib-2.32.3 (good_emerge.info,5.72 KB, text/plain)
2012-05-24 00:42 UTC, John (EBo) David
Details
good build log (good_build.log,238.98 KB, text/plain)
2012-05-24 00:43 UTC, John (EBo) David
Details
emerge info for a failed glib-2.32.3 (bad_emerge.info,5.80 KB, text/plain)
2012-05-24 00:46 UTC, John (EBo) David
Details
full build.log for failing glib-2.32.3 (bad_build.log,47.70 KB, text/plain)
2012-05-24 00:47 UTC, John (EBo) David
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John (EBo) David 2012-05-21 00:29:12 UTC
Created attachment 312435 [details]
glib-2.32.3 ebuild with USE_ASM_GOTO hack patch

After a recent upgrade to gcc-4.6.3 glib failed to build with the following error:

  CC     gdataset.lo
/bin/sh ../libtool --silent --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -I.. -I../glib -I../glib -I..  -DG_LOG_DOMAIN=\"GLib\" -DG_DISABLE_CAST_CHECKS -DG_DISABLE_DEPRECATED -DGLIB_COMPILATION -DPCRE_STATIC -DG_DISABLE_SINGLE_INCLUDES -pthread  -march=native -O2 -pipe -fplugin=/usr/lib64/llvm/dragonegg.so -Wall -c -o gdataset.lo gdataset.c
gbitlock.c: In function 'g_bit_lock':
gbitlock.c:217:3: sorry, unimplemented: 'asm goto' not supported
make[4]: *** [gbitlock.lo] Error 1

I was able to fix it with a trivial patch which undefines USE_ASM_GOTO

modified ebuild and patch uploaded.

As a note, the hacks I did are not appropriate for general use, but worked in the ememergency.  I will also post a bug report with gcc concerning "asm goto" not being supported.
Comment 1 John (EBo) David 2012-05-21 00:30:39 UTC
Created attachment 312437 [details, diff]
a simple patch to force USE_ASM_GOTO off
Comment 2 Jeroen Roovers gentoo-dev 2012-05-21 19:30:38 UTC
1) Please post your `emerge --info dev-libs/glib' output in a comment.
2) Please attach the entire build log to this bug report.
Comment 3 Jory A. Pratt gentoo-dev 2012-05-22 01:55:30 UTC
Without emerge info your guessing there is a problem that does not exist. I have just successfully re-emerged glib with the following useflags using gcc-4.6.3

Portage 2.1.10.62 (hardened/linux/amd64/no-multilib/selinux, gcc-4.6.3, glibc-2.15-r2, 3.3.5-hardened x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.3.5-hardened-x86_64-Intel-R-_Core-TM-_i5_CPU_M_560_@_2.67GHz-with-gentoo-2.1
Timestamp of tree: Mon, 21 May 2012 22:30:01 +0000
app-shells/bash:          4.2_p28
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3::hardened-dev
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo anarchy mozilla hardened-dev
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -Wimplicit-function-declaration"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -Wenum-compare"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --quiet-build=y"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox selinux sesandbox sfperms sign strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common"
MAKEOPTS="-j5 -s --no-print-directory"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-z -9 -f -S .xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp/tmpfs"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/gentoo /home/mozilla /home/hardened-dev"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac alsa amd64 apng audit berkdb bidi bluetooth bzip2 cairo cdda cdio cli consolekit corefonts cracklib crypt cxx dbus djvu dri dts dvd encode faac ffmpeg flac freetype gdbm gpm gtk gtk3 hardened httpd iconv jpeg justify libffi libssh2 live lzma mad matroska mmx modules mp3 mpeg mudflap ncurses nptl nsplugin nss ogg oggvorbis open_perms opengl openmp pam pam_ssh pango pax_kernel pcre png policykit pppd python3 readline sdl selinux session spell sqlite sse sse2 sse3 sse4_1 ssl ssse3 stream svg syslog tcpd theora thunar tiff truetype udev unicode urandom usb vcd vlm vorbis vpx x264 xinerama xorg xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 sparc64 x86_64" QEMU_USER_TARGETS="i386 ppc ppc64 sparc64 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

dev-libs/glib-2.32.3 was built with the following:
USE="(selinux) -debug -doc (-fam) -static-libs -systemtap -test -utils -xattr"
Comment 4 John (EBo) David 2012-05-22 02:36:03 UTC
Jeroen & Jory, I am in the middle of re-emerging world, and want to verify that I have not changed anything since before reposting.  Sorry I forgot to post the emerge info at the time.
Comment 5 Jeroen Roovers gentoo-dev 2012-05-23 13:32:36 UTC
*** Bug 416831 has been marked as a duplicate of this bug. ***
Comment 6 John (EBo) David 2012-05-24 00:42:20 UTC
Created attachment 312895 [details]
a good emerge info for glib-2.32.3

builds correctly with dragonegg lib removed.
Comment 7 John (EBo) David 2012-05-24 00:43:13 UTC
Created attachment 312897 [details]
good build log

builds correctly with dragonegg lib removed.
Comment 8 John (EBo) David 2012-05-24 00:46:43 UTC
Created attachment 312899 [details]
emerge info for a failed glib-2.32.3

with CFLAGS="${CFLAGS} -fplugin=/usr/lib64/llvm/dragonegg.so" included in the make.conf it fails with asm goto not supported.
Comment 9 John (EBo) David 2012-05-24 00:47:58 UTC
Created attachment 312901 [details]
full build.log for failing glib-2.32.3

with CFLAGS="${CFLAGS} -fplugin=/usr/lib64/llvm/dragonegg.so" included in the make.conf it fails with asm goto not supported.
Comment 10 Bernard Cafarelli gentoo-dev 2012-09-28 13:04:05 UTC
*** Bug 393369 has been marked as a duplicate of this bug. ***
Comment 11 Bernard Cafarelli gentoo-dev 2015-09-03 13:41:10 UTC
Last rites for sys-devel/dragonegg in progress, bug #543644