Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 41652 - New ebuild (xsp-0.9.ebuild)
Summary: New ebuild (xsp-0.9.ebuild)
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: dotnet
URL: http://www.go-mono.com/asp-net.html#xsp
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks: 41655
  Show dependency tree
 
Reported: 2004-02-15 05:18 UTC by Chris Laverty
Modified: 2004-05-21 13:20 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xsp-0.9.ebuild (xsp-0.9.ebuild,574 bytes, text/plain)
2004-02-15 05:18 UTC, Chris Laverty
Details
xsp-0.9.ebuild (xsp-0.9.ebuild,660 bytes, text/plain)
2004-02-21 12:59 UTC, aent
Details
xsp.confd ( /etc/conf.d/xsp ) (xsp.confd,205 bytes, text/plain)
2004-02-21 13:07 UTC, aent
Details
xsp.initd ( /etc/init.d/xsp ) (xsp.initd,549 bytes, text/plain)
2004-02-21 13:09 UTC, aent
Details
xsp-0.9.ebuild (xsp-0.9.ebuild,880 bytes, text/plain)
2004-02-22 07:43 UTC, Chris Laverty
Details
xsp.initd ( /etc/init.d/xsp ) (xsp.initd,584 bytes, text/plain)
2004-02-22 07:45 UTC, Chris Laverty
Details
xsp-0.11.ebuild (xsp-0.11.ebuild,664 bytes, text/plain)
2004-04-21 18:18 UTC, aent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Laverty 2004-02-15 05:18:11 UTC
XSP is a small web server that hosts Mono's ASP.NET implementation.  It is required for mod_mono, which I will be submitting separately.

I suggest dev-dotnet/xsp as this is the name referenced in the mod_mono ebuild.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Chris Laverty 2004-02-15 05:18:52 UTC
Created attachment 25655 [details]
xsp-0.9.ebuild
Comment 2 aent 2004-02-21 12:59:54 UTC
Created attachment 26059 [details]
xsp-0.9.ebuild

I believe XSP is under the GPL-2 license, also I modified it to create an
init.d scripts, attaching new ebuild and files...
Comment 3 aent 2004-02-21 13:07:19 UTC
Created attachment 26060 [details]
xsp.confd ( /etc/conf.d/xsp )
Comment 4 aent 2004-02-21 13:09:50 UTC
Created attachment 26061 [details]
xsp.initd ( /etc/init.d/xsp )
Comment 5 Chris Laverty 2004-02-22 07:43:58 UTC
Created attachment 26104 [details]
xsp-0.9.ebuild

New version incorporates changes from aent and now runs as unprivileged user
aspnet
Comment 6 Chris Laverty 2004-02-22 07:45:39 UTC
Created attachment 26105 [details]
xsp.initd ( /etc/init.d/xsp )

Add --chuid
Comment 7 aent 2004-04-21 18:18:51 UTC
Created attachment 29783 [details]
xsp-0.11.ebuild

Version bump
Comment 8 Stuart Herbert (RETIRED) gentoo-dev 2004-04-23 05:26:37 UTC
One for the dotnet team?

Stu
Comment 9 aent 2004-04-28 19:38:25 UTC
xsp-0.12 is just another version bump, no changed to the ebuild are necessary at all for it either... 
Comment 10 Martin Honermeyer 2004-05-10 08:41:06 UTC
little changes for xsp-0.13. It works. Even Webservices now work for me!

One problem though: the files from /usr/share/doc/xsp/test/bin get copied to /usr/share/xsp/doc/test/bin/ - should be easy to fix.

xsp now depends on mono-0.91 (because it belongs to mono beta1). So DEPEND has to be changed to "">=dev-dotnet/mono-0.91". This also means the path in the SRC_URI has to be changed ("http://www.go-mono.com/archive/beta1/${P}.tar.gz").

Martin
Comment 11 Peter Johanson (RETIRED) gentoo-dev 2004-05-21 13:20:34 UTC
Hey all,

Just added this in, with only minor changes. Thanks for all the work on the ebuilds. I've added a dodoc for some docs, and changed the new user's shell to /bin/false. I've found no reason to give that user a real shell, if someone can find reason otherwise, open a new bug with the info.

Please test and report back succcess/failure. I'll mark this closed then.