Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 416291 - media-libs/libvpx-1.1.0 - In function `vp8_machine_specific_config': systemdependent.c:(.text+0xbb): undefined reference to `pthread_once'
Summary: media-libs/libvpx-1.1.0 - In function `vp8_machine_specific_config': systemde...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 446788 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-16 17:20 UTC by Oschtan
Modified: 2013-12-08 00:46 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,138.29 KB, text/plain)
2012-05-16 17:21 UTC, Oschtan
Details
build.log (build.log,194.73 KB, text/plain)
2012-05-21 13:57 UTC, Andrew Savchenko
Details
environment (environment,72.84 KB, text/plain)
2012-05-21 13:58 UTC, Andrew Savchenko
Details
emerge --info (emerge.info,8.29 KB, text/plain)
2012-05-21 14:00 UTC, Andrew Savchenko
Details
build.log from emerge using CFLAGS="-pthread" (build.log,149.21 KB, text/plain)
2013-04-22 12:43 UTC, Thomas Beutin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oschtan 2012-05-16 17:20:19 UTC
echo 'Conflicts:' >> vpx.pc
echo 'Libs: -L${libdir} -lvpx' >> vpx.pc
echo 'Cflags: -I${includedir}' >> vpx.pc
vp8/common/generic/systemdependent.c.o: In function `vp8_machine_specific_config':
systemdependent.c:(.text+0xbb): undefined reference to `pthread_once'
collect2: ld returned 1 exit status
make[1]: *** [libvpx.so.1.1.0] Error 1
make: *** [.DEFAULT] Error 2

USE="mmx sse sse2 sse3"

Reproducible: Always




emerge --info
Portage 2.2.0_alpha105 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r1, 3.3.3-gentoo x86_64)
=================================================================
System uname: Linux-3.3.3-gentoo-x86_64-AMD_Phenom-tm-_8450_Triple-Core_Processor-with-gentoo-2.1
Timestamp of tree: Tue, 15 May 2012 19:45:01 +0000
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.15-r1
Repositories: gentoo overlays-oschtan
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL skype-eula googleearth AdobeFlash-10.3 google-talkplugin google-chrome Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS=" -O2 -pipe -march=amdfam10 -mtune=amdfam10"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/red5/conf /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/red5-webapps"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS=" -O2 -pipe -march=amdfam10 -mtune=amdfam10"
DISTDIR="/mnt/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg candy collision-protect distlocks ebuild-locks fixlafiles metadata-transfer news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,--hash-style=gnu,-O1 -Wl,--as-needed"
LINGUAS="ru"
MAKEOPTS="-j4"
PKGDIR="/mnt/gentoo/package"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/gentoo"
PORTDIR="/mnt/gentoo/gentoo-tree"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://linux.rz.ruhr-uni-bochum.de/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aacplus aalib acpi action_modeswitch additions alsa amd64 amr ao ape auto-hinter berkdb bzip2 cairo cgi cleartype cli consolekit cracklib crypt ctype curl custom-cflags cxx dbus declarative demos development djvu dri dv dvd emerald enca encode exif extras faac fastcgi fbcondecor ffmpeg fontconfig fortran ftp fuse gd gecko gecko-mediaplayer gif git glitz gphoto2 gpm gstreamer gtk3 gudev hddtemp iconv imlib jabber java jbig jpeg jpeg2k kde kvm lame lastfm latin1 lcms libkms libnotify lm_sensors lzma mad mikmod mjpeg mmx mmxext mng mod modules mp3 mp4 mpeg mplayer mudflap multilib multitarget mysql natspec ncurses nls npp nptl nsplugin objc objc++ objc-gc ogg openexr opengl openmp oscar pam pcre pdf perl php plasma png policykit povray pppd prison pulse pulseaudio python python3 qt3support qt4 rar rcc readline realtime reflection rtc sdk sdl sensord session skey slang sndfile source speex spell spl sqlite sqlite3 srt sse sse2 sse3 sse4a ssl startup-notification suid svg symlink syslog system-wide taglib tcpd templates theora thumbnail tidy tiff truetype udev udisks unicode unsupported uploadprogress usb vcd vde vdpau video vorbis vpx webdav-neon wxwidgets x264 xattr xcb xcomposite xml xorg xpm xscreensaver xv xvid xvmc yv12 zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" CAMERAS="kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru" PHP_TARGETS="php5-4" PYTHON_TARGETS="python3_2 python2_7" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Oschtan 2012-05-16 17:21:14 UTC
Created attachment 312027 [details]
build.log
Comment 2 Andrew Savchenko gentoo-dev 2012-05-21 13:57:11 UTC
The same problem here on ~x86.
Comment 3 Andrew Savchenko gentoo-dev 2012-05-21 13:57:47 UTC
Created attachment 312511 [details]
build.log
Comment 4 Andrew Savchenko gentoo-dev 2012-05-21 13:58:01 UTC
Created attachment 312513 [details]
environment
Comment 5 Andrew Savchenko gentoo-dev 2012-05-21 14:00:42 UTC
Created attachment 312515 [details]
emerge --info
Comment 6 Andrew Savchenko gentoo-dev 2012-05-21 14:09:24 UTC
With USE="-threads" the packages shouldn't use pthread at all, but it does.
As a temporary workaround with USE="threads" it builds fine.
Comment 7 Ostashevskyi Viktor 2012-05-23 12:14:09 UTC
I could see same problem:

vp8/common/generic/systemdependent.c.o: In function `vp8_machine_specific_config':
systemdependent.c:(.text+0xd9): undefined reference to `pthread_once'
collect2: ld returned 1 exit status
Comment 8 Samuli Suominen (RETIRED) gentoo-dev 2013-01-15 22:36:33 UTC
*** Bug 446788 has been marked as a duplicate of this bug. ***
Comment 9 Samuli Suominen (RETIRED) gentoo-dev 2013-01-15 22:37:22 UTC

*** This bug has been marked as a duplicate of bug 405813 ***
Comment 10 Andrew Savchenko gentoo-dev 2013-01-16 08:00:35 UTC
This is not a dup of a bug 405813, because in my case ssse3 USE flag is never used nor supported by the hardware affected.
Comment 11 Samuli Suominen (RETIRED) gentoo-dev 2013-01-16 08:07:38 UTC
it really is the same despite of your flags, the build systems lacks -pthread in both cases

you can try CFLAGS="-pthread" and it should compile
Comment 12 Samuli Suominen (RETIRED) gentoo-dev 2013-01-16 08:11:25 UTC
or USE="threads". propably the package shouldn't have such USE flag at all
Comment 13 Samuli Suominen (RETIRED) gentoo-dev 2013-01-16 08:12:00 UTC
sorry, you are right, wrong duplication
Comment 14 Thomas Beutin 2013-04-22 12:41:04 UTC
CFLAGS="-pthread" does not work (see attached build.log)
Comment 15 Thomas Beutin 2013-04-22 12:43:51 UTC
Created attachment 346288 [details]
build.log from emerge using CFLAGS="-pthread"
Comment 16 Luca Barbato gentoo-dev 2013-04-25 07:44:39 UTC
tests must be disable in that situation... I reported the issue upstream long ago and forgot to fix in the ebuild =|
Comment 17 Alexis Ballier gentoo-dev 2013-06-25 20:54:58 UTC
fixed in libvpx-1.2.0_pre20130625
Comment 18 Steev Klimaszewski (RETIRED) gentoo-dev 2013-12-08 00:46:45 UTC
This is fixed in the 1.2 ebuild but still exists on ARM in 1.1.0 as of glibc 2.16.  Is the 1.2 build going to go stable at some point, and if not, can we get the fix backported to 1.1.0?