Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 415367 - app-office/libreoffice selecting part of a file name does not work when using "LibreOffice file dialogs"
Summary: app-office/libreoffice selecting part of a file name does not work when using...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-10 12:35 UTC by Joe Breuer
Modified: 2014-10-24 20:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Breuer 2012-05-10 12:35:36 UTC
When LibreOffice is configured to use its own file dialog implementations, text within the file name cannot be selected with the mouse.
The LibreOffice implementation of the file dialogs is required to properly support working with files on WebDAV - a dialog "you can only select local files" comes up when using the KDE dialogs. The problem can be reproduced with local files as well (no WebDAV required); only the LibreOffice dialogs need to be enabled.

This specific report concerns app-office/libreoffice-3.5.2.2; but the problem exists for some time (I'd say about a year) now.

A nasty impact is the necessary education of non-technical end users.


Reproducible: Always

Steps to Reproduce:
1. Install app-office/libreoffice
2. In Tools -> Options, LibreOffice -> General, enable "Open/Save dialogs": "Use LibreOffice dialogs"
3. Open a file dialog, i.e. File -> Open...
4. Select a file in the upper pane
5. Try to select text in the "File name:" field below, using the mouse
Actual Results:  
No selection paradigms work (drag, double-/triple click). Instead, any click in this field will drop down the field's history list.
Selecting text using the keyboard (arrow keys, hold Shift to select) works correctly.

Expected Results:  
Selecting text within the file name using the mouse works as usual.
The history is only opened when clicking the drop-down icon on the far right.

The problem is observed in a KDE desktop (kdebase-meta-4.8.1), with the Oxygen widget style (x11-themes/oxygen-molecule-3.2).

app-office/libreoffice-3.5.2.2 USE flags: +binfilter +branding +cups +dbus -eds -gnome +graphite +gstreamer +gtk +java -jemalloc +kde -mysql -nlpsolver +nsplugin -odk +opengl -pdfimport -postgres +svg -test +vba +webdav +xmlsec

emerge --info:
Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r3, 3.2.12-gentoo x86_64)
=================================================================
System uname: Linux-3.2.12-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_970_@_3.20GHz-with-gentoo-2.0.3
Timestamp of tree: Wed, 09 May 2012 08:45:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo LOCAL jmbreuer
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=core2 -maes -mcx16 -msahf -mpclmul -mpopcnt -msse4.2 -O2 -pipe -momit-leaf-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /usr/share/X11/xkb"
CXXFLAGS="-march=core2 -mtune=core2 -maes -mcx16 -msahf -mpclmul -mpopcnt -msse4.2 -O2 -pipe -momit-leaf-frame-pointer"
DISTDIR="/storage/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y --jobs=64 --load-average=16"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://gentoo.mneisen.org/ http://gentoo.wheel.sk/ http://gentoo.mirror.pw.edu.pl/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="--jobs=64 --load-average=18"
PKGDIR="/storage/portage/packages/x64cd"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/jmbreuer"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr chardet cjk cli consolekit cracklib crypt css cups curl cxx dbus declarative dga dri dts dv dvd dvdr embedded emboss encode exif fam fame fastcgi ffmpeg firefox flac flash fluidsynth fontconfig foomaticdb fortran gcj gd gdbm gdu gif gimp glitz glut gnutls gphoto2 gpm gstreamer gtk iconv icu ieee1394 imap imlib innodb iphone ipod ipv6 java jce jpeg kde kerberos kipi kpathsea lame lastfm lcms ldap leim libgda libnotify libsamplerate lm_sensors lzo mad mbox mikmod mjpeg mmx mmxext mng modplug modules mono mp3 mp4 mpeg mtp mudflap mule multilib ncurses network network-cron nis nls nptl nsplugin nspluginwrapper nvidia offensive ogg openexr opengl openmp pam pango pcap pcre pda pdf phonon plasma plotutils png policykit ppds pppd qt3support qt4 rdesktop readline rtc samba sasl scanner sdk sdl semantic-desktop session shout slang slp smp sndfile socks5 sound sox spell sqlite sse sse2 ssl ssse3 startup-notification subversion svg tcpd theora threads tiff tk truetype trusted udev unicode usb vdpau vim-syntax vnc vorbis webdav wma wmf wxwidgets x264 xanim xcb xcomposite xiph xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse wacom evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="net" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2013-04-27 11:05:36 UTC
Hi,
firstly sorry that I completely missed this bug.

The issue you are describing seems to be there, viz video.

http://dev.gentooexperimental.org/~scarabeus/libreo-file.ogv
Comment 2 Andreas K. Hüttel gentoo-dev 2013-12-27 19:27:23 UTC
Is this problem still present in current versions? 

If yes, could you please file a bug at the libreoffice buzilla and link to it here?
https://bugs.freedesktop.org/
Comment 3 Joe Breuer 2013-12-28 16:01:31 UTC
The problem is still there in (my) current stable 4.1.2.3.

I've filed a bug with freedesktop.org as https://bugs.freedesktop.org/show_bug.cgi?id=73103


I just noticed that the slightly newer 4.1.3.2-r2 is now stable for amd64; I'll try to remember to drop a comment here when I upgrade (within the next few days, presumably).
Comment 4 Joe Breuer 2013-12-29 07:44:41 UTC
The issue is still unchanged in 4.1.3.2-r2, with KDE 4.11.2 / Qt 4.8.5 (all current stable amd64 as of yesterday afternoon).
Comment 5 Andreas K. Hüttel gentoo-dev 2014-10-24 20:50:14 UTC
Fixed according to upstream bug.