Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 41532 - gtk-sharp-0.16 won't compile because of mscorlib.dll
Summary: gtk-sharp-0.16 won't compile because of mscorlib.dll
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
: 41533 41534 41535 41536 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-02-13 22:33 UTC by Mike Douglas
Modified: 2011-08-06 13:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Douglas 2004-02-13 22:33:53 UTC
When I try to compile gtk-sharp i get this error. I have mono 0.30 installed (from ebuilds in cvs).

The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/local/lib' directory.
make[1]: *** [gapi-fixup.exe] Error 1
make[1]: Leaving directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/parser'
make: *** [native] Error 1
 
!!! ERROR: x11-libs/gtk-sharp-0.16 failed.
!!! Function src_compile, Line 52, Exitcode 2
!!! (no error message)


Reproducible: Always
Steps to Reproduce:
1. emerge mono
2. emerge gtk-sharp
Actual Results:  
emerge of gtk-sharp-0.16 fails

Expected Results:  
gtk-sharp-0.16 compiles correctly
Comment 1 Mike Douglas 2004-02-13 22:39:46 UTC
*** Bug 41536 has been marked as a duplicate of this bug. ***
Comment 2 Mike Douglas 2004-02-13 22:40:17 UTC
*** Bug 41535 has been marked as a duplicate of this bug. ***
Comment 3 Mike Douglas 2004-02-13 22:40:40 UTC
*** Bug 41534 has been marked as a duplicate of this bug. ***
Comment 4 Mike Douglas 2004-02-13 22:41:03 UTC
*** Bug 41533 has been marked as a duplicate of this bug. ***
Comment 5 Todd Berman (RETIRED) gentoo-dev 2004-02-13 23:25:04 UTC
sounds like you have an old mono install around somewhere, ever installed from a tarball, cvs or any non-ebuild source?
Comment 6 Rene Androsch 2004-02-23 08:38:40 UTC
I have mono.30.1-r1 (with manually patch make stuff) -> now I have a mono 30.1-r1 that compiles error free. But gtk-sharp still fails:

make[1]: Leaving directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/gda'
make[1]: Entering directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/gnomedb'
make[1]: Nothing to be done for `install'.
make[1]: Leaving directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/gnomedb'
make[1]: Entering directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/gconf'
for i in GConf GConf.PropertyEditors tools; do \
        make -C $i install || exit 1; \
done
make[2]: Entering directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/gconf/GConf'
mcs ClientBase.cs Client.cs ChangeSet.cs _Entry.cs NoSuchKeyException.cs NotifyEventArgs.cs NotifyEventHandler.cs NotifyWrapper.cs Value.cs  -L ../../glib /r:glib-sharp.dll /target:library /out:gconf-sharp.dll
Compilation succeeded
../../mkinstalldirs /var/tmp/portage/gtk-sharp-0.16/image//usr/lib && \
cp gconf-sharp.dll /var/tmp/portage/gtk-sharp-0.16/image//usr/lib
make[2]: Leaving directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/gconf/GConf'
make[2]: Entering directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/gconf/GConf.PropertyEditors'
mcs PropertyEditor.cs PropertyEditorBool.cs PropertyEditorColorPicker.cs PropertyEditorEnum.cs PropertyEditorEntry.cs PropertyEditorFileEntry.cs PropertyEditorOptionMenu.cs PropertyEditorRadioButton.cs PropertyEditorSpinButton.cs PropertyEditorToggleButton.cs EditorShell.cs  -L ../../glib -L ../../pango -L ../../atk -L ../../gdk -L ../../gtk -L ../../art -L ../../gnome -L ../GConf -L ../../glade /r:glib-sharp.dll /r:pango-sharp.dll /r:atk-sharp.dll /r:gdk-sharp.dll /r:gtk-sharp.dll /r:art-sharp.dll /r:gnome-sharp.dll /r:glade-sharp.dll /r:gconf-sharp.dll /r:System.Drawing /target:library /out:gconf-sharp-peditors.dll
error CS0006: Cannot find assembly `gnome-sharp.dll'
Log:

Compilation failed: 1 error(s), 0 warnings
make[2]: *** [gconf-sharp-peditors.dll] Error 1
make[2]: Leaving directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/gconf/GConf.PropertyEditors'
make[1]: *** [install] Error 1
make[1]: Leaving directory `/var/tmp/portage/gtk-sharp-0.16/work/gtk-sharp-0.16/gconf'
make: *** [install-binding] Error 1

!!! ERROR: x11-libs/gtk-sharp-0.16 failed.
!!! Function einstall, Line 388, Exitcode 2
!!! einstall failed
Comment 7 Rene Androsch 2004-02-23 11:32:42 UTC
I got it to compile error free, by using all 4 USE flags. Since I'm a KDE user, I don't tend to use USE flags that sound like gnome or gtk. But since I needed a GUI for mono, I have too...
Comment 8 Rainer Größlinger (RETIRED) gentoo-dev 2004-08-01 05:28:48 UTC
Can the bug reporter please comment if this is still an issue?
This bug is already 6 months old and chances are good it solved automagically ;)
Comment 9 Rainer Größlinger (RETIRED) gentoo-dev 2004-08-31 04:32:15 UTC
Mike, you are still with us? ;)
Comment 10 Peter Johanson (RETIRED) gentoo-dev 2004-09-19 13:36:55 UTC
Okay, marking CANTFIX. Mike, feel free to re-open if it's still a problem.
Comment 11 Bertrand Jacquin 2011-08-06 13:57:29 UTC
This append when USE=hardened