Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 414419 - net-analyzer/cacti-0.8.8a version bump with trivial prefix patch and ~arm
Summary: net-analyzer/cacti-0.8.8a version bump with trivial prefix patch and ~arm
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement with 2 votes (vote)
Assignee: Gentoo Netmon project
URL: http://www.cacti.net/changelog.php
Whiteboard:
Keywords:
: 467480 (view as bug list)
Depends on:
Blocks: prefix-gx86
  Show dependency tree
 
Reported: 2012-05-02 21:39 UTC by Jaak Ristioja
Modified: 2013-04-27 15:09 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
cacti-0.8.8a.patch (cacti.patch,923 bytes, patch)
2012-05-06 12:51 UTC, Benda Xu
Details | Diff
Enhanced Ebuild also installing some plugins (cacti-0.8.8a.ebuild,9.16 KB, text/plain)
2013-01-03 09:16 UTC, Jens Ott
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaak Ristioja 2012-05-02 21:39:22 UTC
Cacti® 0.8.8a is out. Please bump!
Comment 1 Benda Xu gentoo-dev 2012-05-06 12:51:50 UTC
Created attachment 310971 [details, diff]
cacti-0.8.8a.patch

How, this is a trivial patch for Prefix. Please review. If there is no objection, may I bump the version and apply the patch? Thanks in advance.
Comment 2 Martin Samek 2012-06-06 12:44:45 UTC
Hi, tested and works for me. Please bump. Cacti 8.8 also includes Plugin Architecture 3.1.
Comment 3 Benda Xu gentoo-dev 2012-06-06 14:30:01 UTC
It seems that pva has been stalled for a while.

There are some issues I am not clear of, before which I could become a co-maintainer and commit:

a. in GLEP 11[1], it status that config files of webapp should go to /etc/webapp/${PF}. Should /usr/share/webapps/cacti/0.8.8a/htdocs/include/config.php (for setting mysql db user/password) go to /etc/webapp instead?
b. from webapp.eclass[2], we can declare a file as config-protect with "webapp_configfile". Is this intened to be difference from GLEP 11? 

@webapp herd, could you please comment on the above questions?

1. http://www.gentoo.org/proj/en/glep/glep-0011.html
2. http://devmanual.gentoo.org/eclass-reference/webapp.eclass/index.html
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester gentoo-dev Security 2012-06-06 14:36:07 UTC
Your questions went to /dev/null. JFYI.

(In reply to comment #3)
> @webapp herd, could you please comment on the above questions?

09:33 <darkside_> !expn webapps-request
09:33 <willikins> webapps-request = maintainer-wanted,
Comment 5 Christoph Junghans gentoo-dev 2012-08-22 15:38:58 UTC
I guess EAPI also needs to be bumped to at least 3.
Comment 6 Jens Ott 2013-01-03 09:16:41 UTC
Created attachment 334150 [details]
Enhanced Ebuild also installing some plugins

I enhanced the ebuild to also install plugins based on use-flags. I added all plugins from cacti-plugin-page which I got working without any problems.
Comment 7 Kfir Ozer 2013-01-06 06:50:23 UTC
there's a bug there was in the old ebuild as well regarding adodb.
to resolve i need to do the following.

cd /usr/share/php/adodb/
ln -s /usr/share/php/adodb drivers

if not I got the error:
Missing file: /usr/share/php/adodb/drivers/adodb-mysql.inc.php

besides that...
amazing ebuild
thanks so much!
Comment 8 Kfir Ozer 2013-01-06 07:44:57 UTC
well actually I have a problem with cacti. instead of graphs I see question marks. trying to investigate.
Comment 9 Kfir Ozer 2013-01-06 17:07:47 UTC
ok everything works.. giving it just five minutes wasn't enough for some reason. went through the configuration made sure that rrd tool version matches like that FAQ stated and everything is working. yay!
Comment 10 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2013-02-05 03:26:20 UTC
If you want to test cacti-0.8.8a[1] you can grab it from my overlay[2].

 [1] - http://git.overlays.gentoo.org/gitweb/?p=dev/jmbsvicetto.git;a=blob_plain;f=net-analyzer/cacti/cacti-0.8.8a.ebuild;hb=refs/heads/master
 [2] - http://git.overlays.gentoo.org/gitweb/?p=dev/jmbsvicetto.git

(In reply to comment #6)
> Created attachment 334150 [details]
> Enhanced Ebuild also installing some plugins
> 
> I enhanced the ebuild to also install plugins based on use-flags. I added
> all plugins from cacti-plugin-page which I got working without any problems.

I've reviewed your ebuild while doing my local bump. I have a few issues with it:

 * don't use cd but pushd and popd
 * we should use separate ebuilds for the plugins
 * that solves all the hardcoded plugin versions in the ebuild
 * the src_unpack version is too large and repetitive - it would help adding an auxiliar function
 * the plugins need a thorough revision to verify their license
 * and finally some of them seem questionable

An example for the last point is plugin\:flowview-v1.1-1.tgz which includes almost 1MB of RPMs for CentOS5.
Comment 11 Jeroen Roovers (RETIRED) gentoo-dev 2013-04-27 13:53:16 UTC
*** Bug 467480 has been marked as a duplicate of this bug. ***
Comment 12 Peter Volkov (RETIRED) gentoo-dev 2013-04-27 15:09:30 UTC
Finally bumped.

As for plugins: maintaining them will be really hard, since there is no chance anybody will test all this plugins for compatibility with new cacti version. So I think best solution will be provide user with configurable path to install plugins and leave it as is. For example, it looks like it's possible to define variable somewhere make.conf or /etc/portage/env file, like:

CACTI_PLUGINS="( "plugin_name%URL" )"

and based on this variable ebuild will download and install plugin during installation process. Not best solution, but still better then nothing.

As for EPREFIX changes - i think they should go to webapp.eclass.