Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 414185 - app-text/xiphos-3.1.5 segmentation fault
Summary: app-text/xiphos-3.1.5 segmentation fault
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Theology Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-30 22:36 UTC by Peter Fox
Modified: 2017-12-03 14:39 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info on machine where xiphos-3.1.5 segvs on startup (emerge-info-xiphos.txt,5.90 KB, text/plain)
2012-04-30 22:36 UTC, Peter Fox
Details
emerge --info on machine where xiphos-3.1.5 works fine (emerge-info-xiphos-works.txt,6.03 KB, text/plain)
2012-04-30 22:37 UTC, Peter Fox
Details
gdb session from second machine xiphos segvs on (xiphos-gdb.txt,1.74 KB, text/plain)
2012-04-30 22:46 UTC, Peter Fox
Details
emerge --info on second machine where xiphos-3.1.5 segvs on startup (emerge-info-xiphos-bad2.txt,5.91 KB, text/plain)
2012-04-30 22:47 UTC, Peter Fox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Fox 2012-04-30 22:36:59 UTC
Created attachment 310531 [details]
emerge --info on machine where xiphos-3.1.5 segvs on startup

On some of my machines xiphos-3.1.5 gives a seqv during startup. Of the three machines I've tried, 2 do this. Running under gdb I get:

$ gdb xiphos
GNU gdb (Gentoo 7.3.1 p2) 7.3.1
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/xiphos...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/xiphos 
[Thread debugging using libthread_db enabled]
Gtk-Message: Failed to load module "gnomesegvhandler"
[New Thread 0xb334fb70 (LWP 18051)]
[New Thread 0xb28e3b70 (LWP 18052)]

Program received signal SIGSEGV, Segmentation fault.
__strlen_sse2_bsf () at ../sysdeps/i386/i686/multiarch/strlen-sse2-bsf.S:52
52	../sysdeps/i386/i686/multiarch/strlen-sse2-bsf.S: No such file or directory.
	in ../sysdeps/i386/i686/multiarch/strlen-sse2-bsf.S
(gdb) bt
#0  __strlen_sse2_bsf () at ../sysdeps/i386/i686/multiarch/strlen-sse2-bsf.S:52
#1  0xb7e8a750 in g_strdup () from /usr/lib/libglib-2.0.so.0
#2  0x66666666 in ?? ()
#3  0x00000018 in ?? ()
#4  0xb7f2eff4 in ?? () from /usr/lib/libglib-2.0.so.0
#5  0xb79a722e in gtk_style_properties_set () from /usr/lib/libgtk-3.so.0
#6  0xb79360d0 in ?? () from /usr/lib/libgtk-3.so.0
#7  0xb7a6e8ce in gtk_widget_override_font () from /usr/lib/libgtk-3.so.0
#8  0xb7a6e957 in gtk_widget_modify_font () from /usr/lib/libgtk-3.so.0
#9  0x0809b7db in HtmlOutput ()
#10 0x08ee6300 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
(gdb)
Comment 1 Peter Fox 2012-04-30 22:37:55 UTC
Created attachment 310533 [details]
emerge --info on machine where xiphos-3.1.5 works fine
Comment 2 Peter Fox 2012-04-30 22:46:55 UTC
Created attachment 310535 [details]
gdb session from second machine xiphos segvs on
Comment 3 Peter Fox 2012-04-30 22:47:44 UTC
Created attachment 310537 [details]
emerge --info on second machine where xiphos-3.1.5 segvs on startup
Comment 4 Pacho Ramos gentoo-dev 2017-12-03 14:39:26 UTC
Please retry with 4.0.6a