Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 41402 - lesspipe-1.37.ebuild (New Package)
Summary: lesspipe-1.37.ebuild (New Package)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Ciaran McCreesh
URL:
Whiteboard:
Keywords:
: 104330 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-02-12 11:13 UTC by Moshe Kamensky
Modified: 2005-08-31 02:55 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
lesspipe ebuild (lesspipe-1.37.ebuild,1.32 KB, text/plain)
2004-02-12 11:15 UTC, Moshe Kamensky
Details
env.d file for setting of LESSOPEN (71lesspipe,336 bytes, text/plain)
2004-02-12 11:18 UTC, Moshe Kamensky
Details
env.d file for lesspipe (71lesspipe.bidiv,356 bytes, text/plain)
2004-02-12 11:20 UTC, Moshe Kamensky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Moshe Kamensky 2004-02-12 11:13:58 UTC
This is an ebuild for the lesspipe.sh program, to be used with less(1).
Comment 1 Moshe Kamensky 2004-02-12 11:15:32 UTC
Created attachment 25487 [details]
lesspipe ebuild
Comment 2 Ciaran McCreesh 2004-02-12 11:18:00 UTC
Either your RDEPEND and IUSE are wrong or your src_compile needs fixing.
Comment 3 Moshe Kamensky 2004-02-12 11:18:26 UTC
Created attachment 25488 [details]
env.d file for setting of LESSOPEN

Put in the files subdirectory
Comment 4 Moshe Kamensky 2004-02-12 11:20:14 UTC
Created attachment 25489 [details]
env.d file for lesspipe

put in the files subdirectory
Comment 5 Thomas Eckert 2004-02-12 11:50:33 UTC
on my system there is a /usr/bin/lesspipe.sh (belongs to sys-apps/less-381) ... *dig thru system* ...
ahh, at the momemt lesspipe.sh is installed from FILESDIR of the less-package.

if this package is added the less-ebuild needs to be changed too.

in *my opinion* it's a bit of a overkill to add a separate ebuild for a single
script -- adding the homepage and env.d-vars for lesspipe to the ebuild and env.d
files of the less-ebuild would be nicer. just my 2c
Comment 6 Ciaran McCreesh 2004-03-08 16:39:40 UTC
Closing this as WONTFIX as the existing lesspipe seems to do its job. If you *really* want this in portage, please fix up the src_compile.
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-08-31 02:55:56 UTC
*** Bug 104330 has been marked as a duplicate of this bug. ***