Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 413815 - Stabilize dev-libs/boost-1.48.0-r2 and reverse dependencies
Summary: Stabilize dev-libs/boost-1.48.0-r2 and reverse dependencies
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: C++ Team [disbanded]
URL:
Whiteboard:
Keywords: STABLEREQ
: 398507 (view as bug list)
Depends on: 401551 407433 413807 413813 qt-4.8.1-stable 432558
Blocks: 416723 417427 420885
  Show dependency tree
 
Reported: 2012-04-28 01:34 UTC by Arfrever Frehtes Taifersar Arahesis
Modified: 2012-10-31 16:51 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis 2012-04-28 01:34:35 UTC
List of packages for stabilization:

dev-libs/boost-1.48.0-r1
dev-util/boost-build-1.48.0-r1
dev-python/cgkit-2.0.0_alpha9-r1
dev-python/tagpy-0.94.8-r1
dev-python/visual-5.72-r2
net-libs/rb_libtorrent-0.15.10
sci-libs/cctbx-2010.03.29.2334-r6

Reverse dependencies of Boost should be stabilized quickly after stabilization of Boost.

Maintainers of packages have been added to CC list. If there are no objections, then stabilization will start in 1 week.
Comment 1 Agostino Sarubbo gentoo-dev 2012-04-28 11:49:58 UTC
If maintainers agre with stabilization, I will start ASAP, a rebuild of all boost reverse depend.
Comment 2 Justin Lecher (RETIRED) gentoo-dev 2012-04-28 11:51:18 UTC
sci is fine
Comment 3 Dirkjan Ochtman gentoo-dev 2012-04-28 15:19:09 UTC
python is fine as well.
Comment 4 Davide Pesavento gentoo-dev 2012-04-28 16:21:11 UTC
ACK from qt wrt net-libs/rb_libtorrent-0.15.10
Comment 5 Davide Pesavento gentoo-dev 2012-05-04 17:26:56 UTC
Adding dep on Qt 4.8.1 stabilization because bug 401551 is fixed only in >=qt-core-4.8.1-r2.
Comment 6 Markos Chandras (RETIRED) gentoo-dev 2012-05-06 16:23:00 UTC
New list:

dev-libs/boost-1.48.0-r2
dev-util/boost-build-1.48.0-r1
dev-python/cgkit-2.0.0_alpha9-r1
dev-python/tagpy-0.94.8-r1
dev-python/visual-5.72-r2
net-libs/rb_libtorrent-0.15.10
sci-libs/cctbx-2010.03.29.2334-r6
Comment 7 Agostino Sarubbo gentoo-dev 2012-05-07 14:32:57 UTC
(In reply to comment #0)
> Maintainers of packages have been added to CC list. If there are no
> objections, then stabilization will start in 1 week.

Please wait, because many packages fails to compile with new boost, I will post all bugs asap.
Comment 8 Markos Chandras (RETIRED) gentoo-dev 2012-05-07 14:35:51 UTC
(In reply to comment #7)
> (In reply to comment #0)
> > Maintainers of packages have been added to CC list. If there are no
> > objections, then stabilization will start in 1 week.
> 
> Please wait, because many packages fails to compile with new boost, I will
> post all bugs asap.

Which new boost?
Comment 9 Agostino Sarubbo gentoo-dev 2012-05-07 15:59:18 UTC
(In reply to comment #8)
> Which new boost?
1.48.0-r1
Comment 10 Markos Chandras (RETIRED) gentoo-dev 2012-05-07 16:21:52 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Which new boost?
> 1.48.0-r1

1.48.0-r2 is the target
Comment 11 Arfrever Frehtes Taifersar Arahesis 2012-05-15 19:02:39 UTC
Let's start stabilization.

The list of packages is:

dev-util/boost-build-1.48.0-r1
dev-libs/boost-1.48.0-r2
dev-python/cgkit-2.0.0_alpha9-r1
dev-python/tagpy-0.94.8-r1
dev-python/visual-5.72-r2
net-libs/rb_libtorrent-0.15.10
sci-libs/cctbx-2010.03.29.2334-r6

Reverse dependencies of dev-libs/boost should be stabilized quickly after stabilization of dev-libs/boost.
Comment 12 Jeroen Roovers (RETIRED) gentoo-dev 2012-05-16 16:00:27 UTC
Stable for HPPA.
Comment 13 Agostino Sarubbo gentoo-dev 2012-05-21 21:00:31 UTC
(In reply to comment #11)
> Let's start stabilization.
> 
> The list of packages is:
> 
> dev-util/boost-build-1.48.0-r1
> dev-libs/boost-1.48.0-r2
> dev-python/cgkit-2.0.0_alpha9-r1
> dev-python/tagpy-0.94.8-r1
> dev-python/visual-5.72-r2
> net-libs/rb_libtorrent-0.15.10
> sci-libs/cctbx-2010.03.29.2334-r6
> 
> Reverse dependencies of dev-libs/boost should be stabilized quickly after
> stabilization of dev-libs/boost.

media-libs/lib3ds is pulled in by cgkit.Is ok to stabilize it?
Comment 14 Arfrever Frehtes Taifersar Arahesis 2012-05-22 00:20:00 UTC
(In reply to comment #13)
> media-libs/lib3ds is pulled in by cgkit.Is ok to stabilize it?

dev-python/cgkit-2.0.0_alpha9-r1 needs to be stabilized only on x86.
Comment 15 Agostino Sarubbo gentoo-dev 2012-05-22 11:21:01 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > media-libs/lib3ds is pulled in by cgkit.Is ok to stabilize it?
> 
> dev-python/cgkit-2.0.0_alpha9-r1 needs to be stabilized only on x86.

Ok, but could you be more precise about target?
Comment 16 Agostino Sarubbo gentoo-dev 2012-05-23 09:24:39 UTC
dev-python/visual needs: dev-python/polygon:2 and dev-python/ttfquery

Is ok to add them to the list?
Comment 17 Mike Gilbert gentoo-dev 2012-05-23 15:27:57 UTC
(In reply to comment #16)
> dev-python/visual needs: dev-python/polygon:2 and dev-python/ttfquery
> 
> Is ok to add them to the list?

No open bugs, so should be fine.
Comment 18 Agostino Sarubbo gentoo-dev 2012-05-23 20:39:57 UTC
amd64 stable
Comment 19 Markus Meier gentoo-dev 2012-06-03 18:12:10 UTC
arm stable
Comment 20 Michael Weber (RETIRED) gentoo-dev 2012-06-08 13:43:08 UTC
ppc skips dev-python/visual-5.72-r2 (keywords got dropped)
Comment 21 Michael Weber (RETIRED) gentoo-dev 2012-06-08 18:07:47 UTC
ppc stable all but sci-libs/cctbx-2010.03.29.2334-r6,
i've to investigate/report an build issue.
Comment 22 Justin Lecher (RETIRED) gentoo-dev 2012-06-09 06:37:19 UTC
*** Bug 398507 has been marked as a duplicate of this bug. ***
Comment 23 Myckel Habets 2012-06-12 20:09:18 UTC
Tested the following packages on x86:

=dev-util/boost-build-1.48.0-r1
=dev-libs/boost-1.48.0-r2
=dev-python/cgkit-2.0.0_alpha9-r1
=dev-python/tagpy-0.94.8-r1
=dev-python/visual-5.72-r2
=net-libs/rb_libtorrent-0.15.10
=sci-libs/cctbx-2010.03.29.2334-r6
=dev-python/polygon-2.0.4
=dev-python/ttfquery-1.0.5

All seem ok to me. Please mark them stable for x86.
Comment 24 Jeff (JD) Horelick (RETIRED) gentoo-dev 2012-06-14 18:44:16 UTC
x86 stable. Thanks Myckel.