Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 413675 - sci-misc/boinc-6.12.42 fails to compile against dev-libs/glib-2.32
Summary: sci-misc/boinc-6.12.42 fails to compile against dev-libs/glib-2.32
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: PATCH
: 414197 415757 (view as bug list)
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-04-26 22:03 UTC by Emile de Weerd
Modified: 2012-06-26 13:02 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch that fix the header inclusion error (6.12.42-fix_glib.patch,443 bytes, patch)
2012-04-26 22:05 UTC, Emile de Weerd
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Emile de Weerd 2012-04-26 22:03:47 UTC
When install boinc 6.12.42 after applying the fix for dependence on curl, there still remains an issue. A compilation error:
Only <glib.h> should be included.

Reproducible: Always

Steps to Reproduce:
1. Emerge boinc-6.12.42
2. Error compilation
Actual Results:  
error: Only <glib.h> should be included.

Expected Results:  
successful build

Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r3, 3.0.26-tuxonice x86_64)
=================================================================
System uname: Linux-3.0.26-tuxonice-x86_64-Intel-R-_Core-TM-_i7_CPU_930_@_2.80GHz-with-gentoo-2.0.3
Timestamp of tree: Mon, 23 Apr 2012 20:15:01 +0000
ccache version 3.1.6 [enabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.6-r1, 4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo kde multimedia graaff sunrise x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA @FREE @EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.mirrors.tds.net/gentoo http://gentoo.mirror.pw.edu.pl/ http://mirror.mcs.anl.gov/pub/gentoo/ http://gentoo.kems.net"
LANG="fr_FR.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en fr de nl"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde /var/lib/layman/multimedia /var/lib/layman/graaff /var/lib/layman/sunrise /home/kspx/install/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi aim alsa amd64 apache2 apm bash-completion berkdb bluetooth branding bzip2 cairo calendar cdda cddb cdparanoia cdr cli consolekit cracklib crypt cscope css ctype cups cvs cxx dbus declarative directfb djvu dri dts dv dvb dvd dvdr emacs emboss encode enscript examples exif expat fam fbcon ffmpeg firefox flac fltk fontconfig foomaticdb fortran ftp gdbm gdu gif gimp gmp gnuplot gnutls gphoto2 gpm gps graphviz gtk gzip hal handbook hddtemp iconv icq ieee1394 imagemagick ipv6 jabber java java6 javascript jingle joysticks jpeg jpeg2k kde kerberos kipi kontact lame latex lcms ldap libcaca libedit libnotify lirc lzo mad matroska mime mmx mng modules mp3 mp4 mpeg mudflap multilib musepack mysql ncurses network-manager nfs nls nntp nocd notl nptl nptlonly nsplugin odbc offensive ofx ogg openal openexr opengl openmp oscar pam pango pcntl pcre pda pdf perl phonon php plasma png policykit posix ppds pppd python qt3support qt4 quicktime raw rdesktop readline rss samba sasl scanner sdl semantic-desktop session sharedext slp smp sndfile snmp spell sqlite sqlite3 sse sse2 ssl startup-notification subversion svg symlink sysfs syslog szip taglib tcl tcpd theora threads tidy tiff timidity tk tokenizer truetype udev unicode usb v4l v4l2 vcd vhosts videos vim-syntax vorbis wavpack wifi wmf wxwidgets x264 xcb xcomposite xface xft xinerama xinw xml xorg xosd xscreensaver xulrunner xv xvid yahoo zlib" ALSA_CARDS="hda-intel emu20k2" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="mustek" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en fr de nl" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Emile de Weerd 2012-04-26 22:05:02 UTC
Created attachment 310223 [details, diff]
Patch that fix the header inclusion error

patch proposition
Comment 2 Douglas J Hunley 2012-04-30 14:20:20 UTC
I'm seeing this on ~amd64 when rebuilding @world too:

In file included from gtk/taskbarex.cpp:23:0:
/usr/include/glib-2.0/glib/gtypes.h:28:2: error: #error "Only <glib.h> can be included directly."
gtk/taskbarex.cpp: In member function ‘virtual bool wxTaskBarIconEx::SetBalloon(const wxIcon&, wxString, wxString, unsigned int)’:
gtk/taskbarex.cpp:239:28: warning: deprecated conversion from string constant to ‘gchar*’
gtk/taskbarex.cpp:242:28: warning: deprecated conversion from string constant to ‘gchar*’
gtk/taskbarex.cpp:245:28: warning: deprecated conversion from string constant to ‘gchar*’
make[2]: *** [boincmgr-taskbarex.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/sci-misc/boinc-6.12.42/work/boinc-6.12.42/clientgui'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sci-misc/boinc-6.12.42/work/boinc-6.12.42'
make: *** [all] Error 2
 * ERROR: sci-misc/boinc-6.12.42 failed (compile phase):
 *   emake failed
 * 

Bug is discussed in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=515722
Comment 3 Pacho Ramos gentoo-dev 2012-05-01 15:32:44 UTC
*** Bug 414197 has been marked as a duplicate of this bug. ***
Comment 4 Douglas J Hunley 2012-05-01 15:48:55 UTC
I'm not sure how much sense it makes to fix this bug given bug #411463
Comment 5 Rafał Mużyło 2012-05-13 21:04:10 UTC
*** Bug 415757 has been marked as a duplicate of this bug. ***
Comment 6 trogdog 2012-05-20 09:36:10 UTC
this has been fixed upstream by version 7.0.25 (current stable version) which has been requested for a version bump in bug 411463.
Comment 7 trogdog 2012-06-02 23:25:24 UTC
http://forums.gentoo.org/viewtopic-t-923320.html provides an interim workaround by showing how to create a local overlay and upgrade to the latest version, while waiting for the sci team to address the version bump.
Comment 8 Samuli Suominen gentoo-dev 2012-06-26 13:02:04 UTC
fixed in portage