Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 413635 - sci-libs/ogdi-3.2.0_beta2 please stabilize (was: fails to build with sci-libs/proj-4.8.0 wrt missing projects.h)
Summary: sci-libs/ogdi-3.2.0_beta2 please stabilize (was: fails to build with sci-libs...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal major with 1 vote (vote)
Assignee: Gentoo Science Related Packages
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard:
Keywords: STABLEREQ
: 420297 497330 (view as bug list)
Depends on: 497860
Blocks: 414997 371389 497478 540132
  Show dependency tree
 
Reported: 2012-04-26 15:59 UTC by Juergen Rose
Modified: 2015-04-04 20:59 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/sci-libs/ogdi-3.2.0_beta2/temp/build.log (build.log,16.28 KB, text/plain)
2012-04-26 15:59 UTC, Juergen Rose
Details
ebuild patch 3.2.0_beta2 -> 3.2.0_beta2-r1 (ogdi-3.2.0_beta2-r1.ebuild.patch,573 bytes, patch)
2013-11-08 19:40 UTC, Thomas Beutin
Details | Diff
use >=sci-libs/proj-4.8.0 (ogdi-3.2.0_beta2-proj480.patch,9.71 KB, patch)
2013-11-08 19:42 UTC, Thomas Beutin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2012-04-26 15:59:53 UTC
Created attachment 310187 [details]
/var/tmp/portage/sci-libs/ogdi-3.2.0_beta2/temp/build.log

'emerge ogdi' fails with:
...
make --directory OBJ.Linux -f ../makefile PASS='depend' /var/tmp/portage/sci-libs/ogdi-3.2.0_beta2/work/ogdi-3.2.0.beta2/bin/Linux/libogdi.so.3.2
make[3]: Entering directory `/var/tmp/portage/sci-libs/ogdi-3.2.0_beta2/work/ogdi-3.2.0.beta2/ogdi/c-api/OBJ.Linux'
x86_64-pc-linux-gnu-gcc -I.. -I/var/tmp/portage/sci-libs/ogdi-3.2.0_beta2/work/ogdi-3.2.0.beta2/include/Linux -I/var/tmp/portage/sci-libs/ogdi-3.2.0_beta2/work/ogdi-3.2.0.beta2/ogdi/include      -march=native -O2 -pipe  -Wall -DUNIX=1 -fPIC -DMODULES_PATH="\"/usr/lib64/ogdi/\""   -c -o ecs_dyna.o ../ecs_dyna.c
In file included from /var/tmp/portage/sci-libs/ogdi-3.2.0_beta2/work/ogdi-3.2.0.beta2/ogdi/include/ecs.h:353:0,
                 from ../ecs_dyna.c:32:
/var/tmp/portage/sci-libs/ogdi-3.2.0_beta2/work/ogdi-3.2.0.beta2/ogdi/include/ecs_util.h:108:22: fatal error: projects.h: No such file or directory
compilation terminated.
make[3]: *** [ecs_dyna.o] Error 1





root@leopard:/usr/local/portage/sci-libs(153)# emerge --info =sci-libs/ogdi-3.2.0_beta2
Portage 2.1.10.57 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.15-r1, 3.3.2-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.3.2-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.1
Timestamp of tree: Wed, 25 Apr 2012 07:30:01 +0000
app-shells/bash:          4.2_p24-r1
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3, 3.2.2-r1
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.15-r1
Repositories: gentoo lisp science sunrise x-portage x-cpan x-g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.3 cadsoft Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://ftp.easynet.nl/mirror/gentoo/ "
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lisp /var/lib/layman/science /var/lib/layman/sunrise /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 applet archive arpack asf aspell assistant atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boo boost bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit cracklib crypt css cuda cups curl cxx daap db dbase dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse g3dvl gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp ginac git glade glib glpk gml gmp gmtsuppl gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gstreamer gtk gudev guile harness hddtemp hdf hdf5 hdri http httpd hvm hwdb iconv icq icu id3 ide imagemagick imap innodb inotify ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdrive kerberos kpathsea kqemu kvm ladspa lame lapack latex latex3 lcms ldap lensfun libffi libgda libnotify libsamplerate live lm_sensors lua lzo mad madwifi mail maildir mapnik math matroska matrox media-library mkl mmx mmxext mng modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib musepack musicbrainz mysql mysqli nautilus ncurses netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numpy nvidia obex objc ocaml ocr octave odbc ogdi ogg ole openexr opengl openmp overview pam pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smbclient smp sms sndfile snmp soup sox speex spell sql sqlite sse sse2 sse4 ssl subtitles subversion suexec svg svm swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs tgif theora threads thunderbird tidy tiff tk tools truetype udev unicode usb userlocales utempter vaapi video virtualbox vorbis wav webdav webdav-serf webkit wmf wxwidgets x264 xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xorg xpm xv xvid xvmc yaml zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon fuji" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="caps lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



root@leopard:/usr/local/portage/sci-libs(154)# emerge -pqv =sci-libs/ogdi-3.2.0_beta2
[ebuild  N    ] sci-libs/ogdi-3.2.0_beta2  USE="-static-libs"
Comment 1 Juergen Rose 2012-04-26 16:11:50 UTC
grass, merkaartor and qlandkartegt fails to emerge due to this bug, because they depend via gdal on ogdi.
Comment 2 Justin Lecher (RETIRED) gentoo-dev 2012-04-26 16:19:10 UTC
is  sci-libs/proj installed?
Comment 3 Justin Lecher (RETIRED) gentoo-dev 2012-04-26 16:22:24 UTC
4.8.0 Release Notes
-------------------

...


 o projects.h no longer installed as a public include file.  Please try to
   only use proj_api.h.
Comment 4 Juergen Rose 2012-04-26 16:25:37 UTC
proj is installed:
rose@leopard:/home/rose(3)$ genlop -t pycurl | tail

     Fri Apr 20 17:37:08 2012 >>> dev-python/pycurl-7.19.0
       merge time: 7 seconds.

     Mon Apr 23 12:32:15 2012 >>> dev-python/pycurl-7.19.0
       merge time: 7 seconds.

     Thu Apr 26 16:42:32 2012 >>> dev-python/pycurl-7.19.0
       merge time: 6 seconds.

rose@leopard:/home/rose(4)$ qlist -Iv proj
media-libs/libprojectm-2.0.1-r1
sci-libs/proj-4.8.0
rose@leopard:/home/rose(5)$ genlop -t proj | tail
 * sci-libs/proj

     Thu Apr 26 16:26:34 2012 >>> sci-libs/proj-4.8.0
       merge time: 13 seconds.

rose@leopard:/home/rose(6)$ emerge -pvD proj

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sci-libs/proj-4.8.0::x-portage  USE="java -static-libs" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Comment 5 Justin Lecher (RETIRED) gentoo-dev 2012-04-26 16:25:50 UTC
Fixed dep, compatibility fix needed. 


   26 Apr 2012; Justin Lecher <jlec@gentoo.org> ogdi-3.1.5-r1.ebuild,
+  ogdi-3.1.6.ebuild, ogdi-3.2.0_beta2.ebuild:
+  Restrict proc version to <4.8 as projects.h no longer installed as a public
+  include file, #413635
+
Comment 6 Tomáš Chvátal (RETIRED) gentoo-dev 2012-05-25 07:39:31 UTC
The NAD is no longer provided by external api -> quite large rewrite will be required.

So I expect us to more lastrite the package than fix it...
Comment 7 cmuelle8 2012-06-14 13:34:45 UTC
(In reply to comment #6)
> The NAD is no longer provided by external api -> quite large rewrite will be
> required.
> 
> So I expect us to more lastrite the package than fix it...

There are a lot of requests regarding the change from projects.h to proj_api.h in projects' trac, see

https://trac.osgeo.org/proj/search?q=projects.h

Maybe the next release will ease patching stuff that broke with the change from 4.7.0 to 4.8.0

greetings,
cmuelle8
Comment 8 Pacho Ramos gentoo-dev 2012-06-16 09:16:19 UTC
*** Bug 420297 has been marked as a duplicate of this bug. ***
Comment 9 John (EBo) David 2012-06-16 20:00:01 UTC
this has been jamming up my daily builds for months, and I am wondering if ogdi will be updating or depricated.  I'm wondering because I was stating a new package and looking for various GIS database support utilities...
Comment 10 Thomas Beutin 2013-10-28 20:19:02 UTC
2013-10-20 "move projects.h to installed headers list"
https://trac.osgeo.org/proj/changeset/2396
:)

it's already in trunk, but unfortunately no release yet...
Comment 11 Thomas Beutin 2013-11-08 19:37:34 UTC
There's a patch in RedHat's bugtracker wich makes sci-libs/ogdi-3.2.0_beta2 compiles fine with sci-libs/proj-4.9.0_beta2 (bug 489684):

https://bugzilla.redhat.com/show_bug.cgi?id=816282

I'll attach the neccessary files in a minute or two...
Comment 12 Thomas Beutin 2013-11-08 19:40:59 UTC
Created attachment 362806 [details, diff]
ebuild patch 3.2.0_beta2 -> 3.2.0_beta2-r1
Comment 13 Thomas Beutin 2013-11-08 19:42:21 UTC
Created attachment 362808 [details, diff]
use >=sci-libs/proj-4.8.0
Comment 14 James Cloos 2014-01-07 00:20:01 UTC
Given that <sci-libs/proj-4.8.0 is gone from portage, fixing this has become more urgent.
Comment 15 Justin Lecher (RETIRED) gentoo-dev 2014-01-07 07:27:37 UTC
Please quickly stabilize, because current stable sci-libs/proj breaks build of latest stable of sci-libs/ogdi.
Comment 16 Justin Lecher (RETIRED) gentoo-dev 2014-01-07 07:28:45 UTC
*** Bug 497330 has been marked as a duplicate of this bug. ***
Comment 17 Penetsdorfer Martin 2014-01-08 20:37:02 UTC
emerge: there are no ebuilds to satisfy ">sci-libs/proj-4.8.0".
(dependency required by "sci-libs/ogdi-3.2.0_beta2" [installed])

please use ">=sci-libs/proj-4.8.0" instead of ">sci-libs/proj-4.8.0"
Comment 18 Pacho Ramos gentoo-dev 2014-01-12 18:33:40 UTC
Was ">" dep a typo?
Comment 19 Thomas Beutin 2014-01-12 18:49:17 UTC
(In reply to Pacho Ramos from comment #18)
> Was ">" dep a typo?

actually not, because i use  sci-libs/proj-4.9.0_beta2 (see bug 489684). but feel free to change it.
Comment 20 Pacho Ramos gentoo-dev 2014-01-18 15:54:59 UTC
amd64 stable
Comment 21 Tobias Klausmann (RETIRED) gentoo-dev 2014-06-18 12:28:55 UTC
Stable on alpha.
Comment 22 Raúl Porcel (RETIRED) gentoo-dev 2014-08-01 09:58:23 UTC
sparc keyword dropped
Comment 23 Andreas Schürch gentoo-dev 2014-08-08 18:40:47 UTC
x86 done.
Comment 24 Agostino Sarubbo gentoo-dev 2014-08-09 12:09:02 UTC
ppc stable
Comment 25 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-04-04 20:59:06 UTC
ppc64 stable. Last arch.