Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 412543 - [sabayon,DuPol,quarks overlay] x11-misc/cairo-dock- cannot compile with dev-libs/glib-2.32, "Only <glib.h> can be included directly."
Summary: [sabayon,DuPol,quarks overlay] x11-misc/cairo-dock- cannot compile wit...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Fabio Erculiani (RETIRED)
Depends on:
Blocks: glib-2.32
  Show dependency tree
Reported: 2012-04-18 17:36 UTC by Kevin Dinant
Modified: 2012-05-22 21:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,100.95 KB, text/plain)
2012-04-18 17:39 UTC, Kevin Dinant
build.log cairo-dock-3.0.0 (quarks overlay) (build.log,9.84 KB, text/plain)
2012-04-19 20:42 UTC, Kevin Dinant

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Dinant 2012-04-18 17:36:48 UTC
Cairo-dock- (overlay sabayon, DuPol, quarks) cannot compile with glib-2.32 with this error : /usr/include/glib-2.0/glib/gtypes.h:28:2: erreur: #error "Only <glib.h> can be included directly."

Reproducible: Always

KevinPC ~ # emerge --info
Portage (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r3, 3.3.1-gentoo x86_64)
System uname: Linux-3.3.1-gentoo-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.1
Timestamp of tree: Wed, 18 Apr 2012 16:15:01 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p24
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3, 3.2.2-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.11.5
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.7
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo desktop-effects kde-sunset wirelay arcon mozilla sekyfsr AzP miramir DuPol x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=5.0 --with-bdeps y"
FEATURES="assume-digests binpkg-logs ccache distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS=" rsync://"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="fr fr_FR"
MAKEOPTS="-j5 -l5"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/desktop-effects /var/lib/layman/kde-sunset /var/lib/layman/wirelay /var/lib/layman/arcon /var/lib/layman/mozilla /var/lib/layman/sekyfsr /var/lib/layman/AzP /var/lib/layman/miramir /var/lib/layman/DuPol /usr/local/portage"
USE="X a52 aac acl alsa amd64 amr bash-completion berkdb bluetooth branding bzip2 cdda cdr cleartype cli consolekit corefonts cracklib crypt css cups cxx dbus djvu dri dvd dvdr encode ffmpeg flac fortran ftp gdbm gif gimp gphoto2 gpm gtk handbook iconv imap ipv6 jack java jpeg lcms mad mime mmx mng modules mozilla mp3 mpeg msn mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ocr ogg opencore-amr opengl openmp pam pcre pdf perl php png pppd python rar raw readline scanner session smp source speex spell sql sse sse2 ssl svg symlink sysfs tcpd tiff truetype type1 unicode usb v4l v4l2 vcd videos webkit wifi xcomposite xml xorg xscreensaver xvid zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Kevin Dinant 2012-04-18 17:39:10 UTC
Created attachment 309429 [details]
Comment 2 Dustin Polke 2012-04-18 18:18:21 UTC
Thanks for the report but as this ebuild is not in the official tree, this bugs probably will be closed as INVALID.

I've just check that cairo-dock-3.0.0 has been released and I will work on the version bump for the DuPol overlay. Probably, this issue is already solved in this version.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2012-04-18 19:37:19 UTC
(In reply to comment #2)
> Thanks for the report but as this ebuild is not in the official tree, this
> bugs probably will be closed as INVALID.

It's in -3- overlays, which is a problem in itself. Do the three versions disagree, or why are they needed?

Also, ebuilds in overlays get bug reports assigned to the e-mail address(ses) mentioned in [1].

Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2012-04-18 19:38:15 UTC
@lxnay: The e-mail address mentioned in [1] is not a valid bugzilla user:

  <overlay contact="" name="sabayon" src="git://" status="unofficial" type="git">

Comment 5 Kevin Dinant 2012-04-19 20:40:32 UTC
x11-misc/cairo-dock was updated to 3.0.0 in overlay quarks but compilation fails with, I think, the same error.
Comment 6 Kevin Dinant 2012-04-19 20:42:00 UTC
Created attachment 309539 [details]
build.log cairo-dock-3.0.0 (quarks overlay)
Comment 7 Kevin Dinant 2012-04-19 20:45:31 UTC
I just saw that x11-misc/cairo-dock-3.0.0 has been added to miramir overlay (so now cairo-dock is in 4 overlays) and it does compile there!
Comment 8 Stefan Reimer 2012-04-19 22:36:02 UTC
the ebuild in the miramir overlay is a copy of the ebuild from quarks overlay + the glib compile fix. I updated quarks to cairo-dock-3.0.0-r1

This really proves we should get this thing upstream.. sunrise overlay ?
Suggestions ?
Comment 9 Sławomir Nizio 2012-04-20 17:35:04 UTC
Should be fixed in Sabayon overlay now (for, version bump will be later). It's a copy from quarks (thanks!) with minor modifications, but Sabayon overlays are special: (with rare exceptions) it's needed for an ebuild to be there in order to create a package.
Comment 10 Sławomir Nizio 2012-04-20 18:12:28 UTC
(unless they're in Portage, of course)

By the way, some overlays place plugins under x11-misc category, other ones under x11-plugins - it's a good thing to unify too. I think x11-plugins suits better.

PS I've tested cairo-dock and -plugins on x86 and it works, so you may want to keyword it for this architecture in your overlays.
Comment 11 Stefan Reimer 2012-04-20 18:23:52 UTC
Hi all,
as suggested by Enlik, I moved the plugins to x11-plugins.
and added ~x86 to cairo-dock and plugins in the quarks overlay.
Comment 12 Dustin Polke 2012-04-27 20:43:52 UTC
Version bump to v3.0.0. needs a bit more work, so I fixed v2.4.0.2 in DuPol overlay for now.

Has anyone sent the patch already to upstream's maintainers yet?

(In reply to comment #10)
> PS I've tested cairo-dock and -plugins on x86 and it works, so you may want
> to keyword it for this architecture in your overlays.
Will do with 3.0.0 version bump.

(In reply to comment #3)
> It's in -3- overlays, which is a problem in itself. Do the three versions
> disagree, or why are they needed?
I started using cairo-dock when it was up-to-date in desktop-effects overlay. When it wasn't updated there anymore, I started to work on it in my own overlay where I focussed on fixing automagic dependencies and making applets individually selectable by USE flags.
Comment 13 Dustin Polke 2012-05-01 21:05:57 UTC
Patch sent upstream, see URL
Comment 14 Dustin Polke 2012-05-03 08:28:18 UTC
(In reply to comment #13)
> Patch sent upstream, see URL
Accepted and commited upstream.
Anyone objects to close this bug now?
Comment 15 Sławomir Nizio 2012-05-04 20:49:47 UTC
> Patch sent upstream, see URL

> Anyone objects to close this bug now?
Seems it'd be fine to do so.
Comment 16 Dustin Polke 2012-05-22 21:46:31 UTC
(In reply to comment #15)
> > Anyone objects to close this bug now?
> Seems it'd be fine to do so.

Noone screemed, so closing. Speak up if you want it opened for some reason.