Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 412495 - dev-ruby/ruby-glib2-1.0.3 with dev-libs/glib-2.32.1 - In function 'g_spawn_error_get_type': glib-enum-types.c:163:7: error: stray '#' in program
Summary: dev-ruby/ruby-glib2-1.0.3 with dev-libs/glib-2.32.1 - In function 'g_spawn_er...
Status: RESOLVED DUPLICATE of bug 410975
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-04-18 10:06 UTC by Willard Dawson
Modified: 2012-04-18 16:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info,6.35 KB, text/plain)
2012-04-18 10:06 UTC, Willard Dawson
Details
build log (build.log,18.93 KB, text/plain)
2012-04-18 10:07 UTC, Willard Dawson
Details
Emerge environment (environment,146.35 KB, text/plain)
2012-04-18 10:08 UTC, Willard Dawson
Details
emerge -pqv (emerge-pqv,94 bytes, text/plain)
2012-04-18 10:08 UTC, Willard Dawson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Willard Dawson 2012-04-18 10:06:43 UTC
Created attachment 309397 [details]
emerge --info

Errors are similar to discussion here:
https://github.com/ruby-gnome2/ruby-gnome2/issues/106

In file included from rbgprivate.h:11:0,
                 from rbgobj_value.c:13:
rbgobject.h:231:0: warning: "G_TYPE_MAIN_LOOP" redefined
/usr/include/glib-2.0/gobject/glib-types.h:201:0: note: this is the location of the previous definition
rbgobject.h:235:0: warning: "G_TYPE_MAIN_CONTEXT" redefined
/usr/include/glib-2.0/gobject/glib-types.h:210:0: note: this is the location of the previous definition
rbgobject.h:236:0: warning: "G_TYPE_SOURCE" redefined
/usr/include/glib-2.0/gobject/glib-types.h:219:0: note: this is the location of the previous definition
rbgobject.h:243:0: warning: "G_TYPE_KEY_FILE" redefined
/usr/include/glib-2.0/gobject/glib-types.h:228:0: note: this is the location of the previous definition
glib-enum-types.c: In function 'g_spawn_error_get_type':
glib-enum-types.c:163:7: error: stray '#' in program
glib-enum-types.c:163:10: error: 'ifndef' undeclared (first use in this function)
glib-enum-types.c:163:10: note: each undeclared identifier is reported only once for each function it appears in
glib-enum-types.c:165:7: error: stray '#' in program
glib-enum-types.c:165:10: error: 'endif' undeclared (first use in this function)
make[1]: *** [glib-enum-types.o] Error 1
make[1]: *** Waiting for unfinished jobs....
In file included from rbgprivate.h:11:0,
                 from rbgobj_signal.c:15:
rbgobject.h:231:0: warning: "G_TYPE_MAIN_LOOP" redefined
/usr/include/glib-2.0/gobject/glib-types.h:201:0: note: this is the location of the previous definition
rbgobject.h:235:0: warning: "G_TYPE_MAIN_CONTEXT" redefined
/usr/include/glib-2.0/gobject/glib-types.h:210:0: note: this is the location of the previous definition
rbgobject.h:236:0: warning: "G_TYPE_SOURCE" redefined
/usr/include/glib-2.0/gobject/glib-types.h:219:0: note: this is the location of the previous definition
rbgobject.h:243:0: warning: "G_TYPE_KEY_FILE" redefined
/usr/include/glib-2.0/gobject/glib-types.h:228:0: note: this is the location of the previous definition
make[1]: Leaving directory `/var/tmp/portage/dev-ruby/ruby-glib2-1.0.3/work/ruby18/ruby-gnome2-all-1.0.3/glib2/ext/glib2'
make: *** [all] Error 2
emake failed
Comment 1 Willard Dawson 2012-04-18 10:07:38 UTC
Created attachment 309399 [details]
build log
Comment 2 Willard Dawson 2012-04-18 10:08:00 UTC
Created attachment 309401 [details]
Emerge environment
Comment 3 Willard Dawson 2012-04-18 10:08:44 UTC
Created attachment 309403 [details]
emerge -pqv
Comment 4 jorgeml 2012-04-18 16:09:53 UTC
I have the same problem.
Comment 5 Hans de Graaff gentoo-dev 2012-04-18 16:18:50 UTC
You are mixing stable and unstable packages.
Comment 6 Hans de Graaff gentoo-dev 2012-04-18 16:19:22 UTC

*** This bug has been marked as a duplicate of bug 410975 ***