Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 41220 - mod_php fails configure with +jpeg USE flag
Summary: mod_php fails configure with +jpeg USE flag
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: PHP Bugs
Depends on:
Reported: 2004-02-11 01:53 UTC by Joe Stroller
Modified: 2004-08-16 06:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Emerge patching failure (mod_php-4.3.4-r3.diff-9222.out,5.97 KB, text/plain)
2004-03-29 00:27 UTC, Joe Stroller

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Stroller 2004-02-11 01:53:58 UTC
checking for Oracle-ORACLE support... no
checking whether to enable user-space object overloading support... yes
checking for Ovrimos SQL Server support... no
checking whether to enable pcntl support... yes
checking for fork... yes
checking for waitpid... yes
checking for sigaction... yes
checking for PCRE support... yes
checking for PDFlib support... yes
checking for the location of libtiff... /usr
checking for jpeg_read_header in -ljpeg... no
configure: error: libjpeg not found!

!!! ERROR: dev-php/mod_php-4.3.4-r4 failed.
!!! Function econf, Line 365, Exitcode 1
!!! econf failed

$ sudo emerge -Upv world
>>> --upgradeonly implies --update... adding --update to options.

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[ebuild     U ] dev-php/mod_php-4.3.4-r4 [4.3.4-r2] -X +apache2 -berkdb +crypt -curl -firebird -flash -freetds -gd -gd-external -gdbm +imap -informix -ipv6 +java +jpeg -ldap -mcal -memlimit -mysql +nls -oci8 -odbc +pam +pdflib +png -postgres -qt -snmp +spell +ssl +tiff +truetype +xml2 -yaz  0 kB

Strangely enough:

$ esearch jpeg-mmx
[ Results for search key : jpeg-mmx ]
[ Applications found : 1 ]

*  media-libs/jpeg-mmx
      Latest version available: 1.1.2-r1
      Latest version installed: 1.1.2-r1
      Size of downloaded files: 555 kB
      Description: JPEG library with mmx enhancements

$  emerge info
Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.4.22-grsec-1.9.12)
System uname: 2.4.22-grsec-1.9.12 i686 Pentium II (Deschutes)
Gentoo Base System version
distcc 2.11.1 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.58
Automake: sys-devel/automake-1.7.7
CFLAGS="-march=pentium2 -Os"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=pentium2 -Os"
FEATURES="autoaddcvs ccache distcc sandbox"
USE="3dfx aalib apache2 apm crypt foomaticdb gif gtk2 imap java jpeg libg++ libwww mad maildir md5sum ncurses nls offensive pam pdflib perl pic png python readline samba slang spell ssl svga tcpd tetex tiff truetype usb x86 xml2 zlib"

Re-emerging jpeg-mmx doesn't seem to make any difference
Comment 1 Joe Stroller 2004-02-11 01:57:18 UTC
WEIRD! Removing jpeg USE flag makes no difference.
Comment 2 Joe Stroller 2004-02-11 04:14:29 UTC
Duplicate of bug 27525 <>
I'm not clear why that's been closed, however.
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-02-11 08:07:24 UTC
1. emerge sync, then run the emerge mod_php
2. post up your config.log if you want an exact diagnosis of what's broken in your system
3. alternativly, 99% of the time it's just somebodies libraries out of whack, and can be solved by running revdep-rebuild from gentoolkit.
Comment 4 Joe Stroller 2004-02-11 09:09:26 UTC
It's fixed now. 
Workaround in comment 20 of bug 27525 <> of renaming to allows mod_php to complete compiling successfully.
Comment 5 Joe Stroller 2004-02-11 09:16:47 UTC
Oh, and I already tried ` emerge sync && emerge mod_php && revdep-rebuild  && emerge mod_php` - didn't make any difference.

Perhaps that `mv /opt/blackdown-jdk-1.4.1/jre/lib/i386/ /opt/blackdown-jdk-1.4.1/jre/lib/i386/ && emerge mod_php && mv /opt/blackdown-jdk-1.4.1/jre/lib/i386/ /opt/blackdown-jdk-1.4.1/jre/lib/i386/` did work is completely unrelated to bug 27525. *cough*
Comment 6 Stuart Herbert (RETIRED) gentoo-dev 2004-03-28 16:17:11 UTC
Can you retest now that php-4.3.5 is in Portage?

Comment 7 Joe Stroller 2004-03-29 00:20:46 UTC
Sorry, that ebuild seems to fail here on applying patches. Looks unrelated.

>>> Unpacking source...
 * Due to some previous bloopers with PHP and slotting, you may have
 * multiple instances of mod_php installed. Please look at the autoclean
 * output at the end of the emerge and unmerge all but relevant
 * instances.
 * Apache2 only detected
 * You have the xml USE flag turned off. Previously this
 * disabled XML support in PHP. However PEAR has a hard
 * dependancy on it, so they are now enabled.
>>> Unpacking php-4.3.5.tar.bz2 to /var/tmp/portage/mod_php-4.3.5/work
 * Applying mod_php-4.3.4-r3.diff...

 * Failed Patch: mod_php-4.3.4-r3.diff!
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/mod_php-4.3.5/temp/mod_php-4.3.4-r3.diff-9222.out

!!! ERROR: dev-php/mod_php-4.3.5 failed.
!!! Function epatch, Line 322, Exitcode 0
!!! Failed Patch: mod_php-4.3.4-r3.diff!

Am attaching the diff.out as requested. I suspect you'd probably prefer me to open a new bug report, but I don't really have time to document & investigate right now. Sorry.
Comment 8 Joe Stroller 2004-03-29 00:27:03 UTC
Created attachment 28262 [details]
Emerge patching failure
Comment 9 Stuart Herbert (RETIRED) gentoo-dev 2004-03-29 11:08:00 UTC
mod_php-4.3.5 now compiles.  Can you test again please?

Comment 10 Joe Stroller 2004-03-29 19:53:04 UTC
Seems to work here. Emerged perfectly and SquirrelMail still works.  8-)
Comment 11 Stuart Herbert (RETIRED) gentoo-dev 2004-03-29 21:46:06 UTC
Thank you.  Closing bug.
Comment 12 Stuart Herbert (RETIRED) gentoo-dev 2004-08-16 06:01:44 UTC
Closing old bug