Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 41170 - media-libs/gdk-pixbuf depends on gnome-base/gnome-libs whereas it does not need to
Summary: media-libs/gdk-pixbuf depends on gnome-base/gnome-libs whereas it does not ne...
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on: 13484
Blocks:
  Show dependency tree
 
Reported: 2004-02-10 14:46 UTC by Christian Seiler
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
The patch to the ebuild. (gdk.diff,600 bytes, patch)
2004-02-10 14:48 UTC, Christian Seiler
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Seiler 2004-02-10 14:46:42 UTC
While emerging the GIMP I noticed that portage wanted to emerge also the GNOME 1.4 libraries. I do not want these.

I then traced the dependency down to the package media-libs/gdk-pixbuf.

Reproducible: Always
Steps to Reproduce:
emerge -p gdk-pixbuf without having gnome-base/gnome-libs installed and with having the gnome USE flag unset.
Actual Results:  
gnome-libs is on the list of the packages that are to be emerged.

Expected Results:  
gnome-libs should not be on the list of the packages that are to be emerged.

I modified the ebuild so that the gnome-base/gnome-libs would only be a
dependency if the gnome USE flag was set. gdk-pixbuf emerged just fine and until
now I did not have any problems with the GIMP.

Here is the patch to the ebuild.

--- gdk-pixbuf-0.22.0.ebuild.old        2004-02-09 21:30:32.000000000 +0100
+++ gdk-pixbuf-0.22.0.ebuild    2004-02-09 21:30:32.000000000 +0100
@@ -4,7 +4,7 @@

 inherit virtualx libtool gnome.org

-IUSE="doc"
+IUSE="doc gnome"
 S=${WORKDIR}/${P}
 DESCRIPTION="GNOME Image Library"
 HOMEPAGE="http://www.gtk.org/"
@@ -13,7 +13,7 @@
 	media-libs/tiff
 	=x11-libs/gtk+-1.2*
 	>=media-libs/libpng-1.2.1
-	>=gnome-base/gnome-libs-1.4.1.2-r1"
+	gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )"
 # We need gnome-libs here, else gnome support do not get compiled into
 # gdk-pixbuf (the GnomeCanvasPixbuf library )
Comment 1 Christian Seiler 2004-02-10 14:48:48 UTC
Created attachment 25362 [details, diff]
The patch to the ebuild.
Comment 2 foser (RETIRED) gentoo-dev 2004-02-10 15:12:38 UTC
search please 

and there's actually a comment there which explains the situation *sigh* (even in the diff)

*** This bug has been marked as a duplicate of 2272 ***