Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 411355 - app-admin/collectd-5.1.0: use linux capabilities with configured ping-plugin
Summary: app-admin/collectd-5.1.0: use linux capabilities with configured ping-plugin
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-09 16:25 UTC by Stef Simoens
Modified: 2012-05-04 22:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stef Simoens 2012-04-09 16:25:30 UTC
I'm not sure why the ebuild has 
"
# use collectd_plugins_ping && setcap cap_net_raw+ep ${D}/usr/sbin/collectd
# we cannot do this yet
"
because this allows me to run collectd as a non-priviledged user...


Reproducible: Always

Steps to Reproduce:
- configure ping plugin
- start collectd as non-priviledged user
Actual Results:  
ping plugin: ping_host_add (www.google.com) failed: Operation not permitted


Expected Results:  
no error message

setcap cap_net_raw+ep `which collectd` allows the ping to succeed
Comment 1 Andreas K. Hüttel gentoo-dev 2012-05-04 22:21:51 UTC
Because there is no support in portage for capabilities yet. If it works, it works by chance...

http://archives.gentoo.org/gentoo-dev/msg_18c1565bed3e0d797ad7943d227cb77f.xml