Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410911 - net-im/psi-0.15 version bump
Summary: net-im/psi-0.15 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement with 2 votes (vote)
Assignee: Nikoli
URL:
Whiteboard:
Keywords:
: 437286 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-05 16:14 UTC by Davide Pesavento
Modified: 2013-03-24 10:42 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---
yngwin: Bugday+


Attachments
updated ebuild for psi-0.15 (psi-0.15.ebuild,2.31 KB, text/plain)
2013-03-21 02:33 UTC, Jeremy Egner
Details
diff of old ebuild/above (0.14-0.15.diff,4.43 KB, text/plain)
2013-03-21 02:37 UTC, Jeremy Egner
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Ben de Groot (RETIRED) gentoo-dev 2012-07-03 15:21:38 UTC
Peter: if you don't have any objections, qt herd is interested in taking over maintainership of this package.
Comment 2 Davide Pesavento gentoo-dev 2012-08-29 00:06:06 UTC
RC1 is out.
Comment 3 Ben de Groot (RETIRED) gentoo-dev 2012-08-29 05:17:38 UTC
(In reply to comment #2)
> RC1 is out.

Great! Let's get an ebuild into portage then.
Comment 4 Davide Pesavento gentoo-dev 2012-09-01 21:15:14 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > RC1 is out.
> 
> Great! Let's get an ebuild into portage then.

I'd do it, but the current portage ebuilds (both 0.14 and 9999) are quite scary and I don't have the time to review all the Psi+ patches...
Comment 5 Davide Pesavento gentoo-dev 2012-10-04 03:41:52 UTC
Final is out now.
Comment 6 Ben de Groot (RETIRED) gentoo-dev 2012-10-05 11:42:32 UTC
*** Bug 437286 has been marked as a duplicate of this bug. ***
Comment 7 Markos Chandras (RETIRED) gentoo-dev 2012-10-07 14:58:28 UTC
Nikoli will take care of that. proxy-maintainers and qt@ will be backup herds
Comment 8 Sergey Ilinykh 2012-10-31 14:16:58 UTC
poke me if you have any questions about psi or psi+ =)
Comment 9 Nikoli 2012-11-06 07:02:01 UTC
rion, what about source archives for USE extras and translations? There are git repos, but http://psi-plus.com/ does not provide anything suitable for SRC_URI.
Comment 10 Sergey Ilinykh 2012-11-06 08:33:08 UTC
technik has repo with psi+ sources (https://github.com/tehnick/psi-plus/tags). I can move it to github psi+ project to make it kinda more official =) He sets git tags on each update so tarballs are already here =)

about translations. Justin promissed to set up repository for Psi translations but I guess he is a bit busy. some translations can be found at psi-im.org, but I'm not sure how actual they are.
translations for psi+ also can be downloaded by git tags from github all-in-one or by direct link to raw *.ts files
Comment 11 Nikoli 2012-11-06 09:10:58 UTC
Please provide official tars at psi-plus.com or at https://github.com/psi-plus (github has downloads). Using git tags directly in SRC_URI will not work, because every time new file with new checksums is generated.
Comment 12 Markos Chandras (RETIRED) gentoo-dev 2012-12-10 09:39:19 UTC
Any progress on that?
Comment 13 Andreis Vinogradovs ( slepnoga ) 2012-12-10 11:01:10 UTC
(In reply to comment #12)
> Any progress on that?

No ;) Nikoli (and pva ), to my knowledge, very busy in their work a new project.
Ebuild is not even in the rion overlay, and I do not know the plans of his appearance ,than "weekend next week, if I have the time" ;)
Comment 14 Ben de Groot (RETIRED) gentoo-dev 2013-03-01 12:08:54 UTC
We really need this bump!
Comment 15 Markos Chandras (RETIRED) gentoo-dev 2013-03-01 12:17:05 UTC
(In reply to comment #14)
> We really need this bump!

I'd say we really need a maintainer, not just a bump
Comment 16 Andreis Vinogradovs ( slepnoga ) 2013-03-01 12:25:23 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > We really need this bump!
> 
> I'd say we really need a maintainer, not just a bump

+1
Comment 17 Nikolaj Šujskij 2013-03-01 12:27:16 UTC
> > > We really need this bump!
> > 
> > I'd say we really need a maintainer, not just a bump
> 
> +1

So, slepnoga has volunteered! ;p
Comment 18 Sergey Ilinykh 2013-03-01 12:28:18 UTC
+1 for slepnoga =))
Comment 19 Markos Chandras (RETIRED) gentoo-dev 2013-03-01 12:32:17 UTC
I believe the public has spoken! Andreis, I am looking forward to review your ebuilds ;)
Comment 20 Jeremy Egner 2013-03-21 02:33:21 UTC
Created attachment 342814 [details]
updated ebuild for psi-0.15

I revised the existing 0.14-r4 ebuild to work with 0.15. It works on my amd64 machine, but this is the first ebuild I've modified so it probably has some problems. (or many :)

Also, I wasn't sure how to handle the language packs, as the individual packs don't play nice with SRC_URI, and the older collection doesn't seem to exist. (?)

If anyone feels like taking a look and seeing if it's usable or still needs some work, please do so!
Comment 21 Jeremy Egner 2013-03-21 02:37:09 UTC
Created attachment 342816 [details]
diff of old ebuild/above
Comment 22 Sergey Popov gentoo-dev 2013-03-24 10:42:39 UTC
+  24 Mar 2013; Sergey Popov <pinkbyte@gentoo.org> +psi-0.15.ebuild:
+  Version bump, wrt bug #410911. Psi+ support has been removed for now