Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 410745 - Gentoo Hardened: media-video/mplayer2 dies with PaX error
Summary: Gentoo Hardened: media-video/mplayer2 dies with PaX error
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-04 05:42 UTC by David
Modified: 2012-11-21 11:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info.txt,4.55 KB, text/plain)
2012-04-04 05:42 UTC, David
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David 2012-04-04 05:42:20 UTC
Created attachment 307707 [details]
emerge --info

After installing media-video/mplayer2:  if mplayer2 is run without first running 'paxctl -m /usr/bin/mplayer2' then mplayer2 will die with:

mplayer2: error while loading shared libraries: /usr/lib/libmpg123.so.0: cannot make segment writable for relocation: Permission denied



So, it seems that the 'pax-mark' command needs to be run near the end of the ebuild (as in www-client/firefox-bin/firefox-bin-11.0.ebuild, for example).
Comment 1 Magnus Granberg gentoo-dev 2012-04-04 13:05:11 UTC
(In reply to comment #0)
> Created attachment 307707 [details]
> emerge --info
> 
> After installing media-video/mplayer2:  if mplayer2 is run without first
> running 'paxctl -m /usr/bin/mplayer2' then mplayer2 will die with:
> 
> mplayer2: error while loading shared libraries: /usr/lib/libmpg123.so.0:
> cannot make segment writable for relocation: Permission denied
> 
> 
> 
> So, it seems that the 'pax-mark' command needs to be run near the end of the
> ebuild (as in www-client/firefox-bin/firefox-bin-11.0.ebuild, for example).

what use flags on mplayer2?
you have TEXTREL in libmpg123
disable any asm code should fix it or fix the code.
Comment 2 Magnus Granberg gentoo-dev 2012-04-04 14:50:59 UTC
see Bug 164504
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2012-04-25 09:09:46 UTC
I would say recompiling the mpg123 should solve your problem.

On the stable is the issue with the fix as it was not revbumped. So if you had mpg123 emerged prior the fix you still have the issue.

@hardened: Open stablereq for latest mpg123 and problem will be solved (i don't want the bugspam so you do it).

Closing the bug as CANTFIX as there is nothing on mplayer2 side we could do.
Comment 4 Nikoli 2012-05-03 09:38:13 UTC
mpg123 is not the only problem: with -vo xv mplayer2 works fine, but with -vo vdpau it works only after paxctl -m.

Error message:
MPlayer interrupted by signal 11 in module: preinit_libvo
dmesg:
grsec: denied RWX mmap of <anonymous mapping> by /usr/bin/mplayer2[mplayer:10758] uid/euid:1000/1000 gid/egid:1000/1000, parent /usr/local/bin/vf[vf:10757] uid/euid:1000/1000 gid/egid:1000/1000

vdpau support is mesa based, i have nouveau drivers. Seems the problem is similar to other GL application.
Comment 5 Nikoli 2012-11-21 11:04:51 UTC
'mplayer2 -vo vdpau' works fine with ati foss driver and mesa-9, nouveau problem is in bug #432520