Please rename ESCM_OFFLINE to EVCS_OFFLINE, see tracker bug 311101 and discussions in gentoo-dev:
What is the plan about respecting old variable?
Respect it or just forget and rename to new one?
I'd just rename it. At least this is what git-2.eclass did some time ago.
> I'd just rename it. At least this is what git-2.eclass did some time ago.
Good! Pushed as:
> 02 Apr 2012; Sergei Trofimovich <firstname.lastname@example.org> darcs.eclass:
> Switch from ESCM_OFFLINE var to EVCS_OFFLINE (bug #410467 by Ulrich Müller).
> Don't skip _darcs/ when checkout to $WORKDIR. Add 'rsync' to DEPENDS.