Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 409247 - x11-drivers/nvidia-drivers-290.20-r1: gnome-terminal and gnome-screenshot hang on exit with 100% CPU usage
Summary: x11-drivers/nvidia-drivers-290.20-r1: gnome-terminal and gnome-screenshot han...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-22 00:20 UTC by Ira Moss
Modified: 2012-07-22 22:14 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ira Moss 2012-03-22 00:20:13 UTC
A description of this bug can best be found in bug id 375615, however the cause of it appears for me to be related to opengl and nvidia.

if I have nvidia as my openGl interface, then when running many gnome gtk+2 applications... upon exit, my CPU spikes to 100%, and a top/ps system-monitor yields that the process is still running (though, no visable appearance) 

gnome-terminal and gnome-screenshot are easy ones to duplicate the problem.

Running with:  
Linux 3.2.1-gentoo-r2 x86_64
nvidia-drivers-295.20-r1


Reproducible: Always

Steps to Reproduce:
1.eselect opengl set nvidia
2./etc/init.d/xdm stop
3./etc/init.d/xdm start
4. Login (gdm)
5. Fire up gnome-terminal
6. exit gnome terminal
7. Examine system-monitor or top, and find (in my case 1 of 4) cpu's spiked at 100%  (you'll notice the process is still running)
8. Kill PID, and process drops back down
9. eselect opengl set xorg-x11
10. Repeat steps 2 - 6
11. System back to normal
Actual Results:  
100% CPU, and process still running after exit.

Expected Results:  
normal CPU, and process to have exited.

# emerge --info
Portage 2.1.10.49 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.3, glibc-2.13-r4, 3.2.1-gentoo-r2 x86_64)
=================================================================
System uname: Linux-3.2.1-gentoo-r2-x86_64-Intel-R-_Core-TM-_i5-2500K_CPU_@_3.30GHz-with-gentoo-2.0.3
Timestamp of tree: Tue, 20 Mar 2012 23:30:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.10.3, 1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs buildpkg distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.mirrors.tera-byte.com/ http://gentoo.osuosl.org/ http://gentoo.mirrors.easynews.com/linux/gentoo/"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US en"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aes alsa amd64 apache2 aperfmperf apic arat arch_perfmon aspell avx bash-completion berkdb big-tables bluetooth branding bts bzip2 cairo calendar cdda cdr clamav clflush cli cmov colord consolekit constant_tsc cracklib crypt css ctype cups cx16 cx8 cxx dbus de directv dovecot-sasl dri ds_cpl dtes64 dts dv dvb dvd dvdr dvdread ecwj2k eds emboss encode enscript epb epson ept est evo exif fam fax ffmpeg fftw firefox fits flac flexpriority fortran fpu fxsr garmin gcdmaster gd gdal gdbm gdu geos gif gimp gml gnome gnome-keyring gnome-online-accounts gnomecd gphoto2 gpm gps gpsd graphviz gstreamer gtk hddtemp hdf hdf5 ht iconv ida ieee1394 imagemagick imap ipv6 iscsi java jpeg jpeg2k jpg kerberos krb4 kvm lahf_lm lame lcms ldap libmpeg2 libnotify lm lm_sensors logrotate lvm lzo mad mca mce md5sum mgetty mikmod mmx mmxext mng modules monitor mp3 mp3rtp mp4 mpeg mpg123 mplayer msr mtrr mudflap multilib mysql mysqli nagios-dns nagios-ntp nagios-ping nagios-ssh nas nautilus ncurses netcdf netpbm network-cron nls nonstop_tsc nopl nptl nptlonly nsplugin nss ntp nut nx ogg opengl openmp pae pam pango pat pbe pclmulqdq pcre pdcm pdf pebs pge php pln png pni policykit popcnt ppds pppd pse pse36 pts pulseaudio pvr qt3support radio rdtscp readline reflection rep_good rsync sasl scanner sdl sep session sndfile soap socialweb sockets spell ss sse sse2 sse4_1 sse4_2 ssh ssl ssse3 startup-notification subversion svg syscall sysfs syslog tcpd tiff tm tm2 tordns tpr_shadow truetype tsc udev unicode unzip ups usb v4l v4l2 vdpau vhosts vim-syntax vme vmx vnmi vorbis vpid winbind x264 xcb xine xinetd xml xorg xsave xsaveopt xtopology xtpr xulrunner xv xvid zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="cgi log_forensic actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif so speling status unique_id userdir usertrack vhost_alias proxy proxy_ajp proxy_connect" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="canon nikon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" LIRC_DEVICES="alsa_usb animax audio audio_alsa avermedia avermedia98 avermedia_vdomate awlibusb commandir dsp mouseremote mouseremote_ps2 pctv samsung tuxbox tvbox udp uirt2 uirt2_raw usb_uirt_raw" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_req limit_zone map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi flv mp4 perl" NGINX_MODULES_MAIL="imap smtp" PHP_TARGETS="php5-3" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" SANE_BACKENDS="epson epson2 hp hp3500 hp3900 hp4200 hp5400 hp5590 hpljm1005 hpsj5s hs2p" USERLAND="GNU" VIDEO_CARDS="v4l nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


# cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 275.09.07  (buildmeister@swio-display-x86-rhel47-03.nvidia.com)  Wed Jun  8 14:38:19 PDT 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" LeftOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
Fontpath    "/usr/share/fonts/100dpi"
Fontpath    "/usr/share/fonts/75dpi"
Fontpath    "/usr/share/fonts/Type1"
Fontpath    "/usr/share/fonts/corefonts"
Fontpath    "/usr/share/fonts/cyrillic"
Fontpath    "/usr/share/fonts/default"
Fontpath    "/usr/share/fonts/dejavu"
Fontpath    "/usr/share/fonts/encodings"
Fontpath    "/usr/share/fonts/liberation-fonts"
Fontpath    "/usr/share/fonts/libertine-ttf"
Fontpath    "/usr/share/fonts/misc"
Fontpath    "/usr/share/fonts/stix-fonts"
Fontpath    "/usr/share/fonts/texcm-ttf"
Fontpath    "/usr/share/fonts/ttf-bitstream-vera"
Fontpath    "/usr/share/fonts/urw-fonts"
Fontpath    "/usr/share/fonts/util"
EndSection

Section "InputDevice"
    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HP"
    HorizSync       31.5 - 68.7
    VertRefresh     60.0 - 85.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "hp 7500"
    HorizSync       30.0 - 70.0
    VertRefresh     50.0 - 140.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 210"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 210"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-0: 1024x768 +0+0; CRT-0: 1024x768_85 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT-1: 832x624 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-03-22 00:33:01 UTC

*** This bug has been marked as a duplicate of bug 398723 ***
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-03-22 05:49:22 UTC
Reopening; this bug seems to be somewhat different from bug #398723 after all (see comments in #398723).
Comment 3 Pacho Ramos gentoo-dev 2012-03-22 09:20:27 UTC
Please try on a new created user account with a new homedir
Comment 4 Tango 2012-03-22 15:37:33 UTC
My drivers were updated yesterday to nvidia-drivers-295.20-r1 from the previous stable version and this bug showed up.  I can confirm that switching to xorg's opengl and restarting X (I run startx from a console) solves the problem.

My other observations when using nvidia's opengl are,

1. A single gnome-terminal seems to be spawned all on its own.
2. A Bash (Zombie) process is associated with each running gnome-terminal (no gnome-terminal actually running on the desktop).
3. Every gnome-terminal I start fails to exit properly and consumes 96% to 110% of my CPU's.

I run several gnome-terminals at the same time to login and do maintenance on other systems on my network every couple of days.  This morning 2 CPU's were maxed and 2 were being used heavily.  The system monitor showed 2 gnome-terminals running and 2 Bash Zombies.

The previous stable version of nvidia-drivers did not appear to have this problem.

Portage 2.1.10.49 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 2.6.37-gentoo-r4 x86_64)
=================================================================
System uname: Linux-2.6.37-gentoo-r4-x86_64-AMD_Phenom-tm-_II_X6_1100T_Processor-with-gentoo-2.0.3
Timestamp of tree: Thu, 22 Mar 2012 05:15:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo sunrise x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL Q3AEULA ut2003 AdobeFlash-10.3 LOKI-EULA teamspeak3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://gentoo.mirrors.tds.net/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo http://mirror.usu.edu/mirrors/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /usr/local/portage"
SYNC="rsync://thetangos/gentoo-portage"
USE="X aac aalib acl acpi alsa amd64 artworkextra berkdb bzip2 cairo cdda cddb cdparanoia cdr cli consolekit cracklib crypt css cups cxx dbus device-mapper dlloaders dri dvd dvdr dvix dvix4linux eds encode esd exif extras faac faad fbcon fbcondecor ffmpeg firefox flac fortran gd gdbm gdu gif gnome gnome-keyring gnutls gpm gstreamer gtk guile iconv imagemagick imlib java jepg2k jpeg lame libnotify libwww mad mikmod mmx modules mp3 mpeg mudflap multilib nautilus ncurses networking nls nptl nptlonly nsplugin ntp nvidia ogg openal opengl openmp openxr oss pam pcre pdf png policykit pppd pulseaudio python quicktime readline sdl seamonkey session spell sqlite sqlite3 sse sse2 ssl svg sysfs tcpd tiff tng truetype udev unicode usb v4l v4l2 vcd vdpau vorbis wmf xinerama xorg xulrunner xv xvid zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Pacho Ramos gentoo-dev 2012-03-22 19:51:09 UTC
(In reply to comment #4)
> My drivers were updated yesterday to nvidia-drivers-295.20-r1 from the
> previous stable version and this bug showed up.  I can confirm that
> switching to xorg's opengl and restarting X (I run startx from a console)
> solves the problem.
> 
> My other observations when using nvidia's opengl are,
> 
> 1. A single gnome-terminal seems to be spawned all on its own.
> 2. A Bash (Zombie) process is associated with each running gnome-terminal
> (no gnome-terminal actually running on the desktop).
> 3. Every gnome-terminal I start fails to exit properly and consumes 96% to
> 110% of my CPU's.
> 

Maybe this is being shown under Gentoo because we are applying and old patch to launch gnome-terminal as login shell by default even if upstream (and other distributions) disables it:
/usr/portage/x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-default_shell.patch
Comment 6 Tango 2012-03-22 22:21:26 UTC
More information

Yesterday I also added the pulseaudio use flag in anticipation of Gnome3 becoming stable and ran emerge -avNuD world to pull in the required packages.  I had resisted using pulseaudio before as it just did not function all that well with my system and hardware. So to try and pin-point the cause of this problem I did some more testing.

1. Mask x11-drivers/nvidia-drivers-295.20-r1.
2. Revert back to the last stable nvidia-drivers.
3. Log out and reset nvidia and opengl to nvidia.
4. Restart X and start a gnome-terminal.
5. Exit the gnome-terminal.

Problem continued to be present (gnome-terminal fails to exit properly)

Next Step
1. Disable pulseaudio use flag.
2. Emerge -avNuD world.
3. Emerge -C all packages pulled in by pulseaudio and kill all related process.
4. Logout and restart X.
5. Started a gnome-terminal and exited the terminal.

Problem solved as gnome-terminal exited properly.

Next Step
1. Unmasked x11-drivers/nvidia-drivers-295.20-r1 and reinstall them.
2. Log out and reset nvidia and opengl to nvidia.
3. Restart X and start a gnome-terminal.
4. Exit the gnome-terminal (gnome-terminal continues to exit properly).

So this appears to be a problem related to pulseaudio and nvidia opengl.
Comment 7 Ira Moss 2012-03-23 01:05:45 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > My drivers were updated yesterday to nvidia-drivers-295.20-r1 from the
> > previous stable version and this bug showed up.  I can confirm that
> > switching to xorg's opengl and restarting X (I run startx from a console)
> > solves the problem.
> > 
> > My other observations when using nvidia's opengl are,
> > 
> > 1. A single gnome-terminal seems to be spawned all on its own.
> > 2. A Bash (Zombie) process is associated with each running gnome-terminal
> > (no gnome-terminal actually running on the desktop).
> > 3. Every gnome-terminal I start fails to exit properly and consumes 96% to
> > 110% of my CPU's.
> > 
> 
> Maybe this is being shown under Gentoo because we are applying and old patch
> to launch gnome-terminal as login shell by default even if upstream (and
> other distributions) disables it:
> /usr/portage/x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-
> default_shell.patch


Hmm, that is interesting.  Though, I have not seen the same results... in that I too (because of stablization) upgraded yesterday to the 295 rev of the nvidia drivers... However... I have had this problem with the 290 rev for quite some time.  It wasn't until recently when I found that my opengl was not using xorg-x11 (funny... blender will really not even start right without opengl :-)  ) that I realized this problem.  Now I'm confused... In that you didn't see this problem with the 290 drivers and opengl enabled... but I did?
Comment 8 Ira Moss 2012-03-23 01:06:29 UTC
i.e.   I have had the problem with both 290 and 295
Comment 9 Ira Moss 2012-03-23 01:17:41 UTC
(In reply to comment #6)
> More information
> 
> Yesterday I also added the pulseaudio use flag in anticipation of Gnome3
> becoming stable and ran emerge -avNuD world to pull in the required
> packages.  I had resisted using pulseaudio before as it just did not
> function all that well with my system and hardware. So to try and pin-point
> the cause of this problem I did some more testing.
> 
> 1. Mask x11-drivers/nvidia-drivers-295.20-r1.
> 2. Revert back to the last stable nvidia-drivers.
> 3. Log out and reset nvidia and opengl to nvidia.
> 4. Restart X and start a gnome-terminal.
> 5. Exit the gnome-terminal.
> 
> Problem continued to be present (gnome-terminal fails to exit properly)
> 
> Next Step
> 1. Disable pulseaudio use flag.
> 2. Emerge -avNuD world.
> 3. Emerge -C all packages pulled in by pulseaudio and kill all related
> process.
> 4. Logout and restart X.
> 5. Started a gnome-terminal and exited the terminal.
> 
> Problem solved as gnome-terminal exited properly.
> 
> Next Step
> 1. Unmasked x11-drivers/nvidia-drivers-295.20-r1 and reinstall them.
> 2. Log out and reset nvidia and opengl to nvidia.
> 3. Restart X and start a gnome-terminal.
> 4. Exit the gnome-terminal (gnome-terminal continues to exit properly).
> 
> So this appears to be a problem related to pulseaudio and nvidia opengl.


Tango, just to help narrow this down too...What does your profile look like?

i.e. eselect list profile?

I ask because, yes... I too had not wanted to run puslseaudio for quite sometime, but... it was pulled in automatically for me a few months ago... i.e. 

# eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/10.0
  [2]   default/linux/amd64/10.0/selinux
  [3]   default/linux/amd64/10.0/desktop
  [4]   default/linux/amd64/10.0/desktop/gnome *
  [5]   default/linux/amd64/10.0/desktop/kde
  [6]   default/linux/amd64/10.0/developer
  [7]   default/linux/amd64/10.0/no-multilib
  [8]   default/linux/amd64/10.0/server
  [9]   hardened/linux/amd64
  [10]  hardened/linux/amd64/selinux
  [11]  hardened/linux/amd64/no-multilib
  [12]  hardened/linux/amd64/no-multilib/selinux


my make.conf does not explicity have pulseaudio... however an emerge --info yields that I have it as a use flag.  

I'm not sure if this really matters or not, but my help narrow down some issues.  I'll have to try a recompile as well without pulse.  in looking through.../usr/portage/profiles/targets/desktop/gnome/make.defaults... it does have pulseaudio now...
Comment 10 Tango 2012-03-23 14:16:25 UTC
(In reply to comment #7)
> Hmm, that is interesting.  Though, I have not seen the same results... in
> that I too (because of stablization) upgraded yesterday to the 295 rev of
> the nvidia drivers... However... I have had this problem with the 290 rev
> for quite some time.  It wasn't until recently when I found that my opengl
> was not using xorg-x11 (funny... blender will really not even start right
> without opengl :-)  ) that I realized this problem.  Now I'm confused... In
> that you didn't see this problem with the 290 drivers and opengl enabled...
> but I did?

I never had the problem with the 290 series of drivers because I did not have pulseaudio enabled and installed until after the 295 update.  If you look at how I tested for this you will see that I continued to experience the problem when I reverted back to the 290 series with pulseaudio installed.  After I completely removed pulseaudio both the 290 and 295 drivers worked without any problems when using nvidia's opengl.

I use the default-amd64 profile not the gnome-desktop profile.  While I suspect the gnome-desktop profile enables pulseaudio by default I haven't verified this.  I am confused why an audio application can have this kind of effect on a video application, but then I am not a programmer nor do I fully understand how they all play together.


# eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/10.0 *
  [2]   default/linux/amd64/10.0/selinux
  [3]   default/linux/amd64/10.0/desktop
  [4]   default/linux/amd64/10.0/desktop/gnome
  [5]   default/linux/amd64/10.0/desktop/kde
  [6]   default/linux/amd64/10.0/developer
  [7]   default/linux/amd64/10.0/no-multilib
  [8]   default/linux/amd64/10.0/server
  [9]   hardened/linux/amd64
  [10]  hardened/linux/amd64/selinux
  [11]  hardened/linux/amd64/no-multilib
  [12]  hardened/linux/amd64/no-multilib/selinux

My system is stable and working great right now.  I am using nvidia-drivers-295.20-r1 with nvidia's opengl enabled and pulseaudio has been completely removed from my system.  Also I think the forms would be a better place to discuss this problem rather than here, until a solution or cause for it can be determined. I know there is a bug here somewhere, but where is the question.
Comment 11 Tango 2012-03-23 14:37:54 UTC
(In reply to comment #5)
> Maybe this is being shown under Gentoo because we are applying and old patch
> to launch gnome-terminal as login shell by default even if upstream (and
> other distributions) disables it:
> /usr/portage/x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-
> default_shell.patch

Maybe this is the problem but how would I go about testing this theory?  How do I remove the patch and build gnome-terminal without it?  I no nothing about writing ebuilds, but I do have basic understanding of how to use an overlay.
Comment 12 Pacho Ramos gentoo-dev 2012-03-23 19:10:02 UTC
You can try to edit ebuild and add a comment "#" just before "epatch" line. Then re-emerge gnome-terminal with "emerge -1 --digest gnome-terminal"
Comment 13 Tango 2012-03-24 01:29:45 UTC
(In reply to comment #12)
> You can try to edit ebuild and add a comment "#" just before "epatch" line.
> Then re-emerge gnome-terminal with "emerge -1 --digest gnome-terminal"

Followed your instructions and rebuilt gnome-terminal without the patch.

Re-enabled the pulseaudio USE flag and ran emerge -avNuD world.

I did a complete system reboot and after logging in and checking gnome-terminal the problem reappears.

It seems that if I use nvidia's opengl and have pulseaudio installed the gnome-terminal (and possibly other gnome apps) will fail to exit properly.
Comment 14 Doug Goldstein gentoo-dev 2012-03-24 01:48:38 UTC
It's likely possible this is related to something similar to bug #407593, given how much of the GNOME desktop is composited in OpenGL now days. I looked through mesa and the reference headers and saw a few more functions that mesa implemented differently from the spec.
Comment 15 nbblxuan 2012-07-06 19:58:10 UTC
On my computer, I solved this by altered "Sound theme" to "No sounds" in Sound Preferences! This is werid! Maybe a bug of gentoo.
Comment 16 Doug Goldstein gentoo-dev 2012-07-14 20:33:38 UTC
(In reply to comment #15)
> On my computer, I solved this by altered "Sound theme" to "No sounds" in
> Sound Preferences! This is werid! Maybe a bug of gentoo.

Are you using HDMI audio?
Comment 17 Doug Goldstein gentoo-dev 2012-07-22 22:14:33 UTC
If this issue is still occurring please run nvidia-bug-report.sh and e-mail the output along with a description of the issue to linux-bugs@nvidia.com