Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 40887 - licq-1.2.7 does not show special characters and newlines
Summary: licq-1.2.7 does not show special characters and newlines
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-08 14:28 UTC by Matthias F. Brandstetter
Modified: 2004-02-14 15:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias F. Brandstetter gentoo-dev 2004-02-08 14:28:37 UTC
Hi all,

after my upgrade to KDE-3.2.0 I updated my licq as well to version 1.2.7
(because of kde-plugin). But since then, my licq does not show any special
characters or umlauts (
Comment 1 Matthias F. Brandstetter gentoo-dev 2004-02-08 14:28:37 UTC
Hi all,

after my upgrade to KDE-3.2.0 I updated my licq as well to version 1.2.7
(because of kde-plugin). But since then, my licq does not show any special
characters or umlauts (äöü) or newlines like

here

only one long line. this happens everywhere in app (history view as well),
except in my text input field.

Is this a known issue? What can I do?
Greetings, Matthias

Reproducible: Always
Steps to Reproduce:
1. happens everywhere and anytime in my installation of licq-1.2.7
Comment 2 Michael Vasiliev 2004-02-11 05:12:28 UTC
I believe I have the same issue. After emerging some kde-3.2.0 base packages, all UTF-8 output support in licq kde plugin stopped working. I mean i can write and send messages, and i see what I write in the input window, but the output window does not recognize that as utf-8, and two-byte text is printed out as twice as much of gibberish. The same with history view.
Comment 3 Alexander Jenisch 2004-02-12 13:48:00 UTC
there's a patch for that, made by "bcat". i talked to him today on irc:

http://www.sjaensch.org/licq-qt3.3-sprintf.patch
Comment 4 Alexander Jenisch 2004-02-12 13:52:16 UTC
i forgot to mention, that that patch is tested only against licq CVS by the time beeing. maybe someone tries it out with qt 3.3?
Comment 5 Alexander Jenisch 2004-02-12 14:44:48 UTC
this one should be ok for 1.2.7, but it's still untested, i will test it, when my qt-3.3 has finished compiling, would be great if anyone else would try it too. this patch is again from "bcat" (freenode, #licq):

http://www.sjaensch.org/licq1.2.7-qt3.3-sprintf.patch
Comment 6 Michael Vasiliev 2004-02-13 05:48:41 UTC
Just tested licq1.2.7-qt3.3-sprintf.patch with qt-3.3.0, kde-3.1.5 and licq-1.2.7
It works, and i see no problems so far, everything is back to normal. Thanks a lot!
Comment 7 Matthias F. Brandstetter gentoo-dev 2004-02-13 16:02:04 UTC
... so, what to do now, if you have KDE-3.2.0 and licq-1.2.7 installed "the
Gentooish way", w/o any 3rd-party patches?
Comment 8 Matthias F. Brandstetter gentoo-dev 2004-02-14 15:06:47 UTC
Good, I re-emerged licq-1.2.7 and everything is ok now!
Thanks for all your help!

Greetings, Matthias