Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 40881 - GCC-3.3.2-r5 emerge fails with "cc1: unrecognized option `-auxbase'"
Summary: GCC-3.3.2-r5 emerge fails with "cc1: unrecognized option `-auxbase'"
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Please assign to toolchain
Depends on:
Reported: 2004-02-08 14:02 UTC by b serviss
Modified: 2004-09-03 11:58 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description b serviss 2004-02-08 14:02:08 UTC
When I try to upgrade from Gcc-3-2-3-r3 to Gcc-3.3.2-r5, the emerge fails with the message: "cc1: unrecognized option `-auxbase' " and "cc1: output filename specified twice ".
A Google search on this problem shows a few hits which relate a distribution problem. But as these posts referred to a Mandrake install, I don't know if it's significant.

Reproducible: Always
Steps to Reproduce:
1.Emerge gcc
Actual Results:  
gcc -c   -O -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes 
-Wmissing-prototypes -pedantic -Wno-long-long   -DHAVE_CONFIG_H    
-DSTANDARD_EXEC_PREFIX=\"/usr/lib/gcc-lib/\" -DDEFAULT_TARGET_VERSION=\"3.3.2\" 
-DTOOLDIR_BASE_PREFIX=\"../../../../\"  `test "X${SHLIB_LINK}" = "X" || test 
"yes" != "yes" || echo "-DENABLE_SHARED_LIBGCC"` `test "X${SHLIB_MULTILIB}" = 
        -I. -I. -I/var/tmp/portage/gcc-3.3.2-r5/work/gcc-3.3.2/gcc 
-I/var/tmp/portage/gcc-3.3.2-r5/work/gcc-3.3.2/gcc/../include /var/tmp/portage/gcc-3.3.2-r5/work/gcc-3.3.2/gcc/cp/g++spec.c) 
cc1: unrecognized option `-auxbase' 
cc1: output filename specified twice 
make[2]: *** [g++spec.o] Error 1 
make[2]: Leaving directory `/var/tmp/portage/gcc-3.3.2-r5/work/build/gcc' 
make[1]: *** [stage1_build] Error 2 
make[1]: Leaving directory `/var/tmp/portage/gcc-3.3.2-r5/work/build/gcc' 
make: *** [bootstrap-lean] Error 2 
!!! ERROR: sys-devel/gcc-3.3.2-r5 failed. 
!!! Function src_compile, Line 432, Exitcode 2 
!!! (no error message) 

Expected Results:  
correct upgrade of gcc 

root@bk kdelibs # emerge info 
Portage 2.0.50 (default-x86-1.4, gcc-3.2.3, glibc-2.2.5-r4,2.3.2-r9, 
System uname: 2.4.22-gentoo-r5 i686 AMD Athlon(tm) processor 
Gentoo Base System version 
Autoconf: sys-devel/autoconf-2.58 
Automake: sys-devel/automake-1.7.7 
CFLAGS="-mcpu=athlon -O3 -pipe" 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3/share/config /usr/share/config /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d" 
CXXFLAGS="-mcpu=athlon -O3 -pipe" 
FEATURES="autoaddcvs ccache sandbox" 
USE="3dnow X alsa apache2 apm arts avi berkdb bonobo cdr crypt cups encode esd 
foomaticdb gdbm gif glut gnome gpm gps gtk gtk2 guile imlib jpeg kde lame 
libg++ libwww mad mikmod mitshm motif mozilla mpeg mysql ncurses nls ogg 
oggvorbis opengl oss pam pdflib perl png python qt qtmt quicktime readline ruby 
scanner sdl slang spell ssl svga tcltk tcpd tetex tex truetype usb vorb 
wxwindows x86 xml xml2 xmms xv zlib" 
I've also tried to emerge gcc with: 
USE="-java" emerge gcc 
with the same results.
Comment 1 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-11 13:20:37 UTC
I cannot say I have seen this before.  Only thing I do notice, is that you
have both glibc-2.3.2 and 2.2.5 installed?
Comment 2 b serviss 2004-02-11 14:41:57 UTC
Yes, I checked and both versions are installed. Should I remove the old version?
Comment 3 b serviss 2004-02-11 18:49:18 UTC
I removed the old version of glibc and still have the same emerge error.
Comment 4 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-11 20:00:13 UTC
Just make sure glibc-2.3.3-r9 is the last one installed ..
Comment 5 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-12 09:43:53 UTC
Can you try with automake-1.7.8?
Comment 6 b serviss 2004-02-12 17:35:17 UTC
I've tried Automake-1.7.8 with the same error result.
I have been running Gentoo for quite a while and with the exception of wxPython, this has been the only problem I haven't been able to solve through the forums. As a side note, I saw an "auxbase" problem like mine mentioned in the forums with no solution listed. I'm going to follow that up.

Do I need to re-install Gentoo?
Comment 7 Martin Schlemmer (RETIRED) gentoo-dev 2004-02-14 05:31:39 UTC
Not sure to be honest.  I have never seen this before.  The only references
I can find, seems to be auto{make,conf} related.  What if you try -r7 of gcc?
Comment 8 b serviss 2004-02-14 11:47:29 UTC
I tried -r7 of gcc with no success. I also tried an experimental ebuild for gcc-3.4 with the same error. I tried to bootstrap with the stage1 tar which fails at "findinc".

As I'm the only one affected by this I'm going to try bootstraping one more time. Failing that,a complete reinstall from a livecd.

Please feel free to close this bug report as it is probably a waste of time.

Thanks for all your help,

Comment 9 Alexander Gabert (RETIRED) gentoo-dev 2004-03-11 06:53:04 UTC
this smells coincidental to #32763 but it is not quite the same error
Comment 10 Caleb Tennis (RETIRED) gentoo-dev 2004-09-03 11:58:14 UTC
closing as a cantfix.