Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 408651 - media-gfx/structure-synth-1.5.0 - StructureSynth/.../Sphere.h:25:4: error: ‘GLUquadric’ does not name a type
Summary: media-gfx/structure-synth-1.5.0 - StructureSynth/.../Sphere.h:25:4: error: ‘G...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
: 462696 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-17 22:40 UTC by Piotr Szymaniak
Modified: 2018-06-08 20:55 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build.log (Build.log,7.79 KB, text/plain)
2012-03-17 22:40 UTC, Piotr Szymaniak
Details
include glu.h in the files necessary (glu.patch,570 bytes, patch)
2012-06-04 10:41 UTC, Oliver Koch
Details | Diff
patched ebuild (structure-synth-1.5.0.ebuild,1.06 KB, text/plain)
2012-06-04 10:43 UTC, Oliver Koch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Szymaniak 2012-03-17 22:40:35 UTC
Created attachment 305771 [details]
Build.log

Portage 2.2.0_alpha90 (default/linux/x86/10.0, gcc-4.6.2, glibc-2.14.1-r2, 3.2.7 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.2.7-i686-Intel-R-_Pentium-R-_4_CPU_2.60GHz-with-gentoo-2.1
Timestamp of tree: Thu, 15 Mar 2012 11:15:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
ccache version 3.1.7 [disabled]
app-shells/bash:          4.2_p24
dev-lang/python:          2.7.2-r3, 3.2.2
dev-util/ccache:          3.1.7
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.68
sys-devel/automake:       1.11.3
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.2
sys-devel/gcc-config:     1.5.1-r1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.2-r1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r2
Repositories: gentoo roslin neurogeek
Installed sets: 
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Os -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks ebuild-locks fixlafiles news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.ift.uni.wroc.pl/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/root/roslin /root/neurogeek"
SYNC="rsync://rsync1.pl.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm gpm iconv ipv6 modules mudflap nls nptl nptlonly openmp pam pcre pppd readline session ssl sysfs tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

[ebuild  N    ] app-text/poppler-data-0.4.5 
[ebuild  N    ] x11-proto/xproto-7.0.22  USE="-doc" 
[ebuild  N    ] x11-proto/xextproto-7.2.0  USE="-doc" 
[ebuild  N    ] media-libs/freetype-2.4.9  USE="bzip2 -X -auto-hinter -bindist -debug -doc -fontforge -static-libs -utils" 
[ebuild  N    ] x11-libs/qt-core-4.8.0-r1  USE="exceptions glib iconv ssl (-aqua) (-c++0x) -debug -optimized-qmake -pch (-qpa) -qt3support" 
[ebuild  N    ] x11-libs/xtrans-1.2.6  USE="-doc" 
[ebuild  N    ] media-libs/libpng-1.5.9  USE="-apng (-neon) -static-libs" 
[ebuild  N    ] x11-proto/inputproto-2.2 
[ebuild  N    ] x11-proto/renderproto-0.11.1 
[ebuild  N    ] app-text/libpaper-1.1.24-r1 
[ebuild  N    ] media-libs/tiff-4.0.1  USE="cxx zlib -jbig -jpeg -lzma -static-libs" 
[ebuild  N    ] dev-libs/libpthread-stubs-0.3  USE="-static-libs" 
[ebuild  N    ] app-admin/eselect-opengl-1.2.5-r1 
[ebuild  N    ] x11-proto/xf86vidmodeproto-2.3.1 
[ebuild  N    ] app-arch/unzip-6.0-r2  USE="bzip2 unicode -natspec" 
[ebuild  N    ] app-admin/eselect-qtgraphicssystem-1.1.1 
[ebuild  N    ] x11-proto/fontsproto-2.1.1  USE="-doc" 
[ebuild  N    ] media-libs/jbig2dec-0.11-r1  USE="-png -static-libs -test" 
[ebuild  N    ] media-libs/lcms-2.3  USE="zlib -doc -jpeg -static-libs -test -tiff" 
[ebuild  N    ] app-arch/rpm2targz-9.0.0.4g 
[ebuild  N    ] media-libs/lcms-1.19  USE="zlib -jpeg -python -static-libs -tiff" 
[ebuild  N    ] x11-proto/randrproto-1.3.2 
[ebuild  N    ] x11-proto/kbproto-1.0.5 
[ebuild  N    ] x11-proto/xf86bigfontproto-1.2.0 
[ebuild  N    ] media-fonts/font-util-1.3.0 
[ebuild  N    ] x11-misc/util-macros-1.17 
[ebuild  N    ] x11-proto/xcb-proto-1.7-r1 
[ebuild  N    ] dev-libs/libgpg-error-1.10-r1  USE="nls -common-lisp -static-libs" 
[ebuild  N    ] dev-lang/nasm-2.09.10  USE="-doc" 
[ebuild  N    ] x11-proto/dri2proto-2.6 
[ebuild  N    ] app-admin/eselect-mesa-0.0.10 
[ebuild  N    ] x11-proto/xf86driproto-2.1.1 
[ebuild   R   ] dev-libs/libxml2-2.7.8-r5  USE="ipv6 python* readline -debug -doc -examples -icu -static-libs -test" 
[ebuild  N    ] x11-libs/libpciaccess-0.13  USE="zlib -minimal -static-libs" 
[ebuild  N    ] x11-proto/damageproto-1.2.1 
[ebuild  N    ] x11-libs/qt-script-4.8.0  USE="exceptions iconv jit (-aqua) (-c++0x) -debug -pch (-qpa)" 
[ebuild  N    ] x11-libs/libfontenc-1.1.1  USE="-static-libs" 
[ebuild  N    ] x11-proto/fixesproto-5.0 
[ebuild  N    ] app-arch/libarchive-3.0.3  USE="acl bzip2 e2fsprogs iconv lzma zlib -expat -nettle -static-libs -xattr" 
[ebuild  N    ] x11-libs/libICE-1.0.8  USE="ipv6 -doc -static-libs" 
[ebuild  N    ] x11-libs/libXdmcp-1.1.1  USE="-doc -static-libs" 
[ebuild  N    ] x11-libs/libXau-1.0.7  USE="-static-libs" 
[ebuild  N    ] dev-libs/libgcrypt-1.5.0-r2  USE="-static-libs" 
[ebuild  N    ] media-libs/libjpeg-turbo-1.2.0-r1  USE="-java -static-libs" 
[ebuild  N    ] sys-devel/llvm-3.0-r1  USE="libffi -debug -gold -multitarget -ocaml -test -udis86 -vim-syntax" 
[ebuild  N    ] x11-proto/glproto-1.4.15 
[ebuild  N    ] x11-misc/makedepend-1.0.4 
[ebuild  N    ] x11-libs/libdrm-2.4.31  USE="-libkms -static-libs" VIDEO_CARDS="intel nouveau radeon vmware" 
[ebuild  N    ] virtual/jpeg-0  USE="-static-libs" 
[ebuild  N    ] x11-libs/libSM-1.2.1  USE="ipv6 uuid -doc -static-libs" 
[ebuild  N    ] x11-libs/libXfont-1.4.5  USE="ipv6 -doc -static-libs" 
[ebuild  N    ] dev-util/cmake-2.8.7-r5  USE="-emacs -ncurses -qt4 -test -vim-syntax" 
[ebuild  N    ] dev-libs/libxslt-1.1.26-r3  USE="crypt -debug -python -static-libs" 
[ebuild  N    ] x11-libs/libxcb-1.8.1  USE="-doc (-selinux) -static-libs" 
[ebuild  N    ] x11-libs/libX11-1.4.4  USE="ipv6 -doc -static-libs -test" 
[ebuild  N    ] x11-libs/libXext-1.3.1  USE="-doc -static-libs" 
[ebuild  N    ] x11-libs/libXfixes-5.0  USE="-static-libs" 
[ebuild  N    ] x11-libs/libXrender-0.9.7  USE="-static-libs" 
[ebuild  N    ] x11-libs/libXrandr-1.3.2  USE="-static-libs" 
[ebuild  N    ] x11-libs/libXcursor-1.1.13  USE="-static-libs" 
[ebuild  N    ] x11-libs/libXi-1.5.0  USE="-doc -static-libs" 
[ebuild  N    ] x11-libs/libXdamage-1.1.3  USE="-static-libs" 
[ebuild  N    ] x11-libs/libXxf86vm-1.1.2  USE="-static-libs" 
[ebuild  N    ] media-libs/mesa-8.0.1-r2  USE="classic egl gallium llvm nptl shared-glapi -bindist -d3d -debug -g3dvl -gbm -gles1 -gles2 -openvg -osmesa -pax_kernel -pic (-selinux) -shared-dricore -vdpau -wayland -xa -xvmc" VIDEO_CARDS="intel nouveau radeon vmware -i915 -i965 -r100 -r200 -r300 -r600" 
[ebuild  N    ] virtual/opengl-7.0 
[ebuild  N    ] media-libs/fontconfig-2.8.0-r2  USE="-doc -static-libs" 
[ebuild  N    ] app-admin/eselect-fontconfig-1.1 
[ebuild  N    ] media-fonts/dejavu-2.33  USE="-X -fontforge" 
[ebuild  N    ] virtual/ttf-fonts-1 
[ebuild  N    ] app-text/poppler-0.18.4  USE="cxx introspection lcms utils xpdf-headers -cairo -cjk -curl -debug -doc -jpeg -jpeg2k -png -qt4 -tiff" 
[ebuild  N    ] media-fonts/urw-fonts-2.4.9  USE="-X" 
[ebuild  N    ] net-print/cups-1.5.2-r1  USE="acl filters jpeg pam png ssl threads tiff -X -dbus -debug -gnutls -java -kerberos -ldap -perl -python -slp -static-libs -usb -xinetd" LINGUAS="-da -de -es -eu -fi -fr -id -it -ja -ko -nl -no -pl -pt -pt_BR -ru -sv -zh -zh_TW" 
[ebuild  N    ] app-text/ghostscript-gpl-9.05  USE="cups -X -bindist -dbus -djvu -gtk -idn -jpeg2k -static-libs" LINGUAS="-ja -ko -zh_CN -zh_TW" 
[ebuild  N    ] net-print/foomatic-filters-4.0.12  USE="cups -dbus" 
[ebuild  N    ] x11-libs/qt-gui-4.8.0-r2  USE="accessibility cups exceptions glib (-aqua) (-c++0x) -dbus -debug -egl -gif -gtkstyle -mng -nas -nis -pch (-qpa) -qt3support -tiff -trace -xinerama" 
[ebuild  N    ] x11-libs/qt-opengl-4.8.0-r2  USE="exceptions (-aqua) (-c++0x) -debug -egl -pch (-qpa) -qt3support" 
[ebuild  N    ] media-gfx/structure-synth-1.5.0
Comment 1 Oliver Koch 2012-06-04 10:41:30 UTC
Created attachment 314153 [details, diff]
include glu.h in the files necessary

put this in /usr/portage/media-gfx/structure-synth/files/glu.patch
Comment 2 Oliver Koch 2012-06-04 10:43:13 UTC
Created attachment 314155 [details]
patched ebuild

ebuild with changes to include glu
Comment 3 Oliver Koch 2012-06-04 10:52:07 UTC
The two attachments above should enable you to compile the package.
Comment 4 Priit Laes (IRC: plaes) 2013-01-08 10:54:27 UTC
(In reply to comment #3)
> The two attachments above should enable you to compile the package.

This package also needs to link against media-libs/glu (otherwise you get some linking issues), so following extra modifications were needed:

RDEPEND+="media-libs/glu"

And I also changed the makefile generation command to include glu library:

qmake -project -o ${PN}.pro -after "CONFIG+=opengl link_pkgconfig" \
      -after "PKGCONFIG+=glu" -after "QT+=xml opengl script" \
    || die "qmake failed"
Comment 5 Diego Elio Pettenò (RETIRED) gentoo-dev 2014-10-28 00:42:31 UTC
*** Bug 462696 has been marked as a duplicate of this bug. ***
Comment 6 Toralf Förster gentoo-dev 2014-11-06 22:55:55 UTC
same here at an ~amd64 chroot
Comment 7 Sobhan Mohammadpour gentoo-dev 2017-11-22 19:40:29 UTC
(In reply to Oliver Koch from comment #2)
> Created attachment 314155 [details]
> patched ebuild
> 
> ebuild with changes to include glu

this doesn't compile for!
Comment 8 Larry the Git Cow gentoo-dev 2018-06-08 20:55:47 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=efc89d1aa9607e6c810555b8426458320731a4af

commit efc89d1aa9607e6c810555b8426458320731a4af
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-06-02 11:32:18 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-06-08 20:55:10 +0000

    media-gfx/structure-synth: Remove last-rited package
    
    Closes: https://bugs.gentoo.org/408651
    Closes: https://bugs.gentoo.org/642950
    Closes: https://bugs.gentoo.org/651622

 media-gfx/structure-synth/Manifest                 |  1 -
 media-gfx/structure-synth/metadata.xml             | 11 -------
 .../structure-synth/structure-synth-1.5.0.ebuild   | 38 ----------------------
 profiles/package.mask                              |  5 ---
 4 files changed, 55 deletions(-)