Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 407079 - net-im/prosody-? not compatible with >=dev-lang/lua-5.2.0
Summary: net-im/prosody-? not compatible with >=dev-lang/lua-5.2.0
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Tobias Klausmann
URL: https://groups.google.com/group/proso...
Whiteboard:
Keywords:
Depends on:
Blocks: lua-5.2
  Show dependency tree
 
Reported: 2012-03-06 09:54 UTC by Tobias Klausmann
Modified: 2020-01-09 19:01 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed patch to block too-new versions of Lua (prosody_lua_5.2_block.patch,1.52 KB, text/plain)
2012-03-06 10:01 UTC, Tobias Klausmann
Details
correctly annotated version of patch (prosody_lua_5.2_block.patch,1.52 KB, patch)
2012-03-06 10:03 UTC, Tobias Klausmann
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Klausmann gentoo-dev 2012-03-06 09:54:23 UTC
Lua 5.2 is very different from 5.1. See discussion at $link.
Comment 1 Tobias Klausmann gentoo-dev 2012-03-06 10:01:22 UTC
Created attachment 304375 [details]
Proposed patch to block too-new versions of Lua

Added proposed patch to the builds to block newer versions of Lua.
Comment 2 Tobias Klausmann gentoo-dev 2012-03-06 10:03:00 UTC
Created attachment 304377 [details, diff]
correctly annotated version of patch
Comment 3 Dirkjan Ochtman gentoo-dev 2012-03-06 10:17:03 UTC
You should add yourself to the maintainers and commit it yourself!
Comment 4 Tobias Klausmann gentoo-dev 2012-03-06 10:40:55 UTC
Done & done.
Comment 5 Samuli Suominen gentoo-dev 2012-03-06 10:42:21 UTC
How is this anykind of patch? lua is _NOT_ slotted
Comment 6 Samuli Suominen gentoo-dev 2012-03-06 10:45:19 UTC
Comment on attachment 304377 [details, diff]
correctly annotated version of patch

bogus
Comment 7 Jeroen Roovers gentoo-dev 2012-08-07 09:35:25 UTC
What version isn't compatible and how is it incompatible?
Comment 8 Tobias Klausmann gentoo-dev 2012-08-07 11:19:17 UTC
The details of how/why are at $link, as mentioned.

As for versions: Lua >=5.2 is sufficiently different from <5.2 that Prosody up to and including 0.8.2 (latest release according to http://prosody.im/ ) will not work with it. 

Above mentioned link also has the main dev saying that migrating to being 5.2-compatible is desirable and planned -- but no release has been made since then.
Comment 9 Daniel Kenzelmann 2017-03-14 10:56:27 UTC
It has been 5 years, current prosody version is 0.9.12

Is this really still dependent on lua-5.1 ?
What about others like luasec and lua-zlib (also currently depending on lua:0 in portage)?
Comment 10 schmittlauch 2017-05-11 10:23:59 UTC
Prosody-0.10 will support lua-5.2, although it won't be as well-tested as with 5.1 https://prosody.im/issues/issue/299#comment-6
I suggest migrating to lua-5.2 ince prosody-0.10 is released although this is not recommended by the prosody devs. But getting rid of this lua-5.2 blocker should be quite important.
Comment 11 schmittlauch 2017-10-04 13:36:44 UTC
Good news: prosody-0.10.0 is finally released and includes initial support for lua-5.2! http://blog.prosody.im/prosody-0-10-0-released/

Although the developers still recommend lua-5.1 for stable servers, it might be worth a thought to create at least a use flag for running prosody with lua-5.2 if other packages require lua-5.2. That way we can get rid of the lua blocker while still running prosody as stable as possible with 5.1 if no other packages require a lua-5.2

Is this actually possible with portage?
Comment 12 Daniel Kenzelmann 2017-10-04 14:03:18 UTC
I'd prefer to just remove the blocker and allow lua 5.2
(from what i gathered the 5.1 recommendation in the changelog is just "in case"... )

Maybe adding a local use flag lua51 for now and just could be just dropped later
Comment 13 Tobias Klausmann gentoo-dev 2018-12-29 09:02:04 UTC
So for Prosody >=0.11 upstream recommends Lua 5.2:

"The recommended Lua version for 0.11 is Lua 5.2, while Lua 5.1 is still supported for the platforms that need it. However the 0.11.x series is the last series that will still support Lua 5.1 (and by extension, LuaJIT)."

(from https://prosody.im/doc/release/0.11.0#lua-5.2)

Thus arguably, this bug can be closed. Note that it is not the last blocker for the 5.2 unmasking bug. I will try and do some testing of Prosody with 5.2 sometime soon and the report back here.