Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 406685 - app-arch/torrentzip-0.9 version bump request
Summary: app-arch/torrentzip-0.9 version bump request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: http://sourceforge.net/projects/trrnt...
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2012-03-02 23:30 UTC by Paul Hartman
Modified: 2016-02-20 14:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
torrentzip-0.9.ebuild (torrentzip-0.9.ebuild,828 bytes, text/plain)
2012-03-02 23:32 UTC, Paul Hartman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Hartman 2012-03-02 23:30:52 UTC
trrntzip 0.9 is available, containing various improvements and bugfixes, most notably the addition of ZIP64 support (>2GB archive support, >4GB file support) and utf8 filename support. Resulting files are compatible with those created by the older versions.

There is no proper source tarball that I can find since 2005, but the version 0.9 snapshot tarball can be downloaded from sourceforge's SVN browser. I named my local copy trrntzip-0.9.tar.gz so that's how the ebuild refers to it.

An ebuild will be attached. Please review it as I most likely did things wrong. :)


Reproducible: Always
Comment 1 Paul Hartman 2012-03-02 23:32:47 UTC
Created attachment 304067 [details]
torrentzip-0.9.ebuild
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2012-03-05 13:10:01 UTC
DESCRIPTION is too long. :)
Comment 3 Kerin Millar 2012-12-30 07:20:56 UTC
How about this:

DESCRIPTION="An archiver that uses a modified ZIP format guaranteed to be invariant, given the same source files"