Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 405813 - media-libs/libvpx-1.0.0 USE=ssse3 - x86_systemdependent.c:(.text+0x263): undefined reference to `vp8_build_intra_predictors_mbuv_ssse3'
Summary: media-libs/libvpx-1.0.0 USE=ssse3 - x86_systemdependent.c:(.text+0x263): unde...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-25 19:44 UTC by Andrey Falko
Modified: 2013-06-25 16:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,13.02 KB, text/plain)
2012-02-25 19:51 UTC, Andrey Falko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Falko 2012-02-25 19:44:37 UTC
[LD] libvpx.so.0.9.7
vp8/common/x86/x86_systemdependent.c.o: In function `vp8_arch_x86_common_init':
x86_systemdependent.c:(.text+0x263): undefined reference to `vp8_build_intra_predictors_mbuv_ssse3'
x86_systemdependent.c:(.text+0x271): undefined reference to `vp8_build_intra_predictors_mbuv_s_ssse3'
vp8/encoder/x86/variance_ssse3.c.o: In function `vp8_sub_pixel_variance16x16_ssse3':
variance_ssse3.c:(.text+0x88): undefined reference to `vp8_half_horiz_variance16x_h_sse2'
variance_ssse3.c:(.text+0xb4): undefined reference to `vp8_half_horiz_vert_variance16x_h_sse2'
variance_ssse3.c:(.text+0xdb): undefined reference to `vp8_half_vert_variance16x_h_sse2'
vp8/encoder/x86/variance_ssse3.c.o: In function `vp8_sub_pixel_variance16x8_ssse3':
variance_ssse3.c:(.text+0x188): undefined reference to `vp8_half_horiz_variance16x_h_sse2'
variance_ssse3.c:(.text+0x1b4): undefined reference to `vp8_half_horiz_vert_variance16x_h_sse2'
variance_ssse3.c:(.text+0x1db): undefined reference to `vp8_half_vert_variance16x_h_sse2'
collect2: ld returned 1 exit status
make[1]: *** [libvpx.so.0.9.7] Error 1
make: *** [.DEFAULT] Error 2

Reproducible: Always

Steps to Reproduce:
emerge media-libs/libvpx as a dependency during update
Actual Results:  
See description

Expected Results:  
Package compiles

# emerge --info =media-libs/libvpx-0.9.7-r1
Portage 2.1.10.44 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.13-r4, 3.0.9 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.0.9-x86_64-AMD_Phenom-tm-_II_X6_1100T_Processor-with-gentoo-2.0.3
Timestamp of tree: Sat, 25 Feb 2012 19:00:02 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r3, 3.1.4-r3
dev-util/cmake:           2.8.6-r4
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en ru"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl alsa amd64 apache2 apng arts bash-completion berkdb branding bzip2 cairo cdda cddb cli consolekit cracklib crypt cups curl cxx dbus declarative device-mapper dri dts dvb dvd dvdread encode enscript exif fax fbcon ffmpeg firefox flac foomaticdb fortran gd gdbm gif gimpprint gnome gphoto2 gpm gstreamer gtk hal hpijs iconv imap imlib iproute2 ipv6 java jpeg kde kdeenablefinal kpathsea lame libwww lm_sensors lzma mad maildir matroska mikmod mjpeg mmx mng modules motif mp3 mpeg mplayer mudflap multilib mysql mysqli ncurses nls nptl nptlonly nsplugin nvidia odk offensive ogg openal opengl openmp optimisememory oss pam pcntl pcre pdf perl php plasma png policykit postfix postgres ppds pppd python qemu-ifup qt3support qt4 quicktime readline rpm rtsp sasl scanner sdl sdl-image secure-delete semantic-desktop session snmp sound speex spell sql sqlite ssl ssse3 stream subversion svg sysfs tcpd tetex theora threads tiff tk truetype unicode usb v4l vcd vde vim-syntax vorbis webdav webkit wxwindows x264 xcb xinerama xml xorg xv xvid zip zlib" ALSA_CARDS="usb-usx2y hdsp hdspm" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias cgi" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="hp1020" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" LIRC_DEVICES="hauppauge" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

# emerge -pqv =media-libs/libvpx-0.9.7-r1
[ebuild     U ] media-libs/libvpx-0.9.7-r1 [0.9.6] USE="mmx ssse3 threads (-altivec) -debug -doc -postproc -sse -sse2 -sse3 -static-libs%"
Comment 1 Andrey Falko 2012-02-25 19:49:34 UTC
The workaround is to build libvpx with ssse3 USE flag disabled. Will upload build.log shortly.
Comment 2 Andrey Falko 2012-02-25 19:51:49 UTC
Created attachment 303217 [details]
build.log
Comment 3 Andrey Falko 2012-03-06 07:27:25 UTC
Same problem with media-libs/libvpx-1.0.0
Comment 4 Samuli Suominen gentoo-dev 2012-03-06 07:37:03 UTC
(In reply to comment #0)
> Linux-3.0.9-x86_64-AMD_Phenom-tm-_II_X6_1100T_Processor-with-gentoo-2.0.3
>
> [ebuild     U ] media-libs/libvpx-0.9.7-r1 [0.9.6] USE="mmx ssse3 threads
> (-altivec) -debug -doc -postproc -sse -sse2 -sse3 -static-libs%"

Are you absolutely sure that CPU is even supposed to support ssse3? If yes, how did you verify?
Comment 5 Andrey Falko 2012-03-06 08:08:56 UTC
(In reply to comment #4)
> (In reply to comment #0)
> > Linux-3.0.9-x86_64-AMD_Phenom-tm-_II_X6_1100T_Processor-with-gentoo-2.0.3
> >
> > [ebuild     U ] media-libs/libvpx-0.9.7-r1 [0.9.6] USE="mmx ssse3 threads
> > (-altivec) -debug -doc -postproc -sse -sse2 -sse3 -static-libs%"
> 
> Are you absolutely sure that CPU is even supposed to support ssse3? If yes,
> how did you verify?

You are right. I do not have ssse3 support on my CPU. The way to check is to see if you the ssse3 flag is in /proc/cpuinfo, at least according to this: http://forums.gentoo.org/viewtopic-p-5389373.html?sid=e3a4ba71947aab951cf3b4eafbd3c915
Comment 6 Samuli Suominen gentoo-dev 2013-01-15 22:37:22 UTC
*** Bug 416291 has been marked as a duplicate of this bug. ***
Comment 7 Alexis Ballier gentoo-dev 2013-06-25 16:52:54 UTC
   25 Jun 2013; Alexis Ballier <aballier@gentoo.org> libvpx-9999.ebuild:
+  ssse3 requires sse2, bug #405813