Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 405139 - =x11-base/xorg-server-1.11.4 fails to build with CFLAGS="-O3" (?)
Summary: =x11-base/xorg-server-1.11.4 fails to build with CFLAGS="-O3" (?)
Status: RESOLVED DUPLICATE of bug 402285
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-21 12:33 UTC by n1ghtmare
Modified: 2012-02-21 12:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description n1ghtmare 2012-02-21 12:33:06 UTC
xorg-server-1.11.4 fails to compile with -O3 given in cflags, with -O2 it compiles fine.
like in the package doxygen there should be a temporary backswitch to -O2 so that the bogus wouldnt break a complete system rebuild via "emerge -evD world".

Reproducible: Always

Steps to Reproduce:
1.emerge -1v xorg-server with -O3 in cflags
2.
3.
Actual Results:  
breaks with:

/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c: In function 'handle_detailed_modes':
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:750:19: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:749:19: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:748:19: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:747:33: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:750:19: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:749:19: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:748:19: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:747:33: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:750:19: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:749:19: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:748:19: error: array subscript is above array bounds
/var/tmp/portage/x11-base/xorg-server-1.11.4/work/xorg-server-1.11.4/hw/xfree86/modes/xf86EdidModes.c:747:33: error: array subscript is above array bounds
make[4]: *** [xf86EdidModes.lo] Fehler 1

Expected Results:  
clean merge
Comment 1 Samuli Suominen gentoo-dev 2012-02-21 12:40:41 UTC
Need full build.log and emerge --info attached. 

Also, -O3 is just a collection of optimizations and they are not even same between GCC releases, so you need to pinpoint the problem to a specific flag instead of a full optimization level.

Reopen with the problematic flag revealed, and with the asked log & info.
Comment 2 Chí-Thanh Christopher Nguyễn gentoo-dev 2012-02-21 12:51:18 UTC

*** This bug has been marked as a duplicate of bug 402285 ***