Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 404579 - net-misc/remmina-1.0.0 shouldn't have USE=gtk3 and GTK+-3 should always be preferred
Summary: net-misc/remmina-1.0.0 shouldn't have USE=gtk3 and GTK+-3 should always be pr...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tristan Heaven (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-19 20:59 UTC by Daniel M. Weeks
Modified: 2012-03-10 13:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild with lib corrections (remmina-1.0.0-r1.ebuild,2.09 KB, text/plain)
2012-02-21 07:26 UTC, Daniel M. Weeks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel M. Weeks 2012-02-19 20:59:54 UTC
remmina 1.0.0 supports both GTK2 and GTK3 but there is no use flag present - it forces GTK3 dependencies.

Differences:
GTK3: vte:2.90, gtk+:3, avahi[gtk3]
GTK2: vte:0, gtk+:2

Also, the unique use flag can be removed as support has been removed.

Reproducible: Always
Comment 1 Mike Gilbert gentoo-dev 2012-02-20 20:31:29 UTC
Thanks for the report Daniel.

The hard-dependency on GTK3 is intentional. The GNOME team does not intend to support GTK2 forever. I refer you to bug 374057.

Are you experiencing a problem with Remmina that occurs when it is built against GTK3? If so, lets try and address that.
Comment 2 Mike Gilbert gentoo-dev 2012-02-20 20:46:23 UTC
+  20 Feb 2012; Mike Gilbert <floppym@gentoo.org> -remmina-1.0.0.ebuild,
+  remmina-1.0.0-r1.ebuild, remmina-9999.ebuild:
+  Drop unique use flag. Bug 404579 by Daniel M. Weeks.
Comment 3 Daniel M. Weeks 2012-02-20 21:45:30 UTC
(In reply to comment #1)
> Thanks for the report Daniel.
> 
> The hard-dependency on GTK3 is intentional. The GNOME team does not intend to
> support GTK2 forever. I refer you to bug 374057.
> 
> Are you experiencing a problem with Remmina that occurs when it is built
> against GTK3? If so, lets try and address that.

No there is not a specific GTK3 issue of which I am aware.

I understand that eventually GTK 2 support will be unnecessary but we are currently in a transition period where users may want one or the other. They should be free to make the choice for themselves. This is not a choice users get to make in a binary distribution but should certainly have, and I'm sure come to expect, in a source-based distro like Gentoo.

The Remmina team understands that this choice is one that users should be able to make. The team and I put in the time and effort to develop a way to give people that choice and you have taken it away in defiance of the calculated decisions and hard work of others.

I implore you to add a gtk3 flag and stop taking decisions away from users.
Comment 4 Mike Gilbert gentoo-dev 2012-02-20 22:14:47 UTC
(In reply to comment #3)

Ok, I'm willing to play ball. However, the Remmina git master appears to be broken with GTK2 at the moment. See log excerpt below.

Can you get that fixed and report back?

[ 20%] Building C object remmina/CMakeFiles/remmina.dir/src/remmina_main.c.o
cd /tmp/portage/net-misc/remmina-9999/work/remmina-9999_build/remmina && /usr/bin/x86_64-pc-linux-gnu-gcc  -DHAVE_PTHREAD -DHAVE_LIBGCRYPT  -DNDEBUG -O2 -pipe -march=native  -Wall -fPIC -Wno-unused-result -Wno-unused-but-set-variable -Wno-unused-function -I/tmp/portage/net-misc/remmina-9999/work/remmina-9999/. -I/tmp/portage/net-misc/remmina-9999/work/remmina-9999/remmina/include -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/atk-1.0    -o CMakeFiles/remmina.dir/src/remmina_main.c.o -c /tmp/portage/net-misc/remmina-9999/work/remmina-9999/remmina/src/remmina_main.c
/tmp/portage/net-misc/remmina-9999/work/remmina-9999/remmina/src/remmina_main.c: In function ‘remmina_main_init’:
/tmp/portage/net-misc/remmina-9999/work/remmina-9999/remmina/src/remmina_main.c:1124:2: warning: implicit declaration of function ‘gtk_style_context_add_class’ [-Wimplicit-function-declaration]
/tmp/portage/net-misc/remmina-9999/work/remmina-9999/remmina/src/remmina_main.c:1124:2: warning: implicit declaration of function ‘gtk_widget_get_style_context’ [-Wimplicit-function-declaration]
/tmp/portage/net-misc/remmina-9999/work/remmina-9999/remmina/src/remmina_main.c:1124:75: error: ‘GTK_STYLE_CLASS_PRIMARY_TOOLBAR’ undeclared (first use in this function)
/tmp/portage/net-misc/remmina-9999/work/remmina-9999/remmina/src/remmina_main.c:1124:75: note: each undeclared identifier is reported only once for each function it appears in
/tmp/portage/net-misc/remmina-9999/work/remmina-9999/remmina/src/remmina_main.c:1128:2: warning: passing argument 1 of ‘gtk_tool_item_set_is_important’ from incompatible pointer type [enabled by default]
/usr/include/gtk-2.0/gtk/gtktoolitem.h:114:17: note: expected ‘struct GtkToolItem *’ but argument is of type ‘struct GtkWidget *’
/tmp/portage/net-misc/remmina-9999/work/remmina-9999/remmina/src/remmina_main.c:1131:2: warning: passing argument 1 of ‘gtk_tool_item_set_is_important’ from incompatible pointer type [enabled by default]
/usr/include/gtk-2.0/gtk/gtktoolitem.h:114:17: note: expected ‘struct GtkToolItem *’ but argument is of type ‘struct GtkWidget *’
make[2]: *** [remmina/CMakeFiles/remmina.dir/src/remmina_main.c.o] Error 1
make[2]: Leaving directory `/tmp/portage/net-misc/remmina-9999/work/remmina-9999_build'
make[1]: *** [remmina/CMakeFiles/remmina.dir/all] Error 2
make[1]: Leaving directory `/tmp/portage/net-misc/remmina-9999/work/remmina-9999_build'
make: *** [all] Error 2
Comment 5 Mike Gilbert gentoo-dev 2012-02-20 22:31:30 UTC
+  20 Feb 2012; Mike Gilbert <floppym@gentoo.org> metadata.xml,
+  remmina-1.0.0-r1.ebuild, remmina-9999.ebuild:
+  Add gtk3 use flag, bug 404579. Live ebuild is currently broken with USE=-gtk3.
Comment 6 Mike Gilbert gentoo-dev 2012-02-21 01:38:56 UTC
Submitted pull request to fix compile error.

https://github.com/FreeRDP/Remmina/pull/30
Comment 7 Daniel M. Weeks 2012-02-21 04:01:36 UTC
(In reply to comment #6)
> Submitted pull request to fix compile error.
> 
> https://github.com/FreeRDP/Remmina/pull/30

Thanks for sorting this out, Mike.
Comment 8 Mike Gilbert gentoo-dev 2012-02-21 04:13:25 UTC
Merged upstream.
Comment 9 Daniel M. Weeks 2012-02-21 07:26:33 UTC
Created attachment 302673 [details]
ebuild with lib corrections
Comment 10 Daniel M. Weeks 2012-02-21 07:27:45 UTC
Some lib dependencies also change with the GTK version - no need to depend on avahi[gtk3] when using gtk2 (in fact this might prevent running it) and vte:0 is required with gtk+:2. Please see attached ebuild. I'm not sure if the syntax is up to par but it builds correctly.
Comment 11 Mike Gilbert gentoo-dev 2012-02-21 16:01:13 UTC
Thanks.

--- remmina-9999.ebuild 20 Feb 2012 23:59:45 -0000      1.15
+++ remmina-9999.ebuild 21 Feb 2012 15:55:01 -0000
@@ -19,17 +19,21 @@
        net-libs/libvncserver
        x11-libs/libxkbfile
        gnome-keyring? ( gnome-base/libgnome-keyring )
-       avahi? ( net-dns/avahi[gtk3] )
        crypt? ( dev-libs/libgcrypt )
        freerdp? ( >=net-misc/freerdp-1.0 )
        gtk3? ( x11-libs/gtk+:3
+               avahi? ( net-dns/avahi[gtk3] )
                ayatana? ( dev-libs/libappindicator )
+               vte? ( x11-libs/vte:2.90
+       )
+       !gtk3? ( x11-libs/gtk+:2
+               avahi? ( net-dns/avahi[gtk] )
+               vte? ( x11-libs/vte:0 )
        )
-       !gtk3? ( x11-libs/gtk+:2 )
        ssh? ( net-libs/libssh[sftp] )
        telepathy? ( net-libs/telepathy-glib )
        !net-misc/remmina-plugins
-       vte? ( x11-libs/vte:2.90 )"
+"
 DEPEND="${RDEPEND}
        dev-util/intltool
        dev-util/pkgconfig
Comment 12 Samuli Suominen gentoo-dev 2012-03-08 15:17:38 UTC
reopening since applications should always prefer GTK+-3 and there should be no USE flag for it. bug 374057.
Comment 13 Mike Gilbert gentoo-dev 2012-03-08 16:32:40 UTC
Sorry Daniel; I'm not going to fight Samuli on this.

+  08 Mar 2012; Mike Gilbert <floppym@gentoo.org> remmina-1.0.0-r1.ebuild,
+  remmina-9999.ebuild:
+  Remove gtk3 use flag per ssuominen. Bug 404579.
Comment 14 Pacho Ramos gentoo-dev 2012-03-10 13:40:10 UTC
(In reply to comment #13)
> Sorry Daniel; I'm not going to fight Samuli on this.
> 
> +  08 Mar 2012; Mike Gilbert <floppym@gentoo.org> remmina-1.0.0-r1.ebuild,
> +  remmina-9999.ebuild:
> +  Remove gtk3 use flag per ssuominen. Bug 404579.

Samuli and gnome team ;), please see bug 374057 for reasoning
Comment 15 Samuli Suominen gentoo-dev 2012-03-10 13:42:55 UTC
(In reply to comment #14)
> (In reply to comment #13)
> > Sorry Daniel; I'm not going to fight Samuli on this.
> > 
> > +  08 Mar 2012; Mike Gilbert <floppym@gentoo.org> remmina-1.0.0-r1.ebuild,
> > +  remmina-9999.ebuild:
> > +  Remove gtk3 use flag per ssuominen. Bug 404579.
> 
> Samuli and gnome team ;), please see bug 374057 for reasoning

Read Comment #12 (again?)