Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 404399 - dev-lang/ruby-1.8.7_p357 - callback.func:1:7: error: expected identifier or ‘(’ before ‘long’
Summary: dev-lang/ruby-1.8.7_p357 - callback.func:1:7: error: expected identifier or ‘...
Status: RESOLVED DUPLICATE of bug 370413
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 15:19 UTC by Markus Oehme
Modified: 2012-02-19 07:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,39.52 KB, text/plain)
2012-02-18 15:19 UTC, Markus Oehme
Details
emerge --info (info.txt,5.42 KB, text/plain)
2012-02-18 15:19 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Oehme 2012-02-18 15:19:31 UTC
Created attachment 302373 [details]
build log

On my hardened ~amd64 machine with gcc-4.6.2 I see the following build failure for ruby.

x86_64-pc-linux-gnu-gcc -I. -I../.. -I../../. -I../.././ext/dl -DHAVE_DLFCN_H -DHAVE_DLOPEN -DHAVE_DLCLOSE -DHAVE_DLSYM -DHAVE_DLERROR    -I. -fPIC -O2 -pipe -march=native -ggdb -floop-interchange -floop-strip-mine -floop-block -finline-functions -fno-strict-aliasing  -fPIC  -fno-defer-pop -fno-omit-frame-pointer  -c dl.c
In file included from dl.c:104:0:
callback.func:1:1: warning: data definition has no type or storage class [enabled by default]
callback.func:1:7: error: expected identifier or ‘(’ before ‘long’
In file included from dl.c:104:0:
callback.func:78:33: error: expected ‘)’ before ‘(’ token
callback.func:79:3: warning: data definition has no type or storage class [enabled by default]
callback.func:79:24: error: ‘proc’ undeclared here (not in a function)
callback.func:79:39: error: ‘argc’ undeclared here (not in a function)
callback.func:79:45: error: ‘argv’ undeclared here (not in a function)
callback.func:82:1: error: expected identifier or ‘(’ before ‘}’ token
dl.c:106:1: error: expected ‘;’, ‘,’ or ‘)’ before ‘static’
make[1]: *** [dl.o] Error 1
Comment 1 Markus Oehme 2012-02-18 15:19:46 UTC
Created attachment 302375 [details]
emerge --info
Comment 2 Hans de Graaff gentoo-dev 2012-02-19 07:05:14 UTC

*** This bug has been marked as a duplicate of bug 370413 ***