Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 404397 - x11-libs/gtkhotkey - In file included from gtk-hotkey-error.h:26:0, from gtk-hotkey-info.c:20: /usr/include/glib-2.0/glib/gquark.h:28:2: Fehler: #error "Only <glib.h> can be included directly."
Summary: x11-libs/gtkhotkey - In file included from gtk-hotkey-error.h:26:0, from gtk-...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Serkan Kaba (RETIRED)
URL:
Whiteboard:
Keywords:
: 413045 413049 (view as bug list)
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-02-18 15:11 UTC by Aljosha Papsch
Modified: 2012-04-29 15:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge-info,4.69 KB, text/plain)
2012-02-18 15:11 UTC, Aljosha Papsch
Details
build.log for =x11-libs/gtkhotkey-0.2.1 (build.log,14.28 KB, text/plain)
2012-02-18 15:12 UTC, Aljosha Papsch
Details
New build.log (build.log,21.67 KB, text/plain)
2012-02-19 20:43 UTC, Aljosha Papsch
Details
Patch for x11/tomboykeybinder.h (gtkhotkey-tomboykeybinder.patch,315 bytes, patch)
2012-02-19 20:44 UTC, Aljosha Papsch
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aljosha Papsch 2012-02-18 15:11:32 UTC
=x11-libs/gtkhotkey-0.2.1 includes other glib header files, which should not be included. This leads to an error in compile phase, because the glib header files are designed that only <glib.h> can be included directly.

Reproducible: Always

Steps to Reproduce:
1. Try to emerge x11-libs/gtkhotkey
Actual Results:  
Portage will quit with an error:
 * ERROR: x11-libs/gtkhotkey-0.2.1 failed (compile phase):
 *   emake failed
 * 
 * Call stack:
 *          ebuild.sh, line   85:  Called src_compile
 *        environment, line 2177:  Called _eapi2_src_compile
 *   phase-helpers.sh, line  573:  Called die
 * The specific snippet of code:
 *   		emake || die "emake failed"
 * 
 * If you need support, post the output of 'emerge --info =x11-libs/gtkhotkey-0.2.1',
 * the complete build log and the output of 'emerge -pqv =x11-libs/gtkhotkey-0.2.1'.
 * The complete build log is located at '/var/tmp/portage/x11-libs/gtkhotkey-0.2.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/gtkhotkey-0.2.1/temp/environment'.
 * S: '/var/tmp/portage/x11-libs/gtkhotkey-0.2.1/work/gtkhotkey-0.2.1'
Comment 1 Aljosha Papsch 2012-02-18 15:11:56 UTC
Created attachment 302369 [details]
emerge --info
Comment 2 Aljosha Papsch 2012-02-18 15:12:33 UTC
Created attachment 302371 [details]
build.log for =x11-libs/gtkhotkey-0.2.1
Comment 3 Serkan Kaba (RETIRED) gentoo-dev 2012-02-19 11:17:22 UTC
Fixed in cvs. Thanks for reporting.
Comment 4 Aljosha Papsch 2012-02-19 20:42:34 UTC
It seems that there is more invalid inclusion of headers (new build.log attachment). I went through the source files and found it in x11/tomboykeybinder.h. I'm attaching a patch.
Comment 5 Aljosha Papsch 2012-02-19 20:43:06 UTC
Created attachment 302539 [details]
New build.log
Comment 6 Aljosha Papsch 2012-02-19 20:44:00 UTC
Created attachment 302541 [details, diff]
Patch for x11/tomboykeybinder.h
Comment 7 Serkan Kaba (RETIRED) gentoo-dev 2012-02-21 00:34:32 UTC
Done thanks for testing and the patch
Comment 8 Samuli Suominen gentoo-dev 2012-04-22 10:23:06 UTC
*** Bug 413045 has been marked as a duplicate of this bug. ***
Comment 9 Samuli Suominen gentoo-dev 2012-04-22 10:33:51 UTC
*** Bug 413049 has been marked as a duplicate of this bug. ***