Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 401855 - >=x11-libs/qt-webkit-4.8.0 & >=dev-libs/glib-2.31: error: 'union' tag used in naming 'struct _GMutex'
Summary: >=x11-libs/qt-webkit-4.8.0 & >=dev-libs/glib-2.31: error: 'union' tag used in...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Qt Bug Alias
URL: http://codereview.qt-project.org/21292
Whiteboard:
Keywords: PATCH
: 410707 (view as bug list)
Depends on:
Blocks: glib-2.32
  Show dependency tree
 
Reported: 2012-02-01 21:41 UTC by Maciej Piechotka
Modified: 2012-04-04 13:31 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,4.26 KB, text/plain)
2012-02-11 21:35 UTC, Rolf S. Arvidson
Details
failed emerge log (emerge.log,79.01 KB, text/plain)
2012-02-11 21:36 UTC, Rolf S. Arvidson
Details
emended ebuild to include patch (qt-webkit-4.8.0.ebuild,1.87 KB, text/plain)
2012-02-11 21:37 UTC, Rolf S. Arvidson
Details
patch based on https://bugs.webkit.org/show_bug.cgi?id=72085#c6 (qt-webkit-4.8.0-GMutex-fix.patch,561 bytes, patch)
2012-02-11 21:38 UTC, Rolf S. Arvidson
Details | Diff
patch for qt-webkit-4.8 + glib-2.31 (qt-webkit-4.8+glib-2.31.patch,1.72 KB, patch)
2012-04-01 17:46 UTC, Davide Pesavento
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2012-02-01 21:41:14 UTC
x86_64-pc-linux-gnu-g++ -c -O2 -pipe -ggdb -march=native -msahf -mcx16 -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -w -floop-interchange -floop-strip-mine -floop-block -floop-flatten -ftree-loop-linear -ftree-loop-im -ftree-loop-distribution -ftree-loop-distribute-patterns -fsched-pressure -fsched-spec-load -I/usr/include/freetype2 -Wall -Wextra -Wreturn-type -fno-strict-aliasing -Wcast-align -Wchar-subscripts -Wformat-security -Wreturn-type -Wno-unused-parameter -Wno-sign-compare -Wno-switch -Wno-switch-enum -Wundef -Wmissing-noreturn -Winit-self -Wno-c++0x-compat -fno-stack-protector -Wno-c++0x-compat -O3 -pthread -fvisibility=hidden -fvisibility-inlines-hidden -fPIC -D_REENTRANT -DGST_DISABLE_DEPRECATED -DNDEBUG -DBUILDING_QT__=1 -DNDEBUG -DQT_ASCII_CAST_WARNINGS -DENABLE_JIT=1 -DBUILDING_JavaScriptCore -DBUILDING_WTF -DENABLE_GLIB_SUPPORT=1 -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_HAVE_SSE3 -DQT_HAVE_SSSE3 -DQT_HAVE_SSE4_1 -DQT_HAVE_SSE4_2 -DQT_HAVE_AVX -DQT_SHARED -I../../../../../mkspecs/linux-g++ -I. -I../../../../../include/QtCore -I../../../../../include -I. -I../../Source -I../ThirdParty -Iassembler -Ibytecode -Ibytecompiler -Iheap -Idfg -Idebugger -Iinterpreter -Ijit -Iparser -Iprofiler -Iruntime -Iwtf -Iwtf/gobject -I/var/tmp/paludis/x11-libs-qt-webkit-4.8.0/work/qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source/JavaScriptCore/wtf/symbian -Iwtf/unicode -Iyarr -IAPI -IForwardingHeaders -Igenerated -I../../Source -I../../include -I/include/QtWebKit -I/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I.moc/release-static -o .obj/release-static/GOwnPtr.o wtf/gobject/GOwnPtr.cpp
In file included from /usr/include/glib-2.0/glib/gasyncqueue.h:34:0,
                 from /usr/include/glib-2.0/glib.h:34,
                 from /usr/include/glib-2.0/gobject/gbinding.h:30,
                 from /usr/include/glib-2.0/glib-object.h:25,
                 from /usr/include/glib-2.0/gio/gioenums.h:30,
                 from /usr/include/glib-2.0/gio/giotypes.h:30,
                 from /usr/include/glib-2.0/gio/gio.h:28,
                 from wtf/gobject/GOwnPtr.cpp:24:
/usr/include/glib-2.0/glib/gthread.h:51:16: error: 'union' tag used in naming 'struct _GMutex' [-fpermissive]
/usr/include/glib-2.0/glib/gthread.h:58:7: error: 'union' tag used in naming 'struct _GMutex' [-fpermissive]
make: *** [.obj/release-static/GOwnPtr.o] Error 1
make: *** Waiting for unfinished jobs....
/usr/libexec/paludis/utils/emake: emake returned error 2
Comment 1 Jeroen Roovers gentoo-dev 2012-02-02 15:34:44 UTC
1) Please post your `emerge --info' output in a comment.
2) Please attach the entire build log to this bug report.
Comment 2 Flo Gravo 2012-02-02 15:53:46 UTC
Same here.
See: https://bugs.webkit.org/show_bug.cgi?id=72085
Comment 3 Rolf S. Arvidson 2012-02-11 21:32:49 UTC
I have the same error: capture of emerge output (sorry, build.log overwritten) and emerge --info attached; the fix described in https://bugs.webkit.org/show_bug.cgi?id=72085 appears to build correctly; I attach a suggested ebuild + patch on this basis.
Comment 4 Rolf S. Arvidson 2012-02-11 21:35:28 UTC
Created attachment 301601 [details]
emerge --info
Comment 5 Rolf S. Arvidson 2012-02-11 21:36:09 UTC
Created attachment 301603 [details]
failed emerge log
Comment 6 Rolf S. Arvidson 2012-02-11 21:37:06 UTC
Created attachment 301605 [details]
emended ebuild to include patch
Comment 7 Rolf S. Arvidson 2012-02-11 21:38:24 UTC
Created attachment 301607 [details, diff]
patch based on  https://bugs.webkit.org/show_bug.cgi?id=72085#c6
Comment 8 keenblade 2012-02-18 05:26:46 UTC
(In reply to comment #7)
> Created attachment 301607 [details, diff] [details, diff]
> patch based on  https://bugs.webkit.org/show_bug.cgi?id=72085#c6

Thanks, patch works here.
Comment 9 tman 2012-02-18 07:20:55 UTC
it would be nice if this get bump in qt-overlay.

thanks
Comment 10 Markos Chandras (RETIRED) gentoo-dev 2012-02-18 10:33:39 UTC
We will apply it once this patch is accepted upstream. We don't want to divert the Gentoo package from the upstream one
Comment 11 tman 2012-02-23 06:46:06 UTC
i get this error of i am using the aboved ebuild and patch:

ebuild qt-webkit-4.8.9999.ebuild digest
>>> Downloading 'http://distfiles.gentoo.org/distfiles/qt-everywhere-opensource-src-4.8.9999.tar.gz'
--2012-02-23 07:43:27--  http://distfiles.gentoo.org/distfiles/qt-everywhere-opensource-src-4.8.9999.tar.gz
Resolving distfiles.gentoo.org (distfiles.gentoo.org)... 64.50.236.52, 137.226.34.42, 140.211.166.134, ...
Connecting to distfiles.gentoo.org (distfiles.gentoo.org)|64.50.236.52|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2012-02-23 07:43:28 ERROR 404: Not Found.

>>> Downloading 'http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-4.8.9999.tar.gz'
--2012-02-23 07:43:28--  http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-4.8.9999.tar.gz
Resolving get.qt.nokia.com (get.qt.nokia.com)... 87.248.219.170, 87.248.217.102
Connecting to get.qt.nokia.com (get.qt.nokia.com)|87.248.219.170|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2012-02-23 07:43:28 ERROR 404: Not Found.

!!! Couldn't download 'qt-everywhere-opensource-src-4.8.9999.tar.gz'. Aborting.
Comment 12 Markos Chandras (RETIRED) gentoo-dev 2012-02-29 18:30:40 UTC
(In reply to comment #11)
> i get this error of i am using the aboved ebuild and patch:
> 
> ebuild qt-webkit-4.8.9999.ebuild digest
> >>> Downloading 'http://distfiles.gentoo.org/distfiles/qt-everywhere-opensource-src-4.8.9999.tar.gz'
> --2012-02-23 07:43:27-- 
> http://distfiles.gentoo.org/distfiles/qt-everywhere-opensource-src-4.8.9999.
> tar.gz
> Resolving distfiles.gentoo.org (distfiles.gentoo.org)... 64.50.236.52,
> 137.226.34.42, 140.211.166.134, ...
> Connecting to distfiles.gentoo.org
> (distfiles.gentoo.org)|64.50.236.52|:80... connected.
> HTTP request sent, awaiting response... 404 Not Found
> 2012-02-23 07:43:28 ERROR 404: Not Found.
> 
> >>> Downloading 'http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-4.8.9999.tar.gz'
> --2012-02-23 07:43:28-- 
> http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-4.8.9999.tar.
> gz
> Resolving get.qt.nokia.com (get.qt.nokia.com)... 87.248.219.170,
> 87.248.217.102
> Connecting to get.qt.nokia.com (get.qt.nokia.com)|87.248.219.170|:80...
> connected.
> HTTP request sent, awaiting response... 404 Not Found
> 2012-02-23 07:43:28 ERROR 404: Not Found.
> 
> !!! Couldn't download 'qt-everywhere-opensource-src-4.8.9999.tar.gz'.
> Aborting.

why did you name the ebuild 4.8.9999?
Comment 13 tman 2012-02-29 20:04:35 UTC
oh right i have set this patch in the folder of the qt-overlay qt-webkit. this is my fault.

thanks u for the advice
Comment 14 Davide Pesavento gentoo-dev 2012-03-07 22:43:42 UTC
This is relevant too: https://bugs.webkit.org/show_bug.cgi?id=69840
Comment 15 tman 2012-03-09 07:46:44 UTC
hmm i have no clue which versio is now fixed. but 

/3rdparty/webkit/Source/JavaScriptCore/wtf/symbian -Iwtf/unicode -Iyarr -IAPI -IForwardingHeaders -Igenerated -I../../Source -I../../include -I/include/QtWebKit -I/include -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I.moc/release-static -o .obj/release-static/GOwnPtr.o wtf/gobject/GOwnPtr.cpp
In file included from /usr/include/glib-2.0/glib/gasyncqueue.h:34:0,
                 from /usr/include/glib-2.0/glib.h:34,
                 from /usr/include/glib-2.0/gobject/gbinding.h:30,
                 from /usr/include/glib-2.0/glib-object.h:25,
                 from /usr/include/glib-2.0/gio/gioenums.h:30,
                 from /usr/include/glib-2.0/gio/giotypes.h:30,
                 from /usr/include/glib-2.0/gio/gio.h:28,
                 from wtf/gobject/GOwnPtr.cpp:24:
/usr/include/glib-2.0/glib/gthread.h:51:16: error: ‘union’ tag used in naming ‘struct _GMutex’
/usr/include/glib-2.0/glib/gthread.h:58:7: error: ‘union’ tag used in naming ‘struct _GMutex’
make: *** [.obj/release-static/GOwnPtr.o] Error 1
make: *** Waiting for unfinished jobs....
emake failed
 * ERROR: x11-libs/qt-webkit-4.8.0-r1 failed (compile phase):
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line   85:  Called src_compile
Comment 16 Davide Pesavento gentoo-dev 2012-03-09 11:22:36 UTC
I never said this is fixed. In fact, it's still unfixed in upstream git repo (4.8 branch at least)..
Comment 17 Andreas Proteus 2012-03-30 14:07:37 UTC
Same error with qt-webkit-4.8.1
Comment 18 Andreas Proteus 2012-03-30 14:09:40 UTC
I forgot to say I have glib-2.32.0
Comment 19 Andreas Proteus 2012-03-30 17:03:56 UTC
I can report that the patch works for qt-webkit-4.8.1.

Thank you.
Comment 20 Denys Duchier 2012-03-30 22:24:34 UTC
(In reply to comment #19)
> I can report that the patch works for qt-webkit-4.8.1.

so can I
Comment 21 Davide Pesavento gentoo-dev 2012-04-01 17:46:39 UTC
Created attachment 307395 [details, diff]
patch for qt-webkit-4.8 + glib-2.31

Please test this patch.
Comment 22 Andreas Proteus 2012-04-01 21:08:07 UTC
(In reply to comment #21)
> Please test this patch.

This patch works also.
It compiled successfully qt-webkit-4.8.1 + glib-2.32.0
Comment 23 Davide Pesavento gentoo-dev 2012-04-03 22:01:03 UTC
*** Bug 410707 has been marked as a duplicate of this bug. ***
Comment 24 Davide Pesavento gentoo-dev 2012-04-04 13:31:02 UTC
Fixed in CVS. Thank you all!

  04 Apr 2012; Davide Pesavento <pesa@gentoo.org>
  +files/qt-webkit-4.8.1+glib-2.31.patch, qt-webkit-4.8.1.ebuild:
  Fix build with >=dev-libs/glib-2.31 (bug 401855).