Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 401397 - www-servers/nginx: add automatic minification module (jitify)
Summary: www-servers/nginx: add automatic minification module (jitify)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Tiziano Müller
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-29 19:07 UTC by Nemykal
Modified: 2013-10-17 08:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nemykal 2012-01-29 19:07:57 UTC
Hi all,
Recently became aware of this module for stripping whitespace and optimizing html/css/js automatically: http://www.jitify.com/doc/jitify-nginx/

I tried it myself and it's very easy to integrate into nginx. Just one extra ./configure option to point to the jitify dir. So far I haven't noticed any issues; there doesn't appear to be any downside to using this module. It's completely transparent to web applications (e.g. wordpress) because the minification is done by the server just before outputting to the client.

So I'm writing this as a feature request, whether it would be possible to include a USE flag for including jitify support in nginx in Gentoo. Obviously as an optional module, not enabled by default. 


From my experience though, there is a build issue with the latest version of jitify; 0.9.4 simply doesn't compile. However, 0.9.3 works perfectly, which I retrieved at http://www.jitify.com/download/jitify-core-0.9.3.tar.bz2

Thanks

Reproducible: Always
Comment 1 Johan Bergström 2012-01-30 01:36:32 UTC
Sounds cool. I'll try it out and possibly create an ebuild.
Comment 2 Johan Bergström 2013-09-29 13:05:07 UTC
Was meaning to take a second look at this module, but it doesn't seem to have been upgraded for 2 years. Do we want to add additional modules that aren't maintained?
Comment 3 Tiziano Müller gentoo-dev 2013-10-17 08:03:54 UTC
sorry, but we're not going to add dead modules.